You are here

H9 Max Problems - Right Out Of The Box

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

13 posts / 0 new
Last post
bmagsayo
Joined: Jul 22 2020
Posts: 4

H9 Max Problems - Right Out Of The Box

bmagsayo
August 01, 2020 - 08:55 pm

I sent an email to support but maybe I can get an answer sooner here.

I received just yesterday my H9 Max.  I connected the unit in mono and began scrolling through the presets 1-99 and found many of the presets not working or producing the wrong effect.  I sent a video to support with the first 17 presets played.  Below is a list of what was played in the video and the result of each.

 

1. DDLY - OK

2. ECHO - dry

3. SLAP - dry

4. THICK - no signal

5. LESLIE - dry

6. AUTO WAH - incorrect effect

7. EMAJ 3RD+ - incorrect effect

8. SPRING - OK

9. AIRBAG - OK

10. METAL - OK

11. STREETS - OK

12. STORYTELLER - OK

13. BLACKHOLE - OK

14. SHIMMER - OK

15. MODECHOVERB - OK 

16. SPLITTER VERB - OK

17. ELEC12STRING ROO - dry

 

I also played many of the presets in each algorithm through the H9 Control app with the same result.  Some worked correctly, most worked incorrectly, many were dry, and some with no signal.  Even adjusting the parameters and the ribbon thing did not change the sound whatsoever.

 

I tried clearing (pressing Tap switch/Hotknob) and Initializing (Tap switch/Big Knob) to no avail.  I had the unit in the loop, and I tried it in front of the amp too.

 

Does anyone have a fix to this issue, or a link?

 

Thanks in advance.

 

 

 

 

 

nickrose's picture
Eventide Staff
nickrose
Joined: Jan 17 2008
Posts: 4589
nickrose
August 01, 2020 - 08:56 pm

If you are going in and out mono, make sure you are using input 1 and output 1.

 

bmagsayo
Joined: Jul 22 2020
Posts: 4
bmagsayo
August 01, 2020 - 10:43 pm

nickrose wrote:

If you are going in and out mono, make sure you are using input 1 and output 1.

 

Yup, I'm sure of it.  I even tried input 2 and ouput 2.

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 758
bohan
August 02, 2020 - 12:14 am

If you reinstall the latest firmware using the Direct Updater through USB, it should fix this issue.

The Direct Updater is bundled with the H9 Contorl.
Mac: Click Window -> Open Direct Updater in the menu bar
Windows: You can just search "Direct Updater" in your Start menu of find it in the H9 Control folder

bmagsayo
Joined: Jul 22 2020
Posts: 4
bmagsayo
August 02, 2020 - 12:16 pm

bohan wrote:

If you reinstall the latest firmware using the Direct Updater through USB, it should fix this issue.

The Direct Updater is bundled with the H9 Contorl.
Mac: Click Window -> Open Direct Updater in the menu bar
Windows: You can just search "Direct Updater" in your Start menu of find it in the H9 Control folder

Firmware reinstalled... FIXED!!  I didn't check all the presets yet but the first 20 or so are all on point.

Thanks for your help, greatly appreciated.

 

John335
Joined: Mar 25 2008
Posts: 4
John335
August 22, 2020 - 01:33 am

I have that same problem but when I went to update via USB it told me that the H9 could not be updated. I’m wondering if that’s software corruption?

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 758
bohan
August 22, 2020 - 09:30 am

John335 wrote:

I have that same problem but when I went to update via USB it told me that the H9 could not be updated. I’m wondering if that’s software corruption?

Did you use the Direct Updater? Have you tried using H9 Control for updating?

John335
Joined: Mar 25 2008
Posts: 4
John335
August 22, 2020 - 03:37 pm

The fix for me was applying the update (even if you already have that version of software on it), and I also did it via USB and plugged into my computer.          What was interesting is that the first H9 would not update and neither would the second one Sweetwater sent me. But, finally the third one Sweetwater sent updated just fine and then I went back and the other two updated just fine. I have no idea why things went smoothly after the third one updated without a problem. Anyway, the three H9s now sound great and there are no problem with any of them.

TheOldSaltyOne's picture
TheOldSaltyOne
Joined: Sep 9 2020
Posts: 2
TheOldSaltyOne
September 13, 2020 - 03:21 pm

Just had the same problem from a new H9 Max "Dark" Limited Edition. Firmware number was up to date but the pedal had all the same problems.

Tried reboots, resets and nothing changed so today I took a chance after reading the posts and used the 'EVENTIDE DIRECT UPDATER'.

Problem SOLVED!

I was ready to return this newly purchased, new pedal as it was pitiful out of the box!

Thanks guys.

®...

Sp4zRX
Joined: Sep 23 2020
Posts: 1
Sp4zRX
September 24, 2020 - 10:31 pm

THANK YOU THANK YOU THANK YOU!!!

I was having the same issues and the update fixed it.

I want to add that the tuner wasn’t working either. When I would press both buttons to access the tuner, it would say “NO TUNA”.

All good now! Thank you!!!

bmagsayo
Joined: Jul 22 2020
Posts: 4
bmagsayo
September 25, 2020 - 09:48 am

My question is why doesn’t Eventide update their product before shipping or amend their instruction manual as the first thing to do upon receiving item.  Too costly?  Write it on a Post-It and slap it inside the box before wrapping her up.  I won’t judge.

:)

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 758
bohan
September 25, 2020 - 10:38 am

bmagsayo wrote:

My question is why doesn’t Eventide update their product before shipping or amend their instruction manual as the first thing to do upon receiving item.  Too costly?  Write it on a Post-It and slap it inside the box before wrapping her up.  I won’t judge.

Sorry about that. We didn't realize this issue in the beginning. We found this issue about 2 months ago and now we make sure every unit is good when we ship it.

TheOldSaltyOne's picture
TheOldSaltyOne
Joined: Sep 9 2020
Posts: 2
TheOldSaltyOne
September 27, 2020 - 01:04 pm

To all concerned,

Glad there is peace and happiness now! Thanks for responding Eventide and confirming.

Later all,

®...