You are here

Blackhole and Ardour: no go.

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

8 posts / 0 new
Last post
jegelie
Joined: May 10 2018
Posts: 6

Blackhole and Ardour: no go.

May 16, 2018 - 03:00 pm

Hi,

 

I recently bought the Blackhole plugin, it performs magnificent in Apple Mainstage 3.

But when I wanted to use it in my favourite DAW, Ardour, it would not load.

I already informed the tech team of Ardour. The thing is, they need to get to the bottom why exactly this particular plugin will not load. It is not a license (iLok) issue, since other iLok licensed plugins just do load. There is something coded differently than how things are done in other plugins, they presume.

The necessary infos:

Eventide Blackhole 3.1.1 AU and VST plugin does not load in Ardour 5.12.0 (rev 5.12) Intel 64-bit; the Ardour log shows:
[ERROR]: Cannot get I/O configuration info for AU Blackhole (No MIDI)
[ERROR]: Cannot get I/O configuration info for AU Blackhole

The VST loads, but when invoked it throws an error:
[ERROR]: ** ERROR ** VSTFX : /Library/Audio/Plug-Ins/VST/Eventide/Blackhole.vst could not be instantiated :(

Version of Eventide Blackhole 3.1.1, version of Ardour 5.12.0 "Working Backwards" (rev 5.12) Intel 64-bit, version of Mac OS High Sierra 10.13.4 (17E202).

Side note: I can load the AU and VST in Audacity on this same system.

See also: https://community.ardour.org/node/15666 and http://tracker.ardour.org/view.php?id=7621

I really appreciate the help.

Joost.

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 744
May 18, 2018 - 11:25 am

Hi Joost-

I'm sorry to hear that you are having trouble with Blackhole in Ardour. It does sound to be something specific to Ardour, given the plugin loads fine in other hosts.

Unfortunately, we are unable to reproduce this issue here, on multiple systems. I will note that we have tested on macOS 10.12 and 10.13.2 (not 10.13.4), but we are testing with the same version of Ardour and Blackhole.

Have you tried resetting the VST and AU Caches and Blacklists from Ardour? You might also try uninstalling Blackhole, launching/closing Ardour, reinstalling Blackhole, and then opening Ardour again. I have also noticed somewhat flaky behavior loading AU plugins on recent versions of High Sierra, that have been fixed by restarting the computer.

If the problem persists, please email support@eventide.com referencing this issue. If you've been in touch with the Ardour team, please try and put them in touch with us. It will likely be easiest to fix this issue by working with them directly.

-Tom

jegelie
Joined: May 10 2018
Posts: 6
May 19, 2018 - 03:24 am

Hi Tom,

I've been discussing to and fro with Robin Gareus, one of the main developers on Ardour. It seems he can't reproduce the error due to not having the same setup but judging from Ardour's (coded) way of handling plugins it boils down on the same reason the AU does not validate and the VST does not initiate.
 

Some other test from my side showed that the 'auval' tool validates fine (output: https://pastebin.com/0WF0BMHV), that the AU plugin is capable of running in Audacity and the VST freezes Audacity completely without logs or reasons when invoked, and that the AU plugin will not initiate in Garageband where it says it is not licensed and I need an iLok manager on my computer (which I do have, and the plugin is properly licensed).

Also there is this entry over and over in my Console (/Library/Logs/PACEAntiPiracy/Eden/LicenseServices/LicenseD_000000.log):

[ error] TPaceHttpClient::flush() caught a UtilException with this information:

The HTTP server returned an "Bad Gateway" error (status code 502).

There is no timecode on it, so I can't retrieve when this is thrown.

Attachment
jegelie
Joined: May 10 2018
Posts: 6
May 20, 2018 - 09:28 am

Judging from other posts on your forum, GarageBand still remains a problem for Eventide Blackhole, and thus is not a proper test for validating AU.
 

I succesfully loaded the VST in MuTools MuLab Free (http://www.mutools.com/mulab-downloads.html), and the AU in JU-X Hosting AU application (http://ju-x.com/hostingau.html).

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 744
May 21, 2018 - 01:25 pm

jegelie wrote:

Hi Tom,

I've been discussing to and fro with Robin Gareus, one of the main developers on Ardour. It seems he can't reproduce the error due to not having the same setup but judging from Ardour's (coded) way of handling plugins it boils down on the same reason the AU does not validate and the VST does not initiate.
 

Some other test from my side showed that the 'auval' tool validates fine (output: https://pastebin.com/0WF0BMHV), that the AU plugin is capable of running in Audacity and the VST freezes Audacity completely without logs or reasons when invoked, and that the AU plugin will not initiate in Garageband where it says it is not licensed and I need an iLok manager on my computer (which I do have, and the plugin is properly licensed).

Also there is this entry over and over in my Console (/Library/Logs/PACEAntiPiracy/Eden/LicenseServices/LicenseD_000000.log):

[ error] TPaceHttpClient::flush() caught a UtilException with this information:
The HTTP server returned an "Bad Gateway" error (status code 502).
There is no timecode on it, so I can't retrieve when this is thrown.

Hi Joost-

Thanks for the additional info. Based on the behavior you describe (especially in GarageBand), I do wonder if the licensing is being finicky. I think we should eliminate that possibility first, since we have occasionally seen similar issues that can be dependent on when/how the DAW loads plugins, and the licensing being tripped up somehow. Can you try these steps, and let me know if it helps the issue?

  1. Install the latest version of iLok License manager (www.ilok.com)
  2. In iLok License Manager, go to Preferences->Licenses and select "Remove account data saved on computer"
  3. Sign out of your account, and then close iLok License Manager
  4. Relaunch iLok License Manager, and log in
  5. Right click on the location of the Blackhole license (e.g. iLok or host machine), and click "Synchronize"
  6. Reopen Ardour, or another DAW you've been having probems with, and try to load Blackhole
-Tom
jegelie
Joined: May 10 2018
Posts: 6
May 21, 2018 - 02:47 pm

Hi Tom,

Tried all stipulated steps.

  1. I installed a freshly downloaded iLok License Manager. The installer was an exact MD5 duplicate of the installer I used. Nevertheless, I installed it just to be sure.
  2.  done
  3.  done
  4.  done
  5. Right click on the host machine location gave a sub menu where "Synchronize" was greyed out. I guess the software judged the license info as synchronized already. I don't have the hardware iLok; soft license only - actually, Blackhole is my first plugin I bought with such copy protection. Rest is all free, open source or in-package stuff.
  6. Ardour still doesn't load the AU plugins (Blackhole and Blackhole No Midi); also it throws the error on initiating the VST Blackhole, both as described in the OP.

I also tried this: deactivated the license on my computer, launched Ardour (scans for AU and VST automatically on launch), walked throught the activation steps that the scan initiated on the Blackhole plugin. It gave the same errors. I then cleared the plugin caches and blacklists, and rescanned. Again, same errors.

Then I removed the VST to see if it interfered with the AU; same errors.
I also tried with other sample rate settings on the Mac, and without attached hardwares with just built-in microphone input and laptop speaker output. Also, same errors...

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 744
May 21, 2018 - 03:42 pm

Hey Joost-

Just saw you emailed support. I will contact you there.

jegelie
Joined: May 10 2018
Posts: 6
November 03, 2018 - 03:50 pm

Solved!

In Ardour, go to the menu Ardour > Preferences, then General > Translation. Turn off “Use translations”. Restart. The AU as well as the VST load fine.

 

I’m on a Dutch MacOS, seems there is no translation for the Ardour interface in Dutch yet. When “Use translations” is on, Ardour presents itself in English nonetheless. It is a good workaround for me since I’m only used to the English interface.