You are here

Blackhole and Elevate plugins not showing in Logic, but they do in FCP (MacMini M1)

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

3 posts / 0 new
Last post
Joel Endicott
Joined: Oct 31 2017
Posts: 2

Blackhole and Elevate plugins not showing in Logic, but they do in FCP (MacMini M1)

Joel Endicott
February 19, 2021 - 01:25 pm

I've got a new Mac mini (Apple silicon M1) and have installed Blackhole and the Elevate bundle.  They show up as validated in the plugin manager in Logic but do not show up in the channel strips.  I've tried booting Logic in both Rosetta and not Rosetta but no luck.  I've even uninstalled/reinstalled Logic, and did the same with the plugins.  I deleted the AU cache files, etc.

These plugins do show up and function in Final Cut Pro, so I can't figure out why they are no where to be found in Logic.

Thanks for any help you can give!

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 1049
tlongabaugh
February 22, 2021 - 04:30 pm

Hey, can you try the following steps and let us know if they resolve your issue?

  1. Close Logic Pro X
  2. Make sure Finder is the active application
  3. While holding the Option key, click on the Go menu at the top of your screen and select Library
  4. Delete the following files from your User Library, if they are present:
    1. ~/Library/Caches/com.apple.audiounits.cache
    2. The contents of ~/Library/Caches/AudioUnitCache/
    3. ~/Library/Preferences/com.apple.audio.InfoHelper.plist
    4. ~/Library/Preferences/com.apple.audio.SandboxHelper.plist
  5. Then, open a Terminal window (Applications -> Utilities -> Terminal), and enter the following commands (type each command and press "Enter" afterwards)
    1. killall -9 cfprefsd
    2. killall -9 AudioComponentRegistrar
  6. Restart Logic Pro X
Joel Endicott
Joined: Oct 31 2017
Posts: 2
Joel Endicott
February 22, 2021 - 08:28 pm

tlongabaugh wrote:
  1. Then, open a Terminal window (Applications -> Utilities -> Terminal), and enter the following commands (type each command and press "Enter" afterwards)
    1. killall -9 cfprefsd
    2. killall -9 AudioComponentRegistrar
  2. Restart Logic Pro X

That fixed it!  My Eventide plugins are now showing up in Logic.  (I had previously deleted caches and preferences but had not done the Terminal command.)

Thank you very much!