You are here

Blackhole crashes Cubase 10 and gets blacklisted

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

44 posts / 0 new
Last post
hcsametzki
Joined: Apr 13 2019
Posts: 6

Blackhole crashes Cubase 10 and gets blacklisted

April 14, 2019 - 01:00 pm

Hi,

I bought Blackhole yesterday and installed it on my desktop-pc (i7-6700, 32GB) and on my Laptop (i5-7200U, 8GB). The OS, DAW etc. on

both systems are identical. Windows 10 (v1809), Cubase Pro 10 (v10.0.15), iLok (v5.0.3), WaveLab 6. On my desktop-pc everything works fine.

The 64bit-version of the plugin works with Cubase and the 32bit-version works with my old WaveLab. On my Laptop Cubase crashes without

an error-message when starting the first time with Blackhole installed. Cubase then blacklists the plugin. When I try to reactivate it in the plugin-manager

Cubase crashes again. The 32bit-version works with WaveLab on the Laptop. It's only the 64bit-version in Cubase which causes trouble.

The exact same thing happens with my Eventide UltraChannel-plugin. I tried to deinstall and reinstall the plugins, tried to deinstall and reinstall the

iLok-software, tried to update the c++ redistributable, tried the legacy iLok-software, tried to copy the working .dll-files from my desktop-pc...

Nothing helped. It is possible to use the 32bit-version with jbridge in Cubase but that is only a workaround...

I hope someone can help me to solve this problem.

Thanks

Hans-Christian

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 788
April 15, 2019 - 04:51 pm

Hey Hans-Christian-

Sorry to hear about the issue. I've been able to confirm that Blackhole runs fine inside of Cubase 10 on my Win10 machine here. I've found that Cubase can be very finicky when it comes to fixing these blacklist issues. What I'd do is try the following, I've had success doing this in the past (albeit with Cubase 9):

  1. Uninstall Blackhole: Control Panel -> Uninstall a program
  2. Open Cubase, reset the blacklist, and rescan all of your plugins. Then close Cubase.
  3. In iLok License Manager, deactivate the Blackhole license, then reactivate it again.
  4. Reinstall Blackhole
  5. Open Cubase, and ensure that you have the 64-bit install location listed in the VST Locations folder.
  6. Rescan your plugins if needed.

Let me know if the issue still persists.

-Tom

hcsametzki
Joined: Apr 13 2019
Posts: 6
April 16, 2019 - 07:33 am

Hey Tom,

thanks for your help. tried it exactly as you suggested. But it didn't solve the problem. The first time I started Cubase after the procedure, I got a message that told me that Blackhole is blacklisted. When i tried to reactivate Blackhole in the pluginmanager, Cubase crashes without an error message. Same happens again with the UltraChannel. Again the 32bit-version of Blackhole seems to work fine in my old WaveLab and in Cubase using Jbridge... Also I'm using SlateDrums5 which also uses the software iLok-licenser (license on HD - not on an iLok) and there is no problem. Strange...

Hans-Christian

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 788
April 16, 2019 - 03:44 pm

Hey,

If you navigate to C:\Users\{{USERNAME}}\Documents\Steinberg\CrashDumps, are there any error logs there? If so, please zip them and attach to a post here.

Did you always have these problems with UltraChannel, or did they only start occurring recently?

Also please send me your iLok account name.

One last thing, is you could try running the following two redistributable packages: https://www.microsoft.com/en-us/download/details.aspx?id=52685. I'd like to rule that out as the issue.

-Tom

hcsametzki
Joined: Apr 13 2019
Posts: 6
April 17, 2019 - 01:18 pm

Hey Tom,

I really don't know, if the problem with UltraChannel existed before. I got it long time ago for free and didn't use it very often. I

think it wasn't installed on my laptop before.

I tried to install the two redistributable packages. I got an error message saying that I can't install them because I already installed

newer and better versions of it...

Also there are no error or crash logs in the crashdumps-folder. (only older Cubase9 logs...) I crashed Cubase a few times by reactivating

the plugins but Cubase didn't write an error log... It didn't matter if I loaded a project before or not.

My iLok-Account-Name is hcsametzki

Thanks for your patience

Hans-Christian

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 788
April 17, 2019 - 03:52 pm

Ok. Please email support@eventide.com referencing this post. We'll need to dig in a bit more.

mhazdra
Joined: May 25 2017
Posts: 1
May 16, 2019 - 05:48 pm

Mine doesn't blacklist. It just crashes

Cubase 10 Pro 10.0.20
Windows 10

When removing or changing any VST from any Pre Fader Insert slot in master bus (Stereo Out)  Cubase crashes.
Reproducable on same project and on most projects.
Only happens with  BlackHole VST. (SP 2016 Reverb is fine
Does not happen in Cubase 9.5 Pro

Musicmould
Joined: Dec 12 2016
Posts: 1
July 06, 2019 - 11:39 am

I'm on Mac and Blackhole all of a sudden makes Cubase 10.0.30 beachball forever.

If I remove it from the VST library and restart - all is dandy.

When I put it back - beach ball party.

It works in new projects but once I get a bit into it, beach ball again.

Could it be a memory thing or what?

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 788
July 08, 2019 - 11:11 am

Musicmould wrote:

I'm on Mac and Blackhole all of a sudden makes Cubase 10.0.30 beachball forever.

If I remove it from the VST library and restart - all is dandy.

When I put it back - beach ball party.

It works in new projects but once I get a bit into it, beach ball again.

Could it be a memory thing or what?

Hi-

Did you recently update your software - Blackhole, Cubase, iLok License Manager, or OS? That would help us pinpoint why it may have stopped working.

Please confirm you are using the latest Blackhole and iLok License Manager (www.ilok.com). That usually solves most of these problems.

Lastly, what version of macOS are you on?

-Tom

hcsametzki
Joined: Apr 13 2019
Posts: 6
July 09, 2019 - 01:54 pm

Hi, my problem was solved by running Cubase 10 (on Windows...) as an administrator. I don't know, if there

is a similar thing on Mac OS. But I don't think so. But maybe that helps...

AndrewLMacaulay
Joined: Oct 25 2017
Posts: 5
August 29, 2019 - 04:10 am

Having the same issue, but with pretty much everything Eventide! All of the Eventide plugins get blacklisted when first scanned by Cubase (Pro 10.0.30) and, if forced to be accepted, both Blackhold and E3000 Factory cause Cubase to crash!

If I run Cubase as administrator (not something I should need to do in 2019) forcing a scan of the plugins, then it seems to fix this problem, but I don't know what other issues (or risks) this may introduce. However, this does seem to then allow Cubase to work running normally - so maybe a work around until Eventide fix this issue.

 

Logsplitter
Joined: May 20 2019
Posts: 6
October 07, 2019 - 10:37 am

Same problem here. I can reactivate the blacklisted Eventide plugins, but was wondering if there is a solution to this? When the plug in is in the blacklist column it is listed as VST2, and when reactivated it shows up red, but is listed as vst2.4.

hcsametzki
Joined: Apr 13 2019
Posts: 6
October 08, 2019 - 07:48 am

Hi, running Cubase as an administrator ssems to do the trick if you use windows.

AndrewLMacaulay
Joined: Oct 25 2017
Posts: 5
October 08, 2019 - 08:12 am

hcsametzki wrote:

Hi, running Cubase as an administrator ssems to do the trick if you use windows.

So, over 12 years after UAC was introduced on Windows Vista, Eventide still have plugins that are effectively requiring you to bypass this critical security measure.

Given that Apple have now introduced a UAC-like behaviour to improve their security https://mspoweruser.com/apple-embraces-windows-uac-prompts-after-a-decad... maybe Eventide can get around to fixing this issue?

Logsplitter
Joined: May 20 2019
Posts: 6
October 08, 2019 - 11:29 am

I tried running as admin, and the plug ins get blacklisted anyway. I've tried all kinds of ways of installing them, and actually I have had random sucess, as a couple of the plug ins (Blackhole and SP2016) installed finally without being blacklisted - but I can't find any reason why they did, as I tried replicating the process with other plugs with no success. If I could just trick the Cubase sanner (Sentinel) from checking them the first time, they'd probably be ok after that. Rescanning all plug ins (while cubase is running), doesn't seem to kick the Blackhole and sp2016 back into the blacklist (as those two were blacklisted initially I believe, and snuck in later somehow...).

Jed

 

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 788
October 11, 2019 - 06:51 pm

Logsplitter wrote:

I tried running as admin, and the plug ins get blacklisted anyway. I've tried all kinds of ways of installing them, and actually I have had random sucess, as a couple of the plug ins (Blackhole and SP2016) installed finally without being blacklisted - but I can't find any reason why they did, as I tried replicating the process with other plugs with no success. If I could just trick the Cubase sanner (Sentinel) from checking them the first time, they'd probably be ok after that. Rescanning all plug ins (while cubase is running), doesn't seem to kick the Blackhole and sp2016 back into the blacklist (as those two were blacklisted initially I believe, and snuck in later somehow...).

Jed

Hey Jed-

I've been able to reproduce this error here, and am looking into a fix. Do the plugins work if you "Reactivate" them off of the blacklist?

-Tom

Logsplitter
Joined: May 20 2019
Posts: 6
October 11, 2019 - 08:31 pm

Hi Tom,

Yep, I can reactivate the plugin in Cubase and it shows up in the regular Cubase plugin list (in red). I tried the plugin (Quadravox) and it processed audio. The time I tried to restart Cubase (with the reactivated "red" plugin) it crashed, so I uninstalled the plug in again. Interesting note, when the plugin was in the blacklist is shows "VST2" but when reactivated and in the normal list, it shows as "VST2.4". Both were listed as 64 bit, ( I only installed the 64bit version of the plug.)

Here's a few other details that I passed along to Jerome (at Eventide) as well... 

- I tried disabling avast antivirus during the plug in installation (and running of Cubase) and I restarted the computer after installation.
- I tried installing just the 64 bit version only, and also, both 32 and 64 bit versions.

Neither of those helped.

-Running as Administrator, or running the plugin install (or Cubase) in "windows 8 compatability mode" didn't help.

My previous computer (that I'm retiring, and which all Eventide plug ins installed and worked just find back late-summer) was running Windows 10 Pro (version 1903) on a Lenovo Twist laptop. My new computer is a Power Spec (i7-8700) Windows Pro 10 version 1809 (completely updated Windows, ilok, cubase, and plugin downloads). I later updated windows on the new pc to the same version (1903) as my old computer (which was not having blacklist problems) but it didn’t help.

I checked my Microsoft Visual C++ Redistributable Packages, and both computers had versions from 2017, 2013, 2012... The newest 2017 package (on both computers) is version 2017 (14.16.27027.1), and thus when I tried to install the package you mentioned earlier in the post, it wouldn't allow the older version to be installed.

Good luck in your digging.

-Jed

mat herbert
Joined: Oct 20 2015
Posts: 12
October 15, 2019 - 04:05 pm

HI

 

Another user with Cubase blacklisting ALL of Anthology XI here.

If i reactivate the plugins in Cubase they seem to work fine but i will experience a crash on quitting cubase if they are installed and have been reactivated in the plugin manager.

Looking at the Win 10 event manager gives the faulting module path as ucrtbase.dll.

If i uninstall the Eventide plugins then Cubase will quit without error.

Hopefully you guys can come up with a fix for this fairly soon :D

wwwFINKcz
Joined: Oct 7 2018
Posts: 2
October 15, 2019 - 11:07 pm

mat herbert wrote:

Hi... the same problem here. Eventide plugins crashes my Nuendo10

after I run it as an administrator, it dissapears, but it bring another problems to other plugins. Please guy, solve that issue!! Thx

 

Another user with Cubase blacklisting ALL of Anthology XI here.

If i reactivate the plugins in Cubase they seem to work fine but i will experience a crash on quitting cubase if they are installed and have been reactivated in the plugin manager.

Looking at the Win 10 event manager gives the faulting module path as ucrtbase.dll.

If i uninstall the Eventide plugins then Cubase will quit without error.

Hopefully you guys can come up with a fix for this fairly soon :D

wwwFINKcz
Joined: Oct 7 2018
Posts: 2
October 15, 2019 - 11:11 pm

The same here. Eventide (esp. Phaser) crashes my Nuendo10

only running it as an admin brings eventide plugins to work. But this bring problem to another plugins (running it as an admin)

thx for solving that. And please, make all plugins HiDPI.. thx a lot.

mat herbert
Joined: Oct 20 2015
Posts: 12
October 16, 2019 - 12:01 pm

tlongabaugh wrote:

Hey Jed-

I've been able to reproduce this error here, and am looking into a fix. Do the plugins work if you "Reactivate" them off of the blacklist?

-Tom

 

Hi Tom

 

It might be worth you contacting Fabio Bartolini at Steinberg because i know he's investigating these ucrtbase crashes for the past year now and appears to be quite the expert!

Logsplitter
Joined: May 20 2019
Posts: 6
October 17, 2019 - 06:48 pm

Eventide just tweaked and updated the plug-in installers (due to new Window or Ilok issues?), and problem solved. Thanks for the help Eventide. 

mat herbert
Joined: Oct 20 2015
Posts: 12
October 18, 2019 - 08:33 am

Logsplitter wrote:

Eventide just tweaked and updated the plug-in installers (due to new Window or Ilok issues?), and problem solved. Thanks for the help Eventide. 

Just checked for an updated Anthology XI installer and it's still 2.2.4 which is problematic on my system.

AndrewLMacaulay
Joined: Oct 25 2017
Posts: 5
October 18, 2019 - 08:41 am

Logsplitter wrote:

Eventide just tweaked and updated the plug-in installers (due to new Window or Ilok issues?), and problem solved. Thanks for the help Eventide. 

Are  these available for download yet? Looked on my account and seems that last updates (for some) was Sept 11. And is it for all their plugins? I have Elevate Mastering Bundle, H3000 Factory Native, Instant Flanger Native, Instant Phaser Native, UltraChannel Native and Blackhole 

Logsplitter
Joined: May 20 2019
Posts: 6
October 18, 2019 - 06:38 pm

I'll email them to ask them to post them on the download page...

Logsplitter
Joined: May 20 2019
Posts: 6
October 18, 2019 - 06:39 pm

.. Also note, that the problem may have been solved for Cubase, but the other DAW issues are in the works??

siraltus
Joined: Sep 11 2009
Posts: 16
October 20, 2019 - 09:40 am

Same issue here... Cubase Pro 10.0.40.... ALL of my Eventide plugins are blacklisted - Anthology XI, Room 2016, Newfangled bundle. Running latest installers downloaded yesterday.

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 788
October 21, 2019 - 11:12 am

Hello all - we have a workaround for the Cubase issue, which was sent out late last week to users who had contacted support with this issue, in order to verify the fix. We will be updating the installers on the website shortly.

-Tom

mat herbert
Joined: Oct 20 2015
Posts: 12
October 21, 2019 - 11:20 am

tlongabaugh wrote:

Hello all - we have a workaround for the Cubase issue, which was sent out late last week to users who had contacted support with this issue, in order to verify the fix. We will be updating the installers on the website shortly.

-Tom

 

That's great to hear Tom, I'm REALLY missing my Eventide plugs right now.... fingers crossed this sorts it!

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 788
October 21, 2019 - 05:05 pm

We just updated all Windows installers. Please give them a try and let me know if they don't solve your issue.

AndrewLMacaulay
Joined: Oct 25 2017
Posts: 5
October 21, 2019 - 06:13 pm

tlongabaugh wrote:

We just updated all Windows installers. Please give them a try and let me know if they don't solve your issue.

I've just downloaded the updated installers for my plugins (UltraChannel, Instant Flanger, Instant Phaser, H3000 Factory, BlackHole and NewFangled Elevated; rescanned all plugins and all now recognised and NOT blacklsted :-) ....

Thank you for sorting this!

siraltus
Joined: Sep 11 2009
Posts: 16
October 21, 2019 - 08:23 pm

Just downloaded the new installers. All of Anthology XI and 2016 Stereo Room are no longer blacklisted, however all plugins in my Elevate Mastering Bundle are still blacklisted. The Elevate Mastering Bundle installer in my account doesn't seem to have been updated, as it still shows a "July 31, 2019" date. Can you please update this installer as well?

siraltus
Joined: Sep 11 2009
Posts: 16
October 21, 2019 - 10:34 pm

tlongabaugh wrote:

We just updated all Windows installers. Please give them a try and let me know if they don't solve your issue.

 

tlongabaugh wrote:

We just updated all Windows installers. Please give them a try and let me know if they don't solve your issue.

The Elevated Mastering Bundle plugins are still blacklisted on my system. The installer visible in my account has not been updated, still showing the date of July 31, 2019.

AndrewLMacaulay
Joined: Oct 25 2017
Posts: 5
October 22, 2019 - 07:58 am

[/quote]

The Elevated Mastering Bundle plugins are still blacklisted on my system. The installer visible in my account has not been updated, still showing the date of July 31, 2019.

[/quote]

The Elevate Bundle worked fine for me (there was a later installer provided on my account).

mat herbert
Joined: Oct 20 2015
Posts: 12
October 22, 2019 - 09:48 am

Just installed here, Anthology XI and SP2016 and ALL passed the Cubase plugin check...

No crash on exit either!

Nice, quick work Eventide! thanks yes

siraltus
Joined: Sep 11 2009
Posts: 16
October 22, 2019 - 11:46 am
AndrewLMacaulay wrote:

The Elevate Bundle worked fine for me (there was a later installer provided on my account).

My account still shows Windows installer version 1.5.12 dated July 31, 2019 for the Elevate Bundle.

Can someone from Eventide fix this please?

tlongabaugh's picture
Eventide Staff
tlongabaugh
Joined: May 29 2014
Posts: 788
October 22, 2019 - 12:30 pm

Because Elevate Bundle is a 3rd party bundle, it's up to Newfangled Audio to update. I'll ping them about it.

DGillespie's picture
Eventide Staff
DGillespie
Joined: Jan 29 2008
Posts: 979
October 22, 2019 - 01:58 pm

siraltus wrote:
AndrewLMacaulay wrote:

The Elevate Bundle worked fine for me (there was a later installer provided on my account).

My account still shows Windows installer version 1.5.12 dated July 31, 2019 for the Elevate Bundle. Can someone from Eventide fix this please?

Hi Guys, I knew Tom was working on an issue with PACE, but didn't realize it was a problem for Newfangled Audio users until just now.  It's going to take me a couple days to turn a build around.

Dan

siraltus
Joined: Sep 11 2009
Posts: 16
October 28, 2019 - 03:51 pm

DGillespie wrote:

Hi Guys, I knew Tom was working on an issue with PACE, but didn't realize it was a problem for Newfangled Audio users until just now.  It's going to take me a couple days to turn a build around.

Dan

 

Hi Dan, any news on a fixed build of Elevate? Thanks!

siraltus
Joined: Sep 11 2009
Posts: 16
November 01, 2019 - 08:05 am

Any news on Elevate?

siraltus
Joined: Sep 11 2009
Posts: 16
November 01, 2019 - 11:03 am

I just saw there's a new Windows installer for Elevate. Installed and the plugins are no longer blacklisted. Thank you!

DGillespie's picture
Eventide Staff
DGillespie
Joined: Jan 29 2008
Posts: 979
November 01, 2019 - 12:35 pm

siraltus wrote:

I just saw there's a new Windows installer for Elevate. Installed and the plugins are no longer blacklisted. Thank you!

I was just coming here to let you know and you beat me to it.  Sorry for the delay,

Dan

neilwilkes
Joined: Apr 26 2012
Posts: 152
November 07, 2019 - 11:23 am

There is also a new iLOK/PACE software update that fixes the PACE 5.1 blacklisting at random issue too.

This had been, er, bugging me for a while now & it seemed to happen sometimes but not all the time & it turned out to be a PACE bug. The software update (launch the iLOK manager and it should be offered) fixes this - and you don't even need to restart after installing it either.

Happy Days!

siraltus
Joined: Sep 11 2009
Posts: 16
November 07, 2019 - 11:31 am

neilwilkes wrote:

There is also a new iLOK/PACE software update that fixes the PACE 5.1 blacklisting at random issue too.

This had been, er, bugging me for a while now & it seemed to happen sometimes but not all the time & it turned out to be a PACE bug. The software update (launch the iLOK manager and it should be offered) fixes this - and you don't even need to restart after installing it either.

Happy Days!

 

Yup! SoundToys 5.3.1 and Xils StiX had the blacklisting problem, too, and the 5.1.1 iLok update fixed it for me.