You are here

Elevate Bundle Crossgrade from Saturate (latency problems) under LMMS

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

2 posts / 0 new
Last post
Qarlos
Joined: Apr 14 2019
Posts: 1

Elevate Bundle Crossgrade from Saturate (latency problems) under LMMS

Qarlos
January 01, 2021 - 01:09 pm

I have just installed and authorized my crossgrade to Elevate Bundle from Saturate. But just right now i am trying that under LMMS and whenever i open one instance of EQuivocate, Punctuate, Saturate or Elevate, i experience a DELAY from that plugins being active. Priorly i didn´t have ever problems with Eventide plugins, not even with Saturate when i bought recently weeks ago. Why am i experiencing that kind of issues? Thanks.

DGillespie's picture
Eventide Staff
DGillespie
Joined: Jan 29 2008
Posts: 1020
DGillespie
January 04, 2021 - 01:16 pm

Qarlos wrote:

I have just installed and authorized my crossgrade to Elevate Bundle from Saturate. But just right now i am trying that under LMMS and whenever i open one instance of EQuivocate, Punctuate, Saturate or Elevate, i experience a DELAY from that plugins being active. Priorly i didn´t have ever problems with Eventide plugins, not even with Saturate when i bought recently weeks ago. Why am i experiencing that kind of issues? Thanks.

 

Hi Qarlos,

Elevate, EQuivocate, and Punctuate are all primarily mastering plug-ins and have a lot of latency built in because of their linear phase filter bank.  Unfortunately, there's no way around this.  Saturate has latency, as well, though not as much.

 

Dan