You are here

H3000 Factory Native - soft key names not restored when re-opening session

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

10 posts / 0 new
Last post
danatkorg
Joined: May 28 2008
Posts: 7

H3000 Factory Native - soft key names not restored when re-opening session

danatkorg
January 09, 2013 - 11:15 pm

Custom soft key names appear as expected when selecting presets, but are not restored when re-opening a session containing H3000 Factory instances; instead, they revert to the default names (Soft Key 1-4). Is anyone else seeing this?

Using:

H3000 Factory Native AU 2.0.5

DP 8.0.1

Both OS X 10.7.5 and 10.8.2

nhamiel
Joined: Nov 19 2012
Posts: 1
nhamiel
January 16, 2013 - 01:22 pm

It's really worse than just the custom names not reappearing. The settings don't fully initialize back either, or at least they don't in Logic 9.x. For example loading the Micro Pitchshift preset and loading it on a track everything is fine. Closing the session and reopening it the audio with the plugin on it will actually be delayed. It really makes the plugin unusable in Logic at the moment. 

ameyrairikar
Joined: May 26 2010
Posts: 37
ameyrairikar
January 21, 2013 - 03:18 pm

Hi

There is an active issue with the Softkey names not being restored on session reload. We are looking to getting it fixed for the next release of factory.

nhamiel: What issue are you noticing with the audio on reopening a session ? Is there a change in the sound of the preset ?

Thanks

Sincerely

Amey Rairikar

danatkorg
Joined: May 28 2008
Posts: 7
danatkorg
April 07, 2013 - 07:17 pm

Any progress on this? These names are a huge part of the UI, and their absence makes working with the plug-in a pain.

danatkorg
Joined: May 28 2008
Posts: 7
danatkorg
June 05, 2013 - 01:47 am

It's been another two months - any progress?

DGillespie's picture
Eventide Staff
DGillespie
Joined: Jan 29 2008
Posts: 984
DGillespie
July 10, 2013 - 01:29 pm

Hi danatkorg,

I understand that the issue with the softkey names is frustrating.  The problem is that the names aren't being saved with the session state, and it's not clear how to fix this without breaking compatibility with existing sessions, which is not something we want to risk lightly.  I'm hoping to address this with a release that includes AAX 64 bit, but I don't know when that will be.

However, there should be no sound differences, or problems with any parameters if you're using version 2.0.6.  If you do find any, please let me know.  http://www.eventide.com/~/media/Files/Audio%20Support/Plug%20Ins/Eventide%20Users/209179_H3kFactAU206osx.ashx

Thanks,
Dan 

danatkorg
Joined: May 28 2008
Posts: 7
danatkorg
March 29, 2014 - 03:42 pm

I just tried the latest AAX version, but this still appears to be broken. What is your current plan to address this? After over a year of waiting, it's disappointing to me that this feature - which appears to be central to the usability of the plug-in - is still not functioning correctly. I have a small library of presets that I'd like to release, but I've been holding off until this name issue is sorted out.

DGillespie's picture
Eventide Staff
DGillespie
Joined: Jan 29 2008
Posts: 984
DGillespie
March 29, 2014 - 06:32 pm

HI danatkorg,

Not to repeat myself for your sake, but just for anyone following this thread. 

We have a ground up re-write in progress that should fix this, and a couple other open issues with Factory.  The re-write is actually pretty close, but will still take a bit longer.  In the mean time, AAX64 and Mac VST support were ready and we couldn't, in good conscience, hold them up to wait for these issues, as they had broken compatibility for a lot of people.  

Actually, to be clearer, I had intended for the re-write to be the AAX64 release, but it was taking long enough that we had to bite the bullet and add AAX64 for the current build.  I know the situation hasn't been ideal, but we are working pretty furiously to fix it, and we're just about there.

Dan

danatkorg
Joined: May 28 2008
Posts: 7
danatkorg
March 29, 2014 - 06:46 pm

Hi Dan,

Thanks for your reply, and for clarifying the intent of this release. I had incorrectly assumed that the 3/28 release *was* the big rewrite. I completely understand your decision to release AAX64 and VST as soon as possible, and I'm glad to hear that more development is still in the works.

- (another) Dan

nycjimmy
Joined: Mar 31 2014
Posts: 2
nycjimmy
March 31, 2014 - 11:42 am

Glad to hear about the AAX64 release, but feeling a bit like an idiot for paying $349 a week before it goes on sale for $199. Sad