You are here

UltraChannel and Studio One 2 64 bit

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

6 posts / 0 new
Last post
wheelman0130
Joined: Feb 4 2014
Posts: 6

UltraChannel and Studio One 2 64 bit

wheelman0130
June 10, 2014 - 05:58 pm

Hey Dan,

Thank you for sharing a new plugin with us all, very cool move. I am however, having issues. I installed the plugin and it ran flawlessly for one instantiation on my 64 bit version of Studio One 2. Then, although i could use it on other songs, some of the controls stopped working. In particular the delay and pitch settings. It seems like my original configuration is fixed in memory and can be turned on and off with the pitch in/out button. The mix knob in Pitch remains functional but now seems to control both pitch and delay saturation. This is the same with subsequent instantiations.

Prior to this writing i did discover that you are only supporting 32 bit for my DAW at this time. I presume this may be causing the issues described above. So now, I have two questions:

1) Are you going to support the 64 bit version of Studio One 2 at some future time?

2) What is the uninstall method? (The plugin does not appear in programs and features in Win 7 Pro)

Also, for the record, I was able to add a very nice room sound to my drum buss using this plug in. It sounds very natural to me. Here's hoping that support for 64 bit is on it's way.

Thanks again for the freebee,

Jeffrey Wheeler

DGillespie's picture
Eventide Staff
DGillespie
Joined: Jan 29 2008
Posts: 986
DGillespie
June 10, 2014 - 07:10 pm

Hi Jeffrey,

It should support 64 and 32 bit for all formats.  Please make sure Studio One is pointing at the c:\Program Files\Common Files\Steinberg\VST2 directory to see the 64 bit plug-in, or that you've installed the 64 bit plug-in in your proper search directory for Studio One.  Note that the 32 and 64 bit plug-ins cannot be installed in the same directory.

Dan

rlaine
Joined: Jan 29 2012
Posts: 7
rlaine
June 11, 2014 - 04:51 am

Audio Units don't work with Studio One 2.6 Mac at all. Neither 32bit or 64bit. VST is ok.

The same applies for new versions of Omnipressor (which I just updated together with this).

DGillespie's picture
Eventide Staff
DGillespie
Joined: Jan 29 2008
Posts: 986
DGillespie
June 11, 2014 - 09:59 am

Hi rlane,

I've been able to confirm the issue with Studio One AU, and we're looking into it.

Dan

taco7777
Joined: Jul 14 2014
Posts: 2
taco7777
January 30, 2016 - 12:27 am

So can Studio One Pro use  Ultra Channel  by Eventide  as an efects plug-in ?

DGillespie's picture
Eventide Staff
DGillespie
Joined: Jan 29 2008
Posts: 986
DGillespie
January 30, 2016 - 02:18 pm

Hi TACO777 (making me hungry),

 

Yes, they will work with Studio One, this bug has been fixed.

 

Dan