You are here

Plug-Ins

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

Topic / Topic starter Repliessort descending Last post
Normal topic trouble with crystal plugin
by sklawlor » June 09, 2020 - 07:34 pm
1
by tlongabaugh
June 09, 2020 - 08:10 pm
Normal topic Looking for 2 patches or settings for the patches
by smoniz1972 » November 17, 2018 - 09:28 am
1
by smoniz1972
November 17, 2018 - 09:28 am
Normal topic It's been more than 19 days but (not what you think)
by mudrecords » June 01, 2012 - 05:56 am
1
by mudrecords
June 01, 2012 - 05:56 am
Normal topic Wrong image for Ultrareverb on site
by medway » December 03, 2014 - 09:34 am
1
by medway
December 03, 2014 - 09:34 am
Normal topic Audiosuite? RTAS?
by import » August 24, 2006 - 08:21 am
1
by import
August 24, 2006 - 08:21 am
Normal topic New native H3000 plug in won't work with I-lok 1
by rastoutou » October 24, 2012 - 01:19 pm
1
by rastoutou
October 24, 2012 - 01:19 pm
Normal topic No plans for VST?
by siriusbliss » February 24, 2008 - 02:11 pm
1
by siriusbliss
February 24, 2008 - 02:11 pm
Normal topic UtlraChannel presets not showing up in GUI in Logic Pro X
by davetune » December 30, 2016 - 07:20 pm
1
by davetune
December 30, 2016 - 07:20 pm
Normal topic Ultrareverb not being recognized in logic pro 10 or Abelton 9
by sageman » October 18, 2014 - 02:51 pm
1
by sageman
October 18, 2014 - 02:51 pm
Normal topic H3000 2.5 upgrade older versions won't load in arrangements
by lionelred » April 30, 2015 - 04:32 pm
1
by lionelred
April 30, 2015 - 04:32 pm
Normal topic eventide anthology & mac os 10,4 with protools hd
by import » October 24, 2005 - 04:36 am
1
by import
October 24, 2005 - 04:36 am
Normal topic ?
by mikewillis » September 05, 2016 - 11:11 am
1
by mikewillis
September 05, 2016 - 11:11 am
Normal topic Plugin not found
by innosensius » August 13, 2018 - 11:44 am
1
by innosensius
August 13, 2018 - 11:44 am
Normal topic Where is my serial number for the H3000 demo plugin?
by mkarges » September 14, 2017 - 08:23 am
1
by mkarges
September 14, 2017 - 08:23 am
Normal topic updates to eventide reverb?
by import » October 31, 2004 - 07:09 pm
1
by import
October 31, 2004 - 07:09 pm
Normal topic Getting programs from an H3500 into Factory plug?
by priorytools » February 28, 2008 - 11:17 am
1
by priorytools
February 28, 2008 - 11:17 am
Normal topic Access to H3000-Presets in Logic Pro X
by henkx » May 25, 2019 - 11:59 am
1
by henkx
May 25, 2019 - 11:59 am
Normal topic UltraReverb not opening in Studio One 2.4
by rapier45 » October 25, 2014 - 10:55 pm
1
by rapier45
October 25, 2014 - 10:55 pm
Normal topic Ensemble Subscription to include Equivocate/Elevate?
by pfaffian » October 10, 2017 - 01:35 pm
1
by pfaffian
October 10, 2017 - 01:35 pm
Normal topic Can Octavox track an audio sidechain?
by arpaterson » July 07, 2019 - 05:49 pm
1
by arpaterson
July 07, 2019 - 05:49 pm
Normal topic Nooooo! The iOS sale ended early!
by Aaaand » February 24, 2020 - 10:36 am
1
by nsanchez
February 24, 2020 - 01:13 pm
Normal topic Pendulate download button gives wrong file
by greendingbat » September 03, 2020 - 07:54 am
1
by DGillespie
September 03, 2020 - 09:38 am
Normal topic SST-282 Space Station
by teacue » October 06, 2019 - 08:09 am
1
by tlongabaugh
October 07, 2019 - 11:09 am
Normal topic Octavox feature request
by ericzang » February 02, 2016 - 09:13 pm
1
by ericzang
February 02, 2016 - 09:13 pm
Normal topic No presets after installation
by ddark85 » March 27, 2018 - 10:41 am
1
by ddark85
March 27, 2018 - 10:41 am
New posts
No new posts
Hot topic with new posts
Hot topic without new posts
Sticky topic
Locked topic