You are here

Eclipse/Mixing Link

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

7 posts / 0 new
Last post
PeteB
Joined: Jan 16 2021
Posts: 5

Eclipse/Mixing Link

PeteB
January 17, 2021 - 07:46 am

I am a 6 mo new owner of an Eclipse. It is an awesome machine however a little daunting when attempting to incorporate into a live guitar rig. I have read lots of material in the forums but still struggle with maintaining levels particularly between programs and different guitar settings. Curious if anyone has used a Mixing Link as a way to manage the signal in a guitar amp effects loop. Currently using Mesa Boogies with series loops although I have one Boogie with a parallel loop and oddly that seems more manageable. Any thoughts much appreciated...

Pete

PeteB
Joined: Jan 16 2021
Posts: 5
PeteB
January 24, 2021 - 12:42 am

The Boogie FX Send doesn't seem to have the gain to get good levels on the Eclipse input. With the Mixing Link I am thinking to try: 

  • Guitar amp FX send>instrument IN MixLink
  • MixLink>balanced out >Eclipse IN
  • Eclipse Out > amp FX return 

Any thoughts on the wisdom (or lack of) this approach would be most welcome...many thanks

Pete

tbskoglund's picture
Eventide Staff
tbskoglund
Joined: Aug 28 2020
Posts: 34
tbskoglund
January 26, 2021 - 01:43 pm

Hi Pete, 

 

Can you give me some more information about your set up?

 

Are you getting a low input signal on the Eclipse with the series loop or parallel loop? Or both? 

Which specific MESA Boogie amps are you using? 

 

You mentioned that you are having issues maintaining levels between programs, is the low input signal issue always happening no matter what program you are using? Or is this changing as you change programs?  

 

From what I’ve read here on MESA’s website all of their amps since the MarkIIC+ have buffered effects loops, so it should provide a hot enough signal for your Eclipse. https://mesaboogie.zendesk.com/hc/en-us/articles/226119347-Should-I-use-...

 

I don’t think you would need to add a MixingLink in your effects loop to get the right signal level, how high do you have to turn up the gain on the Eclipse to get a decent signal level from the effects loop? 

PeteB
Joined: Jan 16 2021
Posts: 5
PeteB
January 28, 2021 - 01:29 am

Thanks for your response. I have several Boogie Amps. F-50 and Studio Caliber with parallel FX loops and a Mark II B and TA-30 with series loops. I find a general struggle getting optimum levels on the Eclipse as channel volumes also control send level. Seems if I had more control over the gain in the loop it would afford flexibility not so governed by the amp volume. The Mesa article you cite suggests trying their line driver with 12 db boost might be beneficial in the FX loop so I though perhaps go a step further with the Eventide Mixing Link. Is there benefit to be gained by using the balanced output from the Link to the Eclipse?

tbskoglund's picture
Eventide Staff
tbskoglund
Joined: Aug 28 2020
Posts: 34
tbskoglund
January 28, 2021 - 09:47 am

PeteB wrote:

Thanks for your response. I have several Boogie Amps. F-50 and Studio Caliber with parallel FX loops and a Mark II B and TA-30 with series loops. I find a general struggle getting optimum levels on the Eclipse as channel volumes also control send level. Seems if I had more control over the gain in the loop it would afford flexibility not so governed by the amp volume. The Mesa article you cite suggests trying their line driver with 12 db boost might be beneficial in the FX loop so I though perhaps go a step further with the Eventide Mixing Link. Is there benefit to be gained by using the balanced output from the Link to the Eclipse?

 

Nice Boogie collection! I love my Mark III. 

Your Mark II B might need an additional buffer since according to that article that amp is before Boogies had buffered effects loops. But I'm not familiar enough with the differences in Mark II amps to confirm that. 

When using the parallel effects loops, what are you setting the effects send mix level at? In that situation, your channel level on the amp should be independent of the effects send level. You have the Eclipse set to 100% wet and have tried turning up the effects send mix level up significantly and are still not getting a loud enough signal? 

PeteB
Joined: Jan 16 2021
Posts: 5
PeteB
February 01, 2021 - 01:20 am

Working with the TA-30 lately with channel gain at 12:00 and Eclipse input gain bumped up + 7db still barely moves the needle on the meter. Doesn't seem like the effects send is putting out adequate signal to the Eclipse. Do you think the Mixing Link might be worth a try?

nickrose's picture
Eventide Staff
nickrose
Joined: Jan 17 2008
Posts: 4640
nickrose
February 01, 2021 - 07:54 am

Much as we would love to sell you more equipment, you still have more Eclipse input gain available, so I would crank it up a bit.

Also, double check your cabling, especially balanced/unbalanced matching. The signal does seem very low - if you have noticeable hum or noise, this would point to a cabling issue.