You are here

H9000r Sample Rate Mismatch

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

13 posts / 0 new
Last post
Wiinston's picture
Wiinston
Joined: Dec 16 2015
Posts: 3

H9000r Sample Rate Mismatch

Wiinston
July 01, 2020 - 08:32 pm

Not once since I have setup the h9000r, have I not gotten the sample rate mismatch upon opening emote.

 

I have tried all the tricks posted here in the forum regarding the subject. 

 

I can't reliably use this. After 20+ mins of restarting, toggling sample rates I might get it to sync.

 

The only successive has been through toggling rates via Mac's "Audio Midi Setup" app. But that does not always work. I'm stumped and looking for some feedback.

 

thank you.

 

Im running the beta becuase no other installer would open via catalina.

 

 

MacOs Catalina 10.15.2

H9000r 1.2.4[7] (0021ed6e1)

joeydego's picture
Check out my Eventide Gear
joeydego
Joined: Jul 23 2014
Posts: 229
joeydego (My Eventide Gear)
July 03, 2020 - 01:12 am

How far off is it? Read in another thread as long as it locks its fine. It's apparently a reporting problem, not an actual mismatch

panmorpheo
Joined: Apr 15 2019
Posts: 16
panmorpheo
July 14, 2020 - 07:47 pm

Exact same problem here... It drives me crazy!!!! It was working for a while at 44.1KHz but now that I need to work at 48KHz it just doesn't want to sync. Here is a description of my setup: Master clock Apogee Big Ben, everything else is slave, including the H9000. As I already reported a year ago to Eventide, the internal termination of the H9000 does not work, nor does the physical little dongle provided... The Apogee Big Ben activity monitor led on the front panel does not light up for the H9000 (and it does for all the other devices of my studio). To use the H9000 USB has been a nightmare with 44.1KHz but after a few reboots of the H9000, the computer, the audio interface (RME Fireface 800) in all the possible combinations eventually I would get it to work... Not at 48KHz... Which means that I cannot use the H9000 USB, because the audio gets muted due to a "sample rate mismatch". The H9000 by the way does show that it is locked to the world clock, even though the audio is muted. 

Eventide Staff
tpluta
Joined: Feb 20 2020
Posts: 10
tpluta
July 17, 2020 - 02:25 pm

If the you see SAMPLE RATE MISMATCH in Emote, or USB AUDIO MUTE IS ON on the front panel, it means that the sample rate on the H9000 has changed and the sample rate on your computer needs to be updated to match it. This is a consequence of the H9000's asynchronous USB audio.

If you change the sample rate of your H9000, you then have to change the sample rate on your computer to the same value (via "Audio MIDI Setup" on Mac or in your DAW). You should change the sample rates in that order: H9000 first, computer second. The same thing applies if your H9000 is using some external clock source (like word clock), and that external clock source sample rate changes while you're using USB audio: you will need to update your computer's sample rate afterwards.

Sometimes, you'll see this message even though your computer and your H9000 are on the same sample rate. This can happen if you change the H9000 sample rate to some value other than the computer's sample rate and then switch it back to the computer's sample rate. In this case, you'll need to switch your computer's sample rate to some different value and then revert it back to the H9000's sample rate.

For example...

Suppose my H9000 clock source is set to "Int 48k" and my "H9000 USB Audio" sample rate on my computer is set to 48 kHz, but Emote says there is a SAMPLE RATE MISMATCH. All I need to do to get the USB audio unmuted is go to "Audio MIDI Setup" (on Mac) or my DAW's audio settings, change the computer's sample rate to some different value like 96 kHz, and then switch it back to 48 kHz to match the H9000.

You shouldn't have to reboot your H9000 for this to work.

panmorpheo
Joined: Apr 15 2019
Posts: 16
panmorpheo
July 17, 2020 - 05:17 pm

tpluta wrote:

If the you see SAMPLE RATE MISMATCH in Emote, or USB AUDIO MUTE IS ON on the front panel, it means that the sample rate on the H9000 has changed and the sample rate on your computer needs to be updated to match it. This is a consequence of the H9000's asynchronous USB audio.

If you change the sample rate of your H9000, you then have to change the sample rate on your computer to the same value (via "Audio MIDI Setup" on Mac or in your DAW). You should change the sample rates in that order: H9000 first, computer second. The same thing applies if your H9000 is using some external clock source (like word clock), and that external clock source sample rate changes while you're using USB audio: you will need to update your computer's sample rate afterwards.

Sometimes, you'll see this message even though your computer and your H9000 are on the same sample rate. This can happen if you change the H9000 sample rate to some value other than the computer's sample rate and then switch it back to the computer's sample rate. In this case, you'll need to switch your computer's sample rate to some different value and then revert it back to the H9000's sample rate.

For example...

Suppose my H9000 clock source is set to "Int 48k" and my "H9000 USB Audio" sample rate on my computer is set to 48 kHz, but Emote says there is a SAMPLE RATE MISMATCH. All I need to do to get the USB audio unmuted is go to "Audio MIDI Setup" (on Mac) or my DAW's audio settings, change the computer's sample rate to some different value like 96 kHz, and then switch it back to 48 kHz to match the H9000.

You shouldn't have to reboot your H9000 for this to work.

Thank you TPLUTA for your help. I need to make TWO things very clear, since I repeated them in several occasions but I NEVER recieved aknowledgment of those two issues. 

1. There is a problem with TERMINATION OF THE WORD CLOCK. The INTERNAL TERMINATION of the H9000 does not work, and the little physical dongle termination provided with the unit does not work either. How is it possible that I am the only one having this problem? I assume that there are a ton of professionals much more knowledgeable than me utilizing the H9000 in a very professional environment... How do they deal with this major issue? I can report that the termination is not working because on the Apogee Big Ben there is an activity led which shows when a device is properly terminated and the H9000 is the only device in my studio that does not show as properly terminated.

2. In a setup like mine (and I expect many other people to be in a similar situation) the H9000 and the rest of my equipment is SLAVE to the MASTER CLOCK coming, in my case, from an Apogee Big Ben. If I try to follow your instructions regarding the switching of the computer S/R to a different S/R and the back to the session S/R in order to get the H9000 to resync, how can I do that if the computer S/R is locked to the Master Clock of the Big Ben? (If I try to switch, it shows the different S/R for a second and then it snaps back to the S/R imposed by the Big Ben). Do I have to disconnect the word clock cable of the Audio Interface from the back of the Big Ben, do the switching to a different S/R on my audio Interface, then back to session S/R and then riconnect the Audio Interface word clock cable to the Big Ben? Do you understand the problem? I don't know how to explain it better than this...

panmorpheo
Joined: Apr 15 2019
Posts: 16
panmorpheo
July 19, 2020 - 09:22 pm

Hey TPLUTA,

I also would like to make sure that from my posts one more thing is clear... At 44.1KHz, if I boot up the H9000 first and then the computer and everything else, the USB audio WORKS. But, so far, at 48KHz I tried every possible combination of all the instructions you gave us and it NEVER WORKS. SO, again, the problem is at 48KHz.

Thank you,

Giorgio

Eventide Staff
jbamberg
Joined: Aug 22 2011
Posts: 244
jbamberg
July 20, 2020 - 11:37 am

panmorpheo wrote:

I also would like to make sure that from my posts one more thing is clear... At 44.1KHz, if I boot up the H9000 first and then the computer and everything else, the USB audio WORKS. But, so far, at 48KHz I tried every possible combination of all the instructions you gave us and it NEVER WORKS. SO, again, the problem is at 48KHz.

We are working on this and hope to have a solution soon. Apologies if you have already given us this information, but it would help a lot to know how your other equipment is connected to your computer (in particular, how the word clock is being supplied to the computer - e.g. is your Fireface in an aggregate device on mac OS? if so what are the aggregate device settings?).

Eventide Staff
jbamberg
Joined: Aug 22 2011
Posts: 244
jbamberg
July 20, 2020 - 01:28 pm

One more question: It looks like the Apogee Big Ben reports under terminated and over terminated conditions for the word clock.  Which are you seeing with the H9000?
 

panmorpheo
Joined: Apr 15 2019
Posts: 16
panmorpheo
July 20, 2020 - 02:23 pm

Thank you JBAMBER.

I am very happy that you are finally aware of the issue and are working on it.

My setup features an Apogee Big Ben as master clock. The audio interface is an RME Fireface 800 connected to a Mac Pro running High Sierra. My DAW is Logic. I use an Aggregate Device with FIreface 800 + H9000. The Apogee Big Ben has a led in the front panel for each of the 8 BNC word-clock connections which is lit up when the device atttached is properly terminated. The H9000 is not lit up and it shows as not terminated either if you turn on the internal termination from the clock menu of the unit nor if you attach the little physical termination dongle with a T-shaped adapter at the connection to the Big Ben. 

The audio mute problem is only present at 48KHz. When I work at 44.1KHz I just completely boot up the H9000 first and then the computer and everything else and there is no need to do other tricks, it works... Sometimes, even at 44.1KHz, some USB I/O would stop working randomly and unpredictably, but that is usually resolved with rebooting the whole studio.

One thing that I still do not understand is why the H9000 has to be booted up first and then "synced" by the computer (DAW) whereas any other device utilizing word-clock is just flowlessly synced by the master clock, following any S/R change without problems. Does this have anything to do with the termination problem?

Hope you guys can resolve these issues soon because the USB Audio is a great and vital feature of the H9000! 

Eventide Staff
jbamberg
Joined: Aug 22 2011
Posts: 244
jbamberg
July 22, 2020 - 12:47 pm

panmorpheo wrote:

The Apogee Big Ben has a led in the front panel for each of the 8 BNC word-clock connections which is lit up when the device atttached is properly terminated. The H9000 is not lit up and it shows as not terminated either if you turn on the internal termination from the clock menu of the unit nor if you attach the little physical termination dongle with a T-shaped adapter at the connection to the Big Ben. 

This indicates under-termination.  Nonetheless, the H9000 may still be correctly locked to the word clock.  I read this Apogee tech note on the Big Ben: https://apogeedigital.com/pdf/bigben_termination.pdf - it is possible that we also have the same issue as MOTU equipment, but in any case we are going to try to get hold of a Big Ben and will get to the bottom of this.

panmorpheo wrote:

One thing that I still do not understand is why the H9000 has to be booted up first and then "synced" by the computer (DAW) whereas any other device utilizing word-clock is just flowlessly synced by the master clock, following any S/R change without problems. Does this have anything to do with the termination problem?

The audio mute issue is almost certainly unrelated to the word clock termination.  The problem is the way that the asynchronous USB audio connection works.  There's no way for the H9000 to tell the computer to resync itself when the clock changes.

It should be possible to manage this using the CoreAudio aggregate device.  If you set the RME to be the "Clock Source" in the aggregate device in Audio/MIDI Setup, then you should be able to change the sample rate of the H9000 device in AMS independently of the sample rate of the aggregate device.  So, if you get the USB mute problem, change the sample rate of the H9000 device (NOT the aggregate device!) to 44.1 and back to 48 again.

I've attached a couple of screen shots to illustrate what I'm describing.  In my example the two devices are MG-XU (which is my mixer's built in audio interface) and Eventide Dice (which is my H9000 - it is an older hardware rev without USB).  I have set the the aggregate device clock source to MG-XU (i.e. not my H9000).  My aggregate device's sample rate is 48kHz, but as you can see, the H9000's sample rate is 44.1kHz.  I can change the H9000's rate without affecting the sample rate of the aggregate device.

 

panmorpheo
Joined: Apr 15 2019
Posts: 16
panmorpheo
July 22, 2020 - 07:36 pm

OK Jbamber, thank you!

A lot of important news and answers for everybody struggling with synchronization over USB!

1. The H9000 does not terminate the Word Clock INTERNALLY properly. So Eventide will have to look into this. 

2. The H9000 comes with a TERMINATION PLUG that is 50 ohm. I don't know about other Master Clock devices but the Apogee Big Ben requires a 75 ohm termination plug. I used another 75 ohm termination plug I took from another device in my setup and put on the H9000 T-connector and now the sensing led shows the H9000 PROPERLY TERMINATED. Yayyyy!!!! So, easy solution, do not terminate internally the H9000 but use a T-connector with a 75 ohm termination plug and you are good to go!

3. This one is HUGE. If you are on a Mac and use AGGREGATE DEVICES, make sure that the S/R of you Aggregate Device matches the S/R of the H9000 ALONE/SEPARATE that you can see in the available inerfaces' list in Audio MIDI Setup. My H9000 (on its Own) was at 44.1KHz in AMS and the Aggregate Device was at 48KHz synced with Word Clock and there was no way to make it work even though everything seemed synced and locked. So, again, if you use an Aggregate Device you must match whatever S/R you are using with the Aggregate Device with the S/R of the H9000 that you will find separate in the list of I/O devices available in the AMS app.

Finally we got an undesrtanding and a workaround of this!

Thank you, everybody and Jbamber!

Giorgio

Check out my Eventide Gear
Afturmath
Joined: Aug 21 2019
Posts: 5
Afturmath (My Eventide Gear)
December 28, 2020 - 12:07 pm

After updating to v1.3 and reading through this and a few other clocking-related threads, I think I finally have an aggregate audio device working between my UA Apollo TB2 stack and H9000R with USB + ADAT.

@jbamberg I wanted to confirm a setting for Mac OS X.

If I understand it correctly, the H9000 USB audio is clocked independently of the other digital audio. Is this true when synced over ADAT? I am currently clocking the H9000R via ADAT from an Apollo 8P while simultaneously using USB as an aggregate device. The setting I wanted to confirm is "Drift Correction". Should this be enabled even if the H9000 is clocked over ADAT?

Here are my H9000R clock settings.

Everything sounds fine so far, but I thought I'd ask before I spend too much time testing further.

Eventide Staff
jbamberg
Joined: Aug 22 2011
Posts: 244
jbamberg
December 28, 2020 - 03:57 pm

Afturmath wrote:

@jbamberg I wanted to confirm a setting for Mac OS X.

If I understand it correctly, the H9000 USB audio is clocked independently of the other digital audio. Is this true when synced over ADAT? I am currently clocking the H9000R via ADAT from an Apollo 8P while simultaneously using USB as an aggregate device. The setting I wanted to confirm is "Drift Correction". Should this be enabled even if the H9000 is clocked over ADAT?

The H9000 USB interface is clocked from the same source as everything else in the H9000, as determined by the "Clocksource" in the system settings.  In your case, that's the ADAT input.  So this means that the H9000 is clocking off the Apollo, so the H9000 USB audio should be in sync with the Apollo TB interface.

Refer to Apple's support article here: https://support.apple.com/guide/audio-midi-setup/set-aggregate-device-se...

This says that drift correction should be used when devices aren't hardware-synced to the same clock source.  So, I don't think you'd need it in this case. You'd just need to set the Clock Source of the aggregate to be the Apollo (which it looks like it already is).