You are here

Beta 3.5.0 strange programm change behavior

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

6 posts / 0 new
Last post
underwood
Joined: May 12 2011
Posts: 44

Beta 3.5.0 strange programm change behavior

underwood
February 09, 2012 - 05:00 am

Hello,

I've updated my timefactor and modfactor to 3.5.0 and I got a new midi-controller yesterday. Both pedals act different when recieving a program change command via midi.

The modfactor changes to the program and activates it, eaven when it is in bypass. The timefactor changes programm and goes to bypass. It doesn't matter if it was activated or not. I've compared both midi settings and they are identical.

I think this behavior isn't right. The right way is, that the pedals keep their state, when receiving a programm change command via midi.

I need help!!

I also want to buy a eventide space, how acts the pedal on a program change command via midi?

regards

achaput's picture
Eventide Staff
achaput
Joined: Jan 9 2008
Posts: 557
achaput
February 13, 2012 - 06:12 pm

Hello,

Your TimeFactor is not behaving the way it's supposed to. When it is Active and receives a Program Change message, it should stay Active. There is a setting which changes this behavior, and perhaps you have set this accidentally.

It's under the MIDI Menu under the RCV MAP. In this menu, the left column is a number which represents MIDI Program Change numbers. In the right column are the TimeFactor Presets. If you set this column to BYP or TOG, it means that TimeFactor could go into Bypass upon receiving a MIDI Program Change message.

Alan

underwood
Joined: May 12 2011
Posts: 44
underwood
February 14, 2012 - 05:20 am

Hello,

thanks for the answer. Both Eventides are set identical but behave differend and both wrong.

I've checked my RCV MAP and it is on the default setting:

1>1:1, 2>1:2, 3>2:1....100>50:2

Both do a program change when I send it via midi on the correct preset/program number but the TimeFactor goes in bypass or stays in bypass on program change to the preset and the ModFactor goes active or stays active on program change to the preset.

Right way is, that the pedal stays in it its actual state and only do a program change to the preset. Nothing more.

I've tested a different midi controller on the eventides and tested the controller with other gear.

Sorry for my bad english, I hope you understand what I mean.

regards

achaput's picture
Eventide Staff
achaput
Joined: Jan 9 2008
Posts: 557
achaput
February 14, 2012 - 03:33 pm

That is strange behavior for TimeFactor. Perhaps you could try sending a Program Change from ModFactor to TimeFactor just to test.

Connect ModFactor MIDI Out to TimeFactor MIDI IN.

In ModFactor MIDI Menu, set PGM XMT to ON.

Change a Preset on ModFactor and see what TimeFactor does...

Alan

underwood
Joined: May 12 2011
Posts: 44
underwood
February 15, 2012 - 01:24 pm

Hello,

have tryed it and same behavior as with the other two midi-controllers. TF goes or stays in bypass on programm-change.

I don't have testet the other way. Controlling the MF with the TF, because I think I will get the same results. MF goes or stays in active mode on programm-change.

Any suggestions why the pedals don't stay in their actual mode?

regards

underwood
Joined: May 12 2011
Posts: 44
underwood
April 05, 2012 - 01:22 pm

Hello,

I've updated to the latest FW 3.5.0[4] version and the problem is still there!

When does it get fixed?

regards