You are here

H9 won't communicate with H9 Control

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

22 posts / 0 new
Last post
Boynigel
Joined: Feb 16 2014
Posts: 90

H9 won't communicate with H9 Control

Boynigel
December 14, 2019 - 01:06 am

out of the blue my H9 stopped responding to patch change commands via my Tech21 midi mouse.  now on my ipad i get is this message:  "Communication Error!  Error code (sm_response_timeout) pedal is not responding" 

i found an old post here saying i should try updating the firmware so i clicked the link that took me to the Eventide Direct Updater.  i downloaded it (on my MBP) but when i try to open it i get the message, "Eventde Direct Updater cannot be opened because of a problem...check w/developer to make sure it works with this version of osx" etc

it said that it should work with os 10.8 and higher (i'm running 10.9.5) but it doesn't.

before trying all this i re-applied power while holding down the small hot button and the tap tempo footswitch as also suggested here.

FWIW i've had this h9 for about 5 years.  the last update i did for h9 was a month or two ago...i can't quite remember.  my point being that this problem didn't come about on the heels of any recent updates or changes.  i did update my ipad to the latest os a couple weeks ago but i've used it quite a bit w/the h9 since that update w/no probs until now.

okay, i'm stuck

nickrose's picture
Eventide Staff
nickrose
Joined: Jan 17 2008
Posts: 4538
nickrose
December 19, 2019 - 07:52 pm

Sorry you are having problems, especially as you are a long time H9 guy.

But, to help us help you, you should give a detailed description of your setup.

For example, you seem to be connecting to the H9 both by iPad and by Tech21.  How is this ? At the same time, or different ?

What is the " small hot button" - please use the descriptions in the UM, or it is hard for us to understand you.

Have you re-initialized the H9 ? If not, please do.

Also, try different new cables.

Sorry if the above is obvious, but there are usually reasons why these things don't work.

 

 

 

Boynigel
Joined: Feb 16 2014
Posts: 90
Boynigel
December 21, 2019 - 12:42 pm

nickrose wrote:

Sorry you are having problems, especially as you are a long time H9 guy.

But, to help us help you, you should give a detailed description of your setup.

For example, you seem to be connecting to the H9 both by iPad and by Tech21.  How is this ? At the same time, or different ?

What is the " small hot button" - please use the descriptions in the UM, or it is hard for us to understand you.

Have you re-initialized the H9 ? If not, please do.

Also, try different new cables.

Sorry if the above is obvious, but there are usually reasons why these things don't work.

 

 

 

the Tech21 pedal (midi mouse)is nothing more than a controller that allows me to scroll presets. I've been able to restore the ability to scroll presets with it but I keep getting the error message "Error code [SM_Response_Timeout] on my iPad.  Yes, I've reinitialized it but it doesn't help. What's more, I can't update the firmware either because it says my laptop may not be the correct OS version, even though it is. 

Boynigel
Joined: Feb 16 2014
Posts: 90
Boynigel
December 21, 2019 - 12:50 pm

nickrose wrote:

What is the " small hot button" - please use the descriptions in the UM, or it is hard for us to understand you.

its the tiny leftmost button on the H9 that says " Hotknob". I was told on the forum to hold it down while turning the unit on in order to initialize it but it didn't fix the problem 

nickrose's picture
Eventide Staff
nickrose
Joined: Jan 17 2008
Posts: 4538
nickrose
December 21, 2019 - 07:41 pm

It is very difficult and often near-impossible to diagnose complex problems remotely. This will be as frustrating for the customer as for the unfortunate who is trying to help them.

It is helpful if you give complete information - my rule is to ask:

1) What did you do ?

2) What did you see ?

3) What did you expect to see ?

You will understand why "it didn't fix the problem" is not helpful.

I suspect your problem is that you are trying to control the H9 from two different places - this will confuse it. Please totally disconnect your Tech21 from the H9 and see how it works.

 

 

 

Boynigel
Joined: Feb 16 2014
Posts: 90
Boynigel
December 21, 2019 - 08:40 pm

nickrose wrote:

It is very difficult and often near-impossible to diagnose complex problems remotely. This will be as frustrating for the customer as for the unfortunate who is trying to help them.

It is helpful if you give complete information - my rule is to ask:

 

1) What did you do ?

2) What did you see ?

3) What did you expect to see ?

You will understand why "it didn't fix the problem" is not helpful.

I suspect your problem is that you are trying to control the H9 from two different places - this will confuse it. Please totally disconnect your Tech21 from the H9 and see how it works.

 

what did I do?  Immediately after establishing a Bluetooth connection with H9 Control via my iPad, I select a preset.

What did I see?  The error message as written in my original post 

what did I expect to see?  NOT an error message. That said, once I clear the error message everything seems to work fine. 

 

Now regarding trying re-initialize the H9:

What did I do?  I held down the upper left Hotknob button while powering up the unit. 

What did I see?  The H9 appearing to re-initialize itself

What did I expect to see?  That the procedure would remedy the error message. But it didn't so...

...per forum recommendation by someone who had a similar problem I attempted to update the H9's firmware.:

What did I do?  I downloaded the firmware updater on my MBP 

What did I see?  A message"Eventde Direct Updater cannot be opened because of a problem...check w/developer to make sure it works with this version of osx" etc

for the record the site said that it should work with os 10.8 and higher (i'm running 10.9.5) but it doesn't.

What did I expect to see?  "Eventide Direct Updater successfully opened" and then being able to successfully update the H9 firmware which couldn't be done due to reasons outlined above. 
 

were you able to see the two pics I posted of my error messages?  Thanks for working with me on this 

Boynigel
Joined: Feb 16 2014
Posts: 90
Boynigel
December 21, 2019 - 08:53 pm

nickrose wrote:

I suspect your problem is that you are trying to control the H9 from two different places - this will confuse it. Please totally disconnect your Tech21 from the H9 and see how it works

 

ive been using the Tech21 with the H9 for over 3 years but I'll disconnect and see if it changes anything. Again, the Tech21 is only used for preset scrolling. I do control parameters via expression pedal though, and have been since day one. 
 

on another note I goofed in my last reply by saying I was "re-initializing". I was actually "power cycling" while holding down the Hotknob button and Tap toggle switch simultaneously in an effort to restore factory settings as told to do in an error message (pic of message in one of myprevious posts)

nickrose's picture
Eventide Staff
nickrose
Joined: Jan 17 2008
Posts: 4538
nickrose
December 22, 2019 - 11:06 am

Boynigel wrote:

ive been using the Tech21 with the H9 for over 3 years but I'll disconnect and see if it changes anything. 

That will be helpful. I am concerned about having two controllers.

I've passed your problem onto the H9control developers - hopefully they will understand the messages and tell us what is happening. May not get much response over the holiday.

 

Boynigel
Joined: Feb 16 2014
Posts: 90
Boynigel
December 22, 2019 - 11:15 am

nickrose wrote:

Boynigel wrote:

ive been using the Tech21 with the H9 for over 3 years but I'll disconnect and see if it changes anything. 

That will be helpful. I am concerned about having two controllers.

 

i disconnected the Tech21 MidiMouse and I still get the error message. New details- I get the error message no matter what. In the past I said the error message didn't come up until I selected something (via iPad control) but the simple fact is if I establish a Bluetooth connection and do nothing, within a few seconds the error message pops up.

Given that I am (technically) operational at this point with the H9, I am more interested in figuring out why I can't update the firmware due to the fact that it's telling me that my computers OS isn't compatible with the download for the update (even though I have an approved OS). I already outlined the specific details of this in one of my responses above. 

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 681
bohan
December 22, 2019 - 12:22 pm

Boynigel wrote:

i disconnected the Tech21 MidiMouse and I still get the error message. New details- I get the error message no matter what. In the past I said the error message didn't come up until I selected something (via iPad control) but the simple fact is if I establish a Bluetooth connection and do nothing, within a few seconds the error message pops up.

Given that I am (technically) operational at this point with the H9, I am more interested in figuring out why I can't update the firmware due to the fact that it's telling me that my computers OS isn't compatible with the download for the update (even though I have an approved OS). I already outlined the specific details of this in one of my responses above. 

Could you try connecting to your Mac/PC via a USB cable and see if H9 Control works on your computer? If it succeeds, you can just update your firmware in H9 Control on your computer.

Boynigel
Joined: Feb 16 2014
Posts: 90
Boynigel
December 22, 2019 - 12:52 pm

bohan wrote:

Boynigel wrote:

i disconnected the Tech21 MidiMouse and I still get the error message. New details- I get the error message no matter what. In the past I said the error message didn't come up until I selected something (via iPad control) but the simple fact is if I establish a Bluetooth connection and do nothing, within a few seconds the error message pops up.

Given that I am (technically) operational at this point with the H9, I am more interested in figuring out why I can't update the firmware due to the fact that it's telling me that my computers OS isn't compatible with the download for the update (even though I have an approved OS). I already outlined the specific details of this in one of my responses above. 

Could you try connecting to your Mac/PC via a USB cable and see if H9 Control works on your computer? If it succeeds, you can just update your firmware in H9 Control on your computer.

Control works but the problem is that Direct Updater "cannot be opened because of a problem"  "check with the developer to make sure eventide direct updater works with this version of OS X. You may need to reinstall the application. Be sure to install any available updates for the application in iOS 10." As such my only option given (via Control)is to update the software which I did just to take a chance to see if it helped, but it did not.

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 681
bohan
December 22, 2019 - 11:15 pm

Boynigel wrote:

Control works but the problem is that Direct Updater "cannot be opened because of a problem"  "check with the developer to make sure eventide direct updater works with this version of OS X. You may need to reinstall the application. Be sure to install any available updates for the application in iOS 10." As such my only option given (via Control)is to update the software which I did just to take a chance to see if it helped, but it did not.

Well if the Control works and you've updated the firmware then you don't need the direct updater, and it means it's not the firmware's problem.

Could you try reset your iPad's bluetooth and network settings, and restart it and see if that helps?

Boynigel
Joined: Feb 16 2014
Posts: 90
Boynigel
January 04, 2020 - 01:34 pm

bohan wrote:

Boynigel wrote:

Control works but the problem is that Direct Updater "cannot be opened because of a problem"  "check with the developer to make sure eventide direct updater works with this version of OS X. You may need to reinstall the application. Be sure to install any available updates for the application in iOS 10." As such my only option given (via Control)is to update the software which I did just to take a chance to see if it helped, but it did not.

Well if the Control works and you've updated the firmware then you don't need the direct updater, and it means it's not the firmware's problem.

Could you try reset your iPad's bluetooth and network settings, and restart it and see if that helps?

Control works but i always get the aforementioned 2 error messages.  to be clear, i DID NOT update the firmware as there is no option to do so.  It only lets me update the software which i didn't do because according to the info given, i already am up to date. i thought that the communication error might have just been a glitch between the h9 and my ipad so i tried using control with my iphone which solved the problem.  then the next day i started experiencing the same issues with the iphone as well.

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 681
bohan
January 04, 2020 - 10:21 pm

Boynigel wrote:

Control works but i always get the aforementioned 2 error messages.  to be clear, i DID NOT update the firmware as there is no option to do so.  It only lets me update the software which i didn't do because according to the info given, i already am up to date. i thought that the communication error might have just been a glitch between the h9 and my ipad so i tried using control with my iphone which solved the problem.  then the next day i started experiencing the same issues with the iphone as well.

Have you tried resetting the network setting?

If you have this issue on all your devices (iPad, phone, Mac/PC), then that means it's not the OS's problem. Probably something is wrong with the Bluetooth module in your H9. In that case, you would need to send it in for repair.

Boynigel
Joined: Feb 16 2014
Posts: 90
Boynigel
January 05, 2020 - 02:43 pm

bohan wrote:

Boynigel wrote:

Control works but i always get the aforementioned 2 error messages.  to be clear, i DID NOT update the firmware as there is no option to do so.  It only lets me update the software which i didn't do because according to the info given, i already am up to date. i thought that the communication error might have just been a glitch between the h9 and my ipad so i tried using control with my iphone which solved the problem.  then the next day i started experiencing the same issues with the iphone as well.

Have you tried resetting the network setting?

If you have this issue on all your devices (iPad, phone, Mac/PC), then that means it's not the OS's problem. Probably something is wrong with the Bluetooth module in your H9. In that case, you would need to send it in for repair.

"resetting the network setting"  is that done within the H9/Control, or are you talking about within my devices that host Control?

 

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 681
bohan
January 06, 2020 - 11:15 am

Boynigel wrote:

"resetting the network setting"  is that done within the H9/Control, or are you talking about within my devices that host Control?

I'm talking about your host devices.

ELIEZERGOMES
Joined: Jun 25 2018
Posts: 4
ELIEZERGOMES
January 23, 2020 - 07:04 pm

I have the same problem since the last update. I use android system, I've tried everything and I couldn't solve it. I called Eventide's assistance and it was unable to solve the problem. I try to connect via Bluetooth and it presents the same error that it has presented to everyone, I hope they solve it now. Following are prints of what happens. And the error presented itself after updating, it is not possible that it is a hardware defect.

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 681
bohan
January 27, 2020 - 10:55 am

ELIEZERGOMES wrote:

I have the same problem since the last update. I use android system, I've tried everything and I couldn't solve it. I called Eventide's assistance and it was unable to solve the problem. I try to connect via Bluetooth and it presents the same error that it has presented to everyone, I hope they solve it now. Following are prints of what happens. And the error presented itself after updating, it is not possible that it is a hardware defect.

Could you try using H9 Control on one of your other devices like tablets or desktops? So we may figure out if it is yout H9's problem or your phone's.

ELIEZERGOMES
Joined: Jun 25 2018
Posts: 4
ELIEZERGOMES
January 27, 2020 - 11:26 am
bohan wrote:

ELIEZERGOMES wrote:

I have the same problem since the last update. I use android system, I've tried everything and I couldn't solve it. I called Eventide's assistance and it was unable to solve the problem. I try to connect via Bluetooth and it presents the same error that it has presented to everyone, I hope they solve it now. Following are prints of what happens. And the error presented itself after updating, it is not possible that it is a hardware defect.

Could you try using H9 Control on one of your other devices like tablets or desktops? So we may figure out if it is yout H9's problem or your phone's.

I've tried to connect to more than one cell phone and other computers and it doesn't connect.

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 681
bohan
January 27, 2020 - 12:39 pm

ELIEZERGOMES wrote:

I've tried to connect to more than one cell phone and other computers and it doesn't connect.

Please reintall your the latest H9 firmware using the Direct Updater on a desktop via USB, and reinitialize your H9. Let us know how it goes.

ELIEZERGOMES
Joined: Jun 25 2018
Posts: 4
ELIEZERGOMES
January 27, 2020 - 12:44 pm

bohan wrote:

ELIEZERGOMES wrote:

I've tried to connect to more than one cell phone and other computers and it doesn't connect.

Please reintall your the latest H9 firmware using the Direct Updater on a desktop via USB, and reinitialize your H9. Let us know how it goes.

Can you send me the link?

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 681
bohan
January 27, 2020 - 01:34 pm

ELIEZERGOMES wrote:

Can you send me the link?

The Direct Updater is bundled within H9 Control. You can open it by clicking "Windows" -> "Open Direct Updater" in the menu bar