You are here

Making SoftStep 2 work with Eventide H9 using Advanced Editor and H9 Control

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

4 posts / 0 new
Last post
raymalone
Joined: Dec 26 2014
Posts: 1

Making SoftStep 2 work with Eventide H9 using Advanced Editor and H9 Control

January 09, 2017 - 04:45 pm

After spending the day playing around with both devices I finally got it working for what I needed:

1 - Active / Bypass toggle

2- Tap Tempo

3- Performance switch (Flex)

4- 7 Different programs

I'm putting 3 pics with helpful guidelines, they are far from perfect but worked for me.

If someone can help me out in figuring the LED default states (pic#3) I'd be very happy!

**  The most important setting is to tell the H9 in the Settings menu to Connect to Midi device and then chosse the SoftStep ( SSCOM Port 1) **

 

I'm not sure if I did this post correctly so I apologize in advance if I did something wrong.

 

 

Cheers!

 

Ray Malone

Montreal Canada

 

AttachmentSize
Image icon 1.jpg221.73 KB
Image icon 3.jpg98.75 KB
Image icon 2.jpg122.2 KB
howellrecords
Joined: Mar 10 2014
Posts: 1

Soft Step and Eventide Pedals

February 28, 2017 - 12:27 pm

This thread helped me to finally got my tap tempo to work. Thank you!

cljfford
Joined: Mar 3 2017
Posts: 23

Thank you so much for posting

February 09, 2018 - 04:21 pm

Thank you so much for posting this.

I'm trying to connect a Soft Step 2 to two H9s. I've followed your model but without success, so far. I think a big problem is that I can't do what you emphasize most: **  The most important setting is to tell the H9 in the Settings menu to Connect to Midi device and then choose the SoftStep ( SSCOM Port 1) ** Can someone please help me figure this out?

When I go to Settings in the H9 Control app and select "Connect MIDI Device to Eventide Device" in the menu, I don't see (SSCOM Port 1). I see None. And Clarette 4Pre MIDI. I don't know how the Clarett, my Focusrite Audio Interface, is seen by H9 Control. I've got the H9 synced to the OS X version of the Control app through Bluetooth only.

I have the SoftStep2 connected by USB to the KMI MIDI Expander and the MIDI Expander's MIDI OUT is going to the H9's MIDI IN. The MIDI Expander's amber MIDI OUT light flashes when I stomp the Keys that were programmed as per your instructions but, for instance, H9 Control is not hearing the CC message to Tap when I stomp Key 5. I do have a second MIDI cable running from the 1st H9's MIDI OUT port to the 2nd H9's MIDI IN port, if that is relevent. Maybe I'm getting ahead of myself, since I don't even have the first H9 working but I ultimately want to be able to control the two with the SoftStep.

I see there are some "MIDI Settings" in the Pedal tab next to Settings. Do I need to make adjustments to the settings elsewhere? I've tried a few blind experiments but didn't notice any action.

Thanks for reading.

bohan's picture
Eventide Staff
bohan
Joined: Jan 9 2018
Posts: 36

cljfford wrote:

February 11, 2018 - 12:39 am

cljfford wrote:

I have the SoftStep2 connected by USB to the KMI MIDI Expander and the MIDI Expander's MIDI OUT is going to the H9's MIDI IN. The MIDI Expander's amber MIDI OUT light flashes when I stomp the Keys that were programmed as per your instructions but, for instance, H9 Control is not hearing the CC message to Tap when I stomp Key 5. I do have a second MIDI cable running from the 1st H9's MIDI OUT port to the 2nd H9's MIDI IN port, if that is relevent. Maybe I'm getting ahead of myself, since I don't even have the first H9 working but I ultimately want to be able to control the two with the SoftStep.

I see there are some "MIDI Settings" in the Pedal tab next to Settings. Do I need to make adjustments to the settings elsewhere? I've tried a few blind experiments but didn't notice any action.

Hi, since you have connected SoftStep2 to your H9 through a MIDI cable, you don't need to choose the MIDI device in H9 Control, because that's for something connected to your computer/mobile device rather than H9 itself.

Yes, you do need to change some MIDI settings on H9 (or in H9 Control). First, you need to figure out what MIDI message your SoftStep2's Key 5 is sending. Let's say if it's CC 121, you need to go to Pedal Settings->MIDI Settings->Assign MIDI CC messages to pedal functions->Tap Tempo, and set it to MIDI CC 121.