You are here

ROSE - Update via Eventide Device Manager 1.5.0 - brief scare. OK.

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

1 post / 0 new
Kristal_Rose's picture
Kristal_Rose
Joined: Nov 10 2020
Posts: 10

ROSE - Update via Eventide Device Manager 1.5.0 - brief scare. OK.

Kristal_Rose
November 17, 2020 - 04:45 pm

[SYNOPSIS: If EDM update of Rose fails, try again.]

I concluded that my new Rose RS-017nn was running earlier firmware because it lacked banks for presets.

The Eventide Device Manager awaited a device. I powered on then usb plugged in the Rose. Win informed me a usb driver loaded. EDM identified my Rose in sub-panel and gave me options to install v2.3 - v3.15 (no Rose emulation panel yet). I selected 3.15. It said installing, then the Rose went to blinking and EDM froze. - I waited a couple minutes, closed EDM, disconnected Rose, and restarted Rose. Still solid LEDs, no activity, apparently bricked.

I then reconnected Rose, and opened EDM - got a warning panel 'Not supported USB protocol'. Clicked ok, still had install options via EDM, clicked to install v3.15 again.

This time I got a series of firmware install, erase, and verify progress panels and the Rose emulation panel appeared. Preset banks tested successful. Disconnected usb, repowered. Rose works!

...but it did (seemingly) pop my amp when powered on (I know I should know better, but it hadn't popped doing so earlier) ...and then the amp pops every 15 seconds - which turned out to be something absolutely unrelated and totally coincidental on the other amp channel, just my weird flavor of device karma.

Dell i7-4770 3.4Ghz , 24gb ram, running Win 7 pro SP-1 64bit