You are here

Using nixie with H9 connected

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

1 post / 0 new
rorytheherb
Joined: Apr 14 2016
Posts: 17

Using nixie with H9 connected

June 08, 2017 - 01:12 pm

nixie is a beta version preset librarian and editor for Strymon pedals. To use it to upload and download presets to a Strymon pedal the pedal must be conntected to the computer by MIDI via e.g. a USB interface. I have my Big Sky connected to my USB interface but there are pedals before and after, such that MIDI is merged along the loop. However, I found that when the H9 is between the Big Sky MIDI out and the PC's MIDI in, nixie is unable to detect the Big Sky. If I take the H9 out of my MIDI loop, nixie detects the Big Sky as it should. 

This problem is the case when the H9 is set to MIDI Merge. I would expect that in this mode, the H9 should pass thru all of the MIDI data from its input to its output as it does when in MIDI Thru mode.

The problem goes away when the H9 is set to MIDI thru or MIDI thru + clock. Nixie will detect the Big Sky when H9 is in these modes.

I thought I would share this information here in case anyone else is using nixie for Strymon pedals and also has an H9 in their MIDI chain, since it can be a big inconvenience to re-do all the MIDI connections on your pedalboard just to use the Strymon's preset librarian. Just switch the H9 MIDI output mode to MIDI thru while you use nixie, and switch it back to Merge afterwards.

I am puzzled as to why the problem occurs in MIDI Merge mode at all though. Seems to be a bug. 

regards,

Rory