You are here

Volume drop with Program Change using L6 Helix

Login to Post to Forums

You must be logged in to the Eventide website in order to post to our forums. If you do not have an account, you will need to create one. You may also reset your password.

8 posts / 0 new
Last post
cacibi
Joined: Feb 13 2009
Posts: 46

Volume drop with Program Change using L6 Helix

cacibi
February 19, 2017 - 04:57 pm

I'm having a helluva time today trying to control my H9 with my Helix.  I've run into this problem where, when I change presets using Program Change messages from the Helix to the H9, the volume drops way down on all H9 presets.

As far as I know I am not sending any other commands via the Helix and I have disabled MIDI control of the input and output volume on the H9 via the control app

Additionally, I can't figure out how to map MIDI CC messages from the Helix to control the Fast/Slow button on the Rotary models.  I can get it to brake, but I can't seem to get it to toggle FAST/SLOW.

Any help appreciated

 

cacibi
Joined: Feb 13 2009
Posts: 46
cacibi
February 20, 2017 - 12:53 am

Figured out a workaround for the Performance Switch assignment for the Rotary Algo using my Helix:

 

Posting this in case it's helpful to anyone...took me most of the day to find a workaround :-)

I was trying to figure out how to use MIDI CC from the Helix to control the Performance Switch in the Rotary Algo on my Eventide H9. I could set up a MIDI CC toggle switch and map it to the Performance Switch function, but when I do that - instead of mimicking the Performance Switch 100% (Fast/Slow; hold for Brake) it would only toggle between Fast and Break.

BUT - if you assign an expression pedal as MIDI CC controller to the performance switch...it works. Toe down is brake and heel down toggles between Slow/Fast. You can use Min Value 0 and Max Value 127 for full range, but it seems to feel a little better to me if you set the closest possible max/min values for on/of (63 & 64).

What David Lynch would call a "happy accident" because I kind of like working it with the expression pedal better than hitting a switch. A little more like a real Leslie.

Now...you might ask, why not just assign max/min rotor speeds to the expression pedal and skip the performance switch function altogether? Because it doesn't ramp when you do that. I just glides in between fast and slow and in a rather un-Leslie-like way.

Yarns
Joined: Jan 10 2019
Posts: 6
Yarns
October 04, 2020 - 05:23 pm

Hey Cacibi,

Did you figure out the volume drop issue? I am controlling a H9 with a HX Effects, and the same problem happened today twice (the H9 goes back to normal when I reboot it, but I don't want to play with the risk of random volume drops). This started to happen ever since I started controlling the H9 with the HX.

Thanks in advance for your help.

 

nickrose's picture
Eventide Staff
nickrose
Joined: Jan 17 2008
Posts: 4661
nickrose
October 04, 2020 - 06:44 pm

One possible cause for volume drop issues is that some products send out a MIDI bank select on CC32 which can be used for H9 Swell functions (ISW,OSW). Check these in the system menu and move them to another CC or disable and see if that makes a difference.

 

Yarns
Joined: Jan 10 2019
Posts: 6
Yarns
October 04, 2020 - 07:25 pm

Hi nickrose,

Thanks a lot for your answer.
There was a "CC32" slot that I lowered to zero on the HX, is that what you meant?

nickrose wrote:

One possible cause for volume drop issues is that some products send out a MIDI bank select on CC32 which can be used for H9 Swell functions (ISW,OSW). Check these in the system menu and move them to another CC or disable and see if that makes a difference.

 

nickrose's picture
Eventide Staff
nickrose
Joined: Jan 17 2008
Posts: 4661
nickrose
October 04, 2020 - 08:29 pm

You have the same issue on another thread - this kind of wastes time.

Further, I have to say I know nothing about the Helix.

My suggestion is that you look at the H9 and disable MIDI control of ISW and OSW.

 

 

 

Yarns
Joined: Jan 10 2019
Posts: 6
Yarns
October 05, 2020 - 04:03 pm

Sorry Nick. It's my first time posting on this forum, and I just asked two different persons hoping someone would answer and I am glad you are so prompt in helping.
I disabled the Midi routing on the H9 for Input and Output. I will keep you posted if the problem reoccurs.
Thanks for your help!

 

nickrose wrote:

You have the same issue on another thread - this kind of wastes time.

Further, I have to say I know nothing about the Helix.

My suggestion is that you look at the H9 and disable MIDI control of ISW and OSW.

 

 

 

camn
Joined: Sep 19 2016
Posts: 450
camn
October 06, 2020 - 01:15 am

I didn't dig this thread too much.. but it is Known that the Helix does NOT handle the performance switch correctly. search my old posts for details. I rec anyone with a helix should hardwire an aux switch for that if they want it... unless Helix has fixed this issue.