You are here

windows

Instant Flanger Mk II Installer for Windows

Release Notes

1.2.2

  • Fix occasional installation issue with VC++ distribution

1.2.0

  • Updated plugins with more robust fix for Cubase blacklisting issue. Users will need to download the latest iLok License Manager to take advantage of this fix.

1.1.4

  • Fixes an issue where plugin would be blacklisted or not load in some DAWs on Windows

1.1.3

  • Added notarization support and removed 32-bit builds from macOS installer
  • Added correct signing to Windows installer

Audient Promo for Windows

Release Notes

2.2.2

  • Fix a potential memory leak in AAX version of UltraReverb
  • Updated UltraReverbwith retina graphics
  • Added tail clearing on playback start/stop and plugin bypass/unbypass for both plugins (where applicable, subject to host and plugin format support)
  • Fix occasional installation issue with VC++ distribution

2.2.0

  • Updated plugins with more robust fix for Cubase blacklisting issue. Users will need to download the latest iLok License Manager to take advantage of this fix.

2.1.5

What are the recommended system specifications for the H9 Control app for Windows?

Forums

I am currently looking into buying a Windows touchscreen tablet for the H9 control app. Would this work on a tablet with a total system memory 1Gb? Also if anyone is using a similar setup, could you share what works well for you?

Ensemble Bundle Installer for Windows

Release Notes

2.5.0

  • Added Spring to the bundle
  • Fix a potential memory leak in AAX versions of Octavox, Quadravox, UltraReverb, H3000 Factory
  • Updated UltraReverb, Octavox, and Quadravox with retina graphics
  • Added tail clearing on playback start/stop and plugin bypass/unbypass for delay and reverb plugins (where applicable, subject to host and plugin format support)
  • Fix occasional installation issue with VC++ distribution

2.3.0

H9 Control crashes with non-alpha numeric characters [Windows]

Forums

I just want to report a bug that makes the H9 Control crashes every time I tranfer a preset with a "*" (asterisk) character.

I haven't used more non-alpha numeric characters so I'm not sure if it's just an issue that happens when "*" is present in a preset name. And please note that this happened while using the Eventide Space; I haven't tried with the H9 or the Timefactors I have either.

 

H9 Control 2.1.1 (running under Windows 7)

Eventide Space 5.0.0 [5]

2016 Stereo Room Installer for Windows

This is for 2016 Stereo Room, NOT SP2016 Reverb.

Make sure you are downloading the correct installer for the plugin you have.

Release Notes

3.5.0

  • Added tail clearing on playback start/stop and plugin bypass/unbypass (where applicable, subject to host and plugin format support)
  • Fix occasional installation issue with VC++ distribution

3.4.0