- Eventide Audio

Reply To: Rose 3.9 Version Warning

Home Forums Products Stompboxes Rose 3.9 Version Warning Reply To: Rose 3.9 Version Warning

#154663
buickwilson
Member

My fault (need better glasses). I saw  it as 3.1.1, so I figured 3.9 was the lates. Duh on me it’s 3.11. This works fine.

Thanks for the quick response.

Great pedal. Neil