- Eventide Audio

Reply To: Rose_EDM

Home Forums Products Stompboxes Rose_EDM Reply To: Rose_EDM

#155091
bohan
Moderator
Eventide Staff
stark wrote:

Downloaded EDM and loaded firmware 3.9, it's still asking for me to update firmware to use EDM. What's up with that?

Then why not update to 3.11?