- Eventide Audio

Reply To: H9 Max Windows 10 usb connection issues

Home Forums Products Stompboxes H9 Max Windows 10 usb connection issues Reply To: H9 Max Windows 10 usb connection issues

#156831
joecozzi
Moderator
Eventide Staff

If the app does not automatically find the connected devices, you will need to do some trouble shooting to determine whether the problem lies with your H9, with your Windows PC, or with the cable connecting the two.

One sure fire method to narrow down the source of the problem is to try connecting to your H9 with a different cable on the same computer, and if that does not solve the problem, to try connecting it from a different computer, if possible. If the same connectivity issues does not occur on multiple computers, that would suggest that the problem lies with your computer. In this case please check whether your H9 has been recognized as a MIDI device by your computer in the Device Manager. In order to do so, go to the “Control Panel” and open up “Device Manager”. This will be under “System” or directly visible depending on your Windows Version. Then, click on “Sound, video and game controllers” and you should see your pedal, listed either under its own name or as “USB Audio Device”. If your H9 does not appear there or has the incorrect device type, try connecting the H9 to a different USB port on your Windows PC, and if you are connecting through a USB hub, try connecting directly to a USB port on your Windows PC.

If your Eventide device does appear in the Device Manager with the correct type, please try closing any digital audio workstation that you may have running on your computer and try disconnecting any other connected Audio MIDI devices from your computer as in rare cases other connected devices can cause driver level communication issues. Also, sometimes just restarting your computer can help.

If the same connectivity issues occur on multiple computers, that would suggest that the problem lies with the pedal. In this case please make sure that you are powering your pedal with the power supply that came with your device as under powering a device with a non-Eventide power supply can cause connectivity issues. Also, please check whether your Pedal has been recognized as a MIDI device by your computer in the Device Manager as explained in the preceding paragraph. If the problem persists, please contact support@eventide.com for further help with the issue.