- Eventide Audio

Reply To: Saturate Delay/ 1.10 Update question.

Home Forums Products Plug-Ins Saturate Delay/ 1.10 Update question. Reply To: Saturate Delay/ 1.10 Update question.

#168192
DGillespie
Moderator
Eventide Staff

Hi,

Saturate 1.10 is forward compatible with all older versions of Saturate, so your sessions saved with an older version will load the same with a newer version.

There was a latency reporting issue fixed in version 1.9.1, so yes, go grab the latest from newfangledaudio.com/downloads.

 

Dan