H9 Control crashes with non-alpha numeric characters [Windows]

Home Forums Products Stompboxes H9 Control crashes with non-alpha numeric characters [Windows]

  • This topic is empty.
Viewing 5 reply threads
  • Author
    Posts
    • #112665
      spaceJam
      Member

      I just want to report a bug that makes the H9 Control crashes every time I tranfer a preset with a “*” (asterisk) character.

      I haven’t used more non-alpha numeric characters so I’m not sure if it’s just an issue that happens when “*” is present in a preset name. And please note that this happened while using the Eventide Space; I haven’t tried with the H9 or the Timefactors I have either.

       

      H9 Control 2.1.1 (running under Windows 7)

      Eventide Space 5.0.0 [5]

    • #139559
      nickrose
      Moderator
      Eventide Staff

      I suspect that the workaround is obvious…

       

    • #139570
      spaceJam
      Member

      Yes, or a warning in the manual of H9 Control about not using those characters. Or even better, fix it in the software and not worry about it anymore wink

      And not putting an asterisk in “Size*Matters” (factory presets #46 in Eventide Space) could be really smart if the H9 control software was made so it can not handle those non-alpha numeric characters.

      Of course it was designed years after that preset, right?

    • #139575
      nickrose
      Moderator
      Eventide Staff

      We will fix this in a future release. Until then……..

    • #139585
      gkellum
      Member

      H9 Control crashes every time I tranfer a preset with a "*" (asterisk) character.

      I remember a similar problem being reported a while back, and we added a filter to the preset names editor so that you couldn’t add such characters (although there are several of these kinds of dialogs and I’m not sure if we got them all). When you say it crashes when you transfer a preset, can you explain exactly where you are in H9 Control when you’re doing this, i.e. what screen and what button are you pushing? It wasn’t clear from your post whether you meant transferring a preset from the H9 to H9 Control or from H9 Control to the H9.

    • #139593
      spaceJam
      Member

      It happens when I transfer presets from Space to H9 Control with the export/transfer/save setting in the H9 Control software. I can take screenshots later when I get home if needed.

Viewing 5 reply threads
  • You must be logged in to reply to this topic.