PitchFactor Whammy MIDI Problem

Home Forums Products Stompboxes PitchFactor Whammy MIDI Problem

  • This topic is empty.
Viewing 6 reply threads
  • Author
    Posts
    • #108061
      ChrisJordan
      Member

      Ok, I may be doing something stupid, but here goes.  I am trying to use my PF as a whammy pedal, which I have done before; however, I am not getting any pitch bend.

      • I have V3.0 (19) firmware
      • I'm on Pitchflex
      • The display on the PF is showing it's receiving a signal from the MIDI is PDL 0 to PDL 100 – so I know the signal is getting there.
      • WET:DRY is 100 Wet
      • A(h) is at Unison – A(t) is at +1 Oct
      • B(t) and B(h) are off

      I am at a loss.

      Thanks for any help you can give.

    • #122540
      brock
      Participant

      I just tried your exact settings, and swept from unison up an octave using MIDI CC -> PED.  I'm also at a loss.  From your description, even the MIDI channel is set correctly.  Have you verified that your GLOBAL -> MIX setting is OFF?  Can you 'flex' an octave in Play mode using the middle switch (or an expression pedal)?  That's all I can think of at the moment.

      I like to move the Pitch Mix over to A10 + B0 in a single shifter patch like this.   If it's set to A10 + B10, you'll hear a reduction in amplitude.  A0 + B10, you'd hear … no output.  But you should still hear some pitch shift at anything but this extreme.

    • #122543
      wedelich
      Moderator
      Eventide Staff

      I believe this is a bug.  The workaround is to just plug a "dummy" jack into the expression pedal input on the back.  After you do this, you should be able to use expression pedal over MIDI in Pitchflex.  This is the only algorithm this bug affects.  Try this and let me know if it works. 

      Thanks,

      Russ

    • #133720
      ChrisJordan
      Member

      The dummy jack has fixed it.  Thank you very much.  It was infuriating as I love this little stomper. It's a taken up a big space in my heart.

    • #133721
      ChrisJordan
      Member

      This has fixed it a treat. Thank you very much.

      Chris

    • #133723
      brock
      Participant

      I had forgotten all about this little PitchFlex 'anomaly'.  I did indeed have an expression pedal plugged in when I ran through your posted settings.

    • #122730
      Atomicunderware
      Member

      Any chance of a patch to fix this bug? I remember it was an issue when I first had the TF and MF, but updates fixed it. Now that I have just updated to the new firmware the issue that was never there on the PF has appeared! I don't want to have to revert to the older version which didn't have the problem, but less features, and having a jack plugged in is not an acceptable solution.

Viewing 6 reply threads
  • You must be logged in to reply to this topic.