TimeFactor Expression Pedal Settings Jumping Around

Home Forums Products Stompboxes TimeFactor Expression Pedal Settings Jumping Around

  • This topic is empty.
Viewing 4 reply threads
  • Author
    Posts
    • #112669
      Ryanburton267
      Member

      I have just gotten started using the TimeFactor, and have realized that when the EXP pedal is plugged in, the values I have set it to control jump around. 

       

       

    • #139602
      nickrose
      Moderator
      Eventide Staff

      It could obviously be a hardware fault in the TF, but before you fear the worst, I would suggest trying another cable and pedal.

       

    • #139930
      Ryanburton267
      Member

      I have tried other cables and pedals, and this one seems to work so far ecept the exp numbers jump arojund still. usually it solves my issue by unplugging the pedal and plugging it back in

      • #139939
        nickrose
        Moderator
        Eventide Staff
        Ryanburton267 wrote:

        usually it solves my issue by unplugging the pedal and plugging it back in

        If by "unplugging the pedal" you refer to the expression pedal, this would suggest a dirty socket on the H9. A squirt of switch cleaner would be indicated.

    • #141360
      Ryanburton267
      Member

      I have not tried contact cleaner, but it is something i will have to try. I have seen alot of people having to send them in to get a ribbon fixed, but ive heard it costs around $100-$150 and I cant do that, especially for something that isnt my fault, it is clearly a part in the pedal that goes bad with no reason from the musician. 

    • #141390
      Given To Fly
      Participant

      When one of the Factor pedals has a problem with the ribbon connector inside the pedal, “jumping around” means random and erratic switching between all algorithms/parameters/etc. From your description, it sounds like the expression pedal you are using is not compatible with the TimeFactor. I had an expression pedal that never allowed the values to “settle” too. It was frustrating. My solution was to use the recommended Ernie Ball Jr. 25k Volume Pedal which works well. For what its worth, I do not think your TimeFactor is broken but you may have to try a new expression pedal. If you have the same problem with an Ernie Ball Jr. 25k Volume Pedal (try one out at a music store if you can) than the ball is back in Eventide’s court so to speak. 

Viewing 4 reply threads
  • You must be logged in to reply to this topic.