- Eventide Audio

Reply To: Time and Mod factor

Home Forums Products Stompboxes Time and Mod factor Reply To: Time and Mod factor

#132297
timothyhill
Member

Sounds like you have the KILLDRY function on. When it's on, the pedal won't pass any audio when it's bypassed. Try turning KILLDRY off, hopefully that will fix your problem. How to do so is detailed in the owner's manual in the System Menu Tree section (second option after BYPASS). Basically, go into System mode, select KILLDRY using the encoder knob, then turn the encoder until the display reads NO.

The reason they include this function is for people with parallel effects loops (some guitar amps, most mixing boards, etc.) where the effects mix is controlled by a knob on the amp or the board. This sounds like what you have. However, this really only works when using one pedal per loop. As you found out, it doesn't work so well when you want to use two or more pedals in the loop.

If you have the option of using the loop as a serial loop (refer to your amp or mixer documentation), this will work better. If you only have a parallel loop, set its mix control to its maximum setting (or to the highest level which sounds good to you). Just be aware that, even when bypassed, the pedals will still pass audio, which is ever so slightly delayed by passing through the pedal. When mixed back in when returns to the amp, it may change your overall tone, especially if the loop's mix control is set to less than 100% effect (max). Series loops don't have that problem because there's no way for dry audio to completely pass around the loop when the loop is active, while parallel loops can pass dry audio around the loop when the loop is on.

Bottom line, though, is when using more than one pedal in an effects loop, series loops are ideal, but parallel loops can yeild good results when setting the loop's mix control to max.

Another option would be to use only the TF in the loop and use the MF in front of the amp between the amp and guitar.