- Eventide Audio

Home Forums Products Stompboxes Eventide: MIDI Sync on Space does not work. Please fix it. Reply To: Eventide: MIDI Sync on Space does not work. Please fix it.

Eventide Staff


An update on MIDI sync in the Space MODECHOVERB algorithm:

Ok, so I Iooked into this and discovered that:

A. the delay section (echoes with feedback/repeats) is not timed correctly and does seem to flange or bounce around a click track, AND,

B. The overwhelming cause of these specific errors is NOT FROM MIDI clock syncing problems (though I'm still investigating those at large). 

Anyway, I've fixed this in MODECHOVERB and it should be available in the next update (no timeframe yet).  I also added a REVERB OFF option.  The source of this bug was as follows:

The MODECHOVERB signal chain feeds input->modulation->Reverb->Echoes (feedback delay).   The reverb always had an implied predelay (that depended on SIZE) that was throwing off the calcuation of the note-based delay times of the feedback delay, The echoes didn't start or repeat in the right spot in time.  I restructured the algorithm so that the delay was being fed with a non-predelayed reverberant signal, and added the option to turn REVERB off completely as well.   This seemed to fix the issue almost completely.  

I'll look into REVERSE as well and keep investigating the MIDI clock stuff in general.   I did notice that if the pedal stops receiving MIDI clock and then suddenly receives it again, that even if the clock is at the correct tempo, it takes the clock filter a second or so to "re-lock."  It gets there, but I think we can make it faster and tighter.  But again, this is actually an entirely seperate issue than the one detailed above about MODECHOVERB.