Eventide: MIDI Sync on Space does not work. Please fix it.

Home Forums Products Stompboxes Eventide: MIDI Sync on Space does not work. Please fix it.

  • This topic is empty.
Viewing 14 reply threads
  • Author
    Posts
    • #108094
      abrasivesounds
      Member

      Alright, here's a video showing that the midi sync on the space does not work. I've been messing with this for the last week, running tons of different configurations, but nothing works.

      Alas, I had to accept that the midi sync on the SPACE does not work.

      I've even tried using cc to control the tempo, but the same issues are present.

      Please come out with an update, as I bought this to sync with my other midi instruments.

    • #122631
      nickrose
      Moderator
      Eventide Staff

      There clearly is room for improvement in our MIDI clock performance. But, note that the test you are using is not very meaningful – since both boxes you show only display BPM in whole values, with no decimal point, it is quite likely that they could show value a BPM apart. For example if the sender is sending 120.6 it might display this as 121, whereas the receiver might display it as 120. This would also explain why it is different when moving in different directions.

      Our own silly fault for displaying the received value – you will note that almost nobody else does. Not saying we don't need to improve it (it's on the list), just that this is not a very meaningful test. The only thing that matters here is how it sounds …

    • #122632
      abrasivesounds
      Member

      I definitely understand what you're saying about the rounding of the sync, and I figured there was something going on like that.

      The issue is that patches using the echo are not in sync with the drum machine. They are slightly off, and when I do cascading delays with the timeline, the space is definitely out of sync. Additionally, I can't use the sync thru because the midi clock isn't precise.

      This is only an issue because I bought the space to have tempo synced reverse reverbs. 

    • #133796
      nickrose
      Moderator
      Eventide Staff

      As mentioned, we recognize that there is room for improvement…

      One thing to look out for – it won't respond to a small change in received tempo, as the audio effects of changes caused by this can be worse than the resulting error. So, if you go from (say) 119 to 120, it may not respond accurately. But, if you go from 100 to 120, it should be pretty much spot on (once it has settled).

    • #133797
      abrasivesounds
      Member

      Thanks for taking the time to respond. I'm not trying to knock you guys, as the reverb sounds are fantastic. I was really just hoping to have tempo synced reverse reverbs.

      Anyway, I don't do tempo changes at all, so it's a non-issue. I just noticed that the midi sync has a bit of lag to it. Isolated, it's not a big deal, but when running other midi-synced items (delays/tremolos) it becomes compounded.

      Looking forward to an update. I'll just stick with the luuuuusssshhh/dreammmyyyyy reverbs for not, because those rock realllllly hard.

    • #133892
      gosh
      Member

      ok, so i posted a message but it appears that it must have been too negative because the mod didn't allow it!

      I too suffer from this problem (sloppy midi clock sync resulting in sloppy delays) and eventide support tell me the problem does not exist. 

      It's not my midi clock source as that is ultra stable, i assure you.  Please can this get fixed!

      It really shouldn't be an issue..

      Geoff

    • #133893
      rmaxwell
      Moderator

      Hi Geoff,

      This is the first I have heard of this issue with Space.  I now see the comments preceding your post.  I have spoken with our developers and we will try to verify, isolate, and correct the problem in a subsequent software release.  Thanks for calling it to our attention.  Please stay tuned.

      Ray

    • #133894
      gosh
      Member

      Thanks Ray, appreciated.

    • #133895
      abrasivesounds
      Member

      I'm glad they are acknowledging it.

      When running the echomodverb, the repeats do not sync at all. Additionally, the feedack/repeats on the reverse are not in sync either.

      Can't wait for an update!

    • #133911
      wedelich
      Moderator
      Eventide Staff

      Hi gosh and abrasivesounds,

      I'm currently looking into this and would really appreciate any help you could give me.  Specifically, I'm looking for audio recordings that demonstrate the issues you are having along with a detailed setup description including all devices, settings, etc.  Even better would be audio recordings where you tell me at which specific times the issue starts/stops.  And, EVEN better would be an additional recording of your midiclock output that you are feeding the stompbox.  Anything helps, but the more specific the better. 

      Thanks for pointing this out, and we'll try to get it analyzed and resolved. 

      You can add files to the forum or email me: rwedelich@eventide.com

      -Russ

    • #133914
      wedelich
      Moderator
      Eventide Staff

      All,

      An update on MIDI sync in the Space MODECHOVERB algorithm:

      Ok, so I Iooked into this and discovered that:

      A. the delay section (echoes with feedback/repeats) is not timed correctly and does seem to flange or bounce around a click track, AND,

      B. The overwhelming cause of these specific errors is NOT FROM MIDI clock syncing problems (though I'm still investigating those at large). 

      Anyway, I've fixed this in MODECHOVERB and it should be available in the next update (no timeframe yet).  I also added a REVERB OFF option.  The source of this bug was as follows:

      The MODECHOVERB signal chain feeds input->modulation->Reverb->Echoes (feedback delay).   The reverb always had an implied predelay (that depended on SIZE) that was throwing off the calcuation of the note-based delay times of the feedback delay, The echoes didn't start or repeat in the right spot in time.  I restructured the algorithm so that the delay was being fed with a non-predelayed reverberant signal, and added the option to turn REVERB off completely as well.   This seemed to fix the issue almost completely.  

      I'll look into REVERSE as well and keep investigating the MIDI clock stuff in general.   I did notice that if the pedal stops receiving MIDI clock and then suddenly receives it again, that even if the clock is at the correct tempo, it takes the clock filter a second or so to "re-lock."  It gets there, but I think we can make it faster and tighter.  But again, this is actually an entirely seperate issue than the one detailed above about MODECHOVERB. 

      -Russ

    • #133915
      goldglob
      Member

      This is not directly related to this topic, but thought it might be worth mentioning. Modfactor- wave speed linked to midi clock- thought it was out- but then realized the clock was triggering the start of the wave (zero crossing) but what you hear as the pulse is actually the crest, so it seems that the clock is out.

    • #133916
      abrasivesounds
      Member

      I can try getting some audio files up today. I'll just make one channel the 4/4 click and the other the guitar audio. I'll run the reverse algorithm as well the modechoverb.

      I generally run: korg electribe -> space. All midi channels are set properly, as are midi receive / clock filter, per the manual. The sync is not horribly off, maybe 50-100ms at most. However, I do a lot of cascading delays / verbs / trems, so things start to compound.

      I use a program called bidule, and it does midi monitoring. Is that what you have in mind when you say recording of the midiclock output?

    • #134386
      mc_deli
      Member

      Wedelich,

      Can I humbly suggest you take any of the factor pedals, hook them up via USB to the most commonly used DAWs and experience MIDI sync drift for yourself at length.

      I have the Pitchfactor and Modfactor and Logic 9.1.6, PT 8.1, PT 10.1.1 and the factors just don't stay in sync.

      It is mind numbing and disappointing. Please fix it in a "future software update" yesterday!

    • #134387
      wedelich
      Moderator
      Eventide Staff

      Hi mc_deli, 

      Have you tried V3.5 for both PF and MF?  You'll be able to install them with EUU.  I did some work to improve MIDI CLK sync performance in this new version.   This was included in the beta we released a little over a month ago, and so far we're getting positive responses from the users concerning the new MIDICLK performance.  Just last week we released V3.5 to full release version.

      With the new improvements, you should try it with the CLK FLT option ON.  

      Also, if there is any way to adjust the resolution of MIDICLK in your DAWs, you should set them to the smallest possible clock interval to minimize any jitter.  I find 1 ms and below works well on the factors especially with the aforementioned new work for MIDICLK sync.  

Viewing 14 reply threads
  • You must be logged in to reply to this topic.