- Eventide Audio

Reply To: Latest OS Compatibility Info

Home Forums Products Plug-Ins Latest OS Compatibility Info Reply To: Latest OS Compatibility Info

#161475
tmart
Participant

Hi.  I’m still seeing (in early January, 2022) issues with my Eventide & Newfangled plugins running on Mac M1 w/ Monterey: even with current Eventide installers such as H9 Series, etc. – Final Cut Pro is reporting incompatibility on pretty much all of the Eventide AU and Newfangled (Elevate bundle) AU plugins.  Am I missing something?  Thanks in advance.