2 Factors on iPAD with latest H9 and FW not working

Home Forums Products Stompboxes 2 Factors on iPAD with latest H9 and FW not working

  • This topic is empty.
Viewing 1 reply thread
  • Author
    Posts
    • #115279
      pinup57
      Member

      Hi,

       

      I had several conversations with support last fall about midi support for the iOS H9 app, and was VERY happy when I dropped by and saw that the january ’19 update includes support for connecting several devices over midi on the iPad. That’s great news, and I’m very thankful for this.

      However, after several hours of trying everything possible, I wasn’t able to get that to work. There are many combinations I tried, it just doesn’t work. I have managed to get either one of my Factors to connect (after many a reset to factory settings both on the app and the pedals, inluding re-registration of the hardware) but as soon as I connect both, nothing works anymore, including when I only connect one of them. As soon as I launch the app, both pedals freeze and I need to physically unplug the USB connector for them to recover. Then I need to go to the whole procedure:  reset pedals (hot-knob +  right switch), reset app, reregister pedal on account, one-after-another to get at least one to work.

      I have tried different USB hubs to no avail. I’m using a iPad2, iOS9.5, and a iConnect Midi4+ interface (all softwere is up-to-date).  I triple checked all the midi routings, nothing else is communicating on the same midiport. Most of the error message say “communication error”. If I plug only one, it says “”an error occurred while communicating with the xxFactor device <xF-serial_number_here>” ……….. Error code MessageConstats::sm_reponse_timeout, Error code [sm_response_timeout]. If I connect both, I get the same message but instead of identifying the pedal it just says “H9 device”.

      It would be so cool if I got that to work…. I’d appreciate any help

      Thanks!

      Dirk

       

      Show More...

      (PS TimeFactor and PitchFactor. And one note: yes I know about the camera connection kit, yes I bought one for this purpose but I will NOT use it simply because Apple didn’t bother to let it connect a charger. That was 100% money wasted. I’m working my **s off on a project, 12/14 hours a day for the past 6 months and can’t be bothered with battery-low breaks…. really.)

       

      Show Less...
    • #151714
      bohan
      Moderator
      Eventide Staff
      pinup57 wrote:

      I had several conversations with support last fall about midi support for the iOS H9 app, and was VERY happy when I dropped by and saw that the january '19 update includes support for connecting several devices over midi on the iPad. That's great news, and I'm very thankful for this.

      However, after several hours of trying everything possible, I wasn't able to get that to work. There are many combinations I tried, it just doesn't work. I have managed to get either one of my Factors to connect (after many a reset to factory settings both on the app and the pedals, inluding re-registration of the hardware) but as soon as I connect both, nothing works anymore, including when I only connect one of them. As soon as I launch the app, both pedals freeze and I need to physically unplug the USB connector for them to recover. Then I need to go to the whole procedure:  reset pedals (hot-knob +  right switch), reset app, reregister pedal on account, one-after-another to get at least one to work.

      Hi I'd like to know more about your setup. So how did you connect your stompboxes to your interface and iPad? What cables did you use?

      The update in January added support to connect to multiple devices via MIDI. The correct way to do that on an iPad is to click the "Connect to Eventide devices via MIDI" in the Settings page. Please see attached images.

      • #151715
        pinup57
        Member
        bohan wrote:

        Hi I’d like to know more about your setup. So how did you connect your stompboxes to your interface and iPad? What cables did you use?

        The update in January added support to connect to multiple devices via MIDI. The correct way to do that on an iPad is to click the “Connect to Eventide devices via MIDI” in the Settings page. Please see attached images.

        Hi, thanks for the quick reply. The Factors are connected to the iConnnectivity iCM4+ interface over USB using a USB hub (tried several hubs to no avail). The iCM4+ is connected to the iPad using the provided iConnectivity cable which is specially designed for this purpose. I  connect the devices in H9 Control by using the “Connect to Eventide devices via MIDI” option in the Settings page. There I choose the port I routed the Factors to and from. As I reported, I can get each to work independantly, but only if I totally reset everything after a failed attempt to connect both.

        Regards,

        Dirk

      • #151720
        bohan
        Moderator
        Eventide Staff
        pinup57 wrote:

        Hi, thanks for the quick reply. The Factors are connected to the iConnnectivity iCM4+ interface over USB using a USB hub (tried several hubs to no avail). The iCM4+ is connected to the iPad using the provided iConnectivity cable which is specially designed for this purpose. I  connect the devices in H9 Control by using the "Connect to Eventide devices via MIDI" option in the Settings page. There I choose the port I routed the Factors to and from. As I reported, I can get each to work independantly, but only if I totally reset everything after a failed attempt to connect both.

        I can see a potential problem here. So H9 Control can save the connection by remembering the MIDI ports' names. Therefore, if you have 2 identical MIDI port names for 2 pedals, H9 Control could mess them up. Did you set two different MIDI port names for your pedals?

      • #151722
        pinup57
        Member
        bohan wrote:

        I can see a potential problem here. So H9 Control can save the connection by remembering the MIDI ports’ names. Therefore, if you have 2 identical MIDI port names for 2 pedals, H9 Control could mess them up. Did you set two different MIDI port names for your pedals?

        Both pedals are using the same midiport as seen from the iPad. The routing is done inside the iCM4+. I don’t think that this could be otherwise: there’s only one port selectable in H9Control. Could this be related to incorrect device ID’s? I didn’t find an option to change these.

      • #151739
        bohan
        Moderator
        Eventide Staff
        pinup57 wrote:

        Both pedals are using the same midiport as seen from the iPad. The routing is done inside the iCM4+. I don't think that this could be otherwise: there's only one port selectable in H9Control. Could this be related to incorrect device ID's? I didn't find an option to change these.

        Now I'm pretty sure that's what caused the problem. The port names are configurable. Please refer to:

        https://downloads.iconnectivity.com/manuals/ICM4Manual2016-08.pdf

        http://forums.iconnectivity.com/index.php?p=/discussion/333/setting-custom-midi-port-names-for-os-x-and-ios

      • #151741
        pinup57
        Member
        bohan wrote:

        Now I’m pretty sure that’s what caused the problem. The port names are configurable. Please refer to:

        https://downloads.iconnectivity.com/manuals/ICM4Manual2016-08.pdf

        http://forums.iconnectivity.com/index.php?p=/discussion/333/setting-custom-midi-port-names-for-os-x-and-ios

        Hi, Thank you.

        Hi, it was not a matter of port names, but you put me on the right track: we must NOT use one single port for both pedals, but one distinct port for each one, and do the connection and registration process twice in a row. At first this didn’t work, but I finally managed to connect both. One glitch though: I had connected the TimeFactor first, and when I registered the PitchFactor, one of the dialogs mentioned the TF (I think it was the one that said “retrieving information from the pedal). But that didn’t seem to matter.

        I think this should be mentioned in the release notes: it’s not so obvious. I’m a veteran midi user, and I hadn’t realised this at all….. I thought that the “connect eventide device by midi” dialog indicated the port the devices should be connected to, so in my midi router I merged them to that port. This messed everything up including the iCM4+ which I needed to restart several times. The devices should really not share ports!

        But now that it works, I couldn’t be more happy! Thanks for your support, and awesome sounding products.

        Show More...

        Cheers

        Dirk

        Show Less...
      • #151743
        bohan
        Moderator
        Eventide Staff
        pinup57 wrote:

        But now that it works, I couldn't be more happy! Thanks for your support, and awesome sounding products.

        You're welcome. I'm happy that worked out for you. 

Viewing 1 reply thread
  • You must be logged in to reply to this topic.