Cannot update Time Factor Version 1

Home Forums Products Stompboxes Cannot update Time Factor Version 1

  • This topic is empty.
Viewing 3 reply threads
  • Author
    • #108135

      Using update utility version 1.6.1 build 14 I am trying to update Time Factor from it's current version 1.0 to the lastest version.  The problem is when I put it into update mode (power on middle switch held down) the update utility software doesn't recognise the device.  If I have the device on but in a normal mode such as play mode then it finds the device but doesn't let me update it cos it's version 1.  Also I am having to do this over MIDI because the USB connection doesn't work on Windows 7 64bit for some reason – the drivers won't install.  Can someone help?

    • #122726


      there are some general troubleshooting tips in this sticky:-

      some gotcha's that caught me out are MIDI clock needs to be off.

      but I have never tried to do this over MIDI or on Windows 7 x64.

      Might be easier to try a different computer via USB.

      Good luck


    • #122727

      I read that post and several others.  I tried it on Win XP and that did recognise the device as a usb device but the update utility still did not work with the time factor.  The time factor is version 1.0.  The other updates worked fine with my other pedals and this particular version of the update utility but they were all version 2 or higher.  My feeling is that the update utility build 14 doesn't work with version 1.0 of time factor for some reason.  I've emailed support with a very detailed description, including pictures, of the process and the problem.

    • #133891
      Eventide Staff

      If it truly is a V1.0, this would be an pre-production early alpha or beta version, which does not support USB updates.

      You will have to contact, and need to send it in to get it fixed.It is unlikely to be under warranty.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.