Can’t update my TIME Factor

Home Forums Products Stompboxes Can’t update my TIME Factor

  • This topic is empty.
Viewing 2 reply threads
  • Author
    • #109471

      Haven't done this in a while so lots of upgrades to install.

      With the most recent updater (1.6.1), it sees the pedal if I'm not in update mode, but when I follow the instructions (pressing the middle switch when powering up to go in update mode), the updater can't locate the pedal.

      I tried my old updater utility (1.0.2), which starts ok, then I choose update 1.10, then I'm prompted for my username and password, but then the updater crashes and quits.

    • #124185


      Try this-

      Log into the Eventide Website and change your password to one using only
      alphanumeric characters a-z A-Z 0-9 and then restart. The link to
      change your password is at the top right of the Forum page.

    • #125948


      I'm having the exact same problem. I have an older Timefactor that the Update Utility will see if the pedal is booted up normally, however if I put it in update mode the tool will not detect the pedal.

      I've tried USB from the pedal, I've tried using MIDI through multiple interfaces (Profire2626 and 002), multiple Win7 machines, a WinXP machine.

      By the looks of what cattaneo is saying, the older update utility will allow me to update my pedal however I cannot find a download source for the older version. I can only find v1.6.1.

      Can Eventide suggest a solution here or provide a download link to an older version of the update utility? This is killing me trying to get this thing updated.

Viewing 2 reply threads
  • You must be logged in to reply to this topic.