Eventide Device Manager: not finding connected MISHA(s)

Home Forums Products Eurorack Modules Eventide Device Manager: not finding connected MISHA(s)

Viewing 8 reply threads
  • Author
    Posts
    • #168541
      scobot1
      Participant

      Hello, I have two MISHAs.

      Neither is being “seen/found” by Eventide Device Manager (V1.9.2).

      Last month, I was able to update the firmware on one of the MISHAs (to V1.00.04) by following the instructions and using the provided USB cable, and using Eventide Device Manager.

      I purchased a second MISHA (I love MISHA!) – its current firmware is V1.00.00. Following the instructions for updating the firmware, using all the same cables and computer (MAC), the Eventide Device Manager does not find the connected MISHA (it is in standby mode – User1 and User2 lights are lit).

      I checked the connection/troubleshooting using the “updated” MISHA, and the Eventide Device Manager did not see/find that one either. I have tried this whole procedure on a PC as well – the same results.

      Is there anything else I can try? Is there a new version of the Eventide Device Manager? Is there a way to just load the firmware onto the SD card and update it that way?

      Thank you for your help. Just trying to update the firmware. Nothing fancy 🙂

    • #168542
      scobot1
      Participant

      Additional info: yes I have tried different USB cables.

      Question: does the EDM connect to a server somewhere…is it possible there is an issue with the software/host/server that is not indicated while using the software? Just grasping at straws here. The only thing I can think of is if something was “down” on Eventide’s end and the EDM needed to “ping” (communicate with) that and it was unable to…would that keep the EDM from “working” at finding the connected MISHA(s). I can try again tomorrow if that is the case.

      Thanks.

    • #168549
      tbskoglund
      Moderator
      Eventide Staff

      Hello,

      Sorry to hear you are having issues.

      Just to confirm, you are powering Misha while holding User 1 and the left Shift button to get into update mode?

      Are you using any sort of USB hub to connect to your computer?

      Can you try factory resetting one of your Mishas and try the connection again? You can factory reset the unit by holding Key and Scale while you power it on.

      EDM connects to a server to retrieve the software to download, but this should not affect your connection to Misha.

      Let me know what happens.

    • #168551
      scobot1
      Participant

      Hello, thanks for the reply.

      1) Yes, holding User1 and left shift button, User1 and User2 LEDs are lit.

      2) No USB hub. Have tried different inputs on both MAC and PC

      3) Did a factory reset on the V1.00.00 MISHA. EDM did not find a connected device.

      The curious thing is, at some point (last month), the process did work just fine for the one unit that I was able to update to the V1.00.04 firmware. So it’s as if the software is no longer working. Could that be? I downloaded the latest version. Is there a way to test the software? Is there an “old” version of the EDM you could send me to try? Might be a bug in this version? Or any way to load firmware via SD card?

      The MISHA is receiving power from the computer USB port (stays on if I turn off the modular case while still connected to the computer) – so somehow power is coming over the USB cable at least indicating that it is connected to the USB. I don’t know if the MISHA is seen as a USB device over USB or not so don’t know if it is a communication/port thing. But like I said, Two MISHAs, two computers to test on…one software.

      The first time was so easy, I was surprised to run into trouble.  Will the EDM “see” a connected device even if it has the latest firmware, or does it only “see” a device that is able to be updated? (doesn’t explain the one with the old firmware, but might explain why it doesn’t see the “updated” one) – grasping at straws! lol

       

       

    • #168552
      tbskoglund
      Moderator
      Eventide Staff

      Yes, your Misha should show up in EDM regardless of the firmware version it has.

      No, you cannot update the firmware via the SD card, you must use EDM.

      The latest version of EDM should work correctly, we have tested this on a few machines with different Mishas and we are not experiencing any issues.

      Have you tried selecting “Search for Devices” in EDM once your Misha is connected?

      Can you let me know what Mac model you are using, and what OS it is running?

      On your mac, if you open a terminal window, copy/paste the command below and hit enter, this will show a list of connected USB devices. You should see one titled “Misha Updater”.

      ioreg -p IOUSB -l -w 0 

    • #168555
      scobot1
      Participant

      HI,

      Oh yes, believe me I have clicked on “Search for device” – like a 1000 times (both for Mac and PC). 🙂

      PC: Windows 10

      Mac (is old Mac Mini, will look up details) But NOTE: this is the same MAC and OS that did update the other Misha. Only when I was unable to get it to work, did I download the PC version of the software. So…there shouldn’t be an issue unless the software was updated since I did the successful firmware update.

      I will look to see if the “Misha Updater” is showing up on MAC. Anything similar to look for on the Windows PC?

      Was the EDM updated in the last month or so? Is there an old version I can try? Am I obsessing too much about updating to firmware V1.00.04? lol

      Thanks.

       

    • #168566
      scobot1
      Participant

      MISHA 1 “About” info:

      • Version: 1.00.04
      • Build: 22091201
      • Boot Ver: 3.02
      • Ser#: MI-***90
      • Board Rev: 8

      MISHA 2 “About” info:

      • Version: 1.00.00
      • Build: 22062403
      • Boot Ver: 3.00
      • Ser#: MI-***93
      • Board Rev: 8

      EDM on Windows 10 and Windows 7 not seeing either MISHA. (tested multiple USB cables and ports)

      EDM on Mac OS High Sierra 10.13.6 EDM successfully updated MISHA 1 to firmware 1.00.004 on 12/20/2022 – but now EDM will not find either MISHA connected to Mac(?!) Worked a month ago.

      Was there an update to EDM since 12/20/22? Can I try an older version?

      I assume there may be future firmware updates for MISHA, so would like to figure this out so I can stay up to date. Frustrating the EDM on the Mac worked, but no longer does. Oh computers!

      Thanks again. Sorry for the headaches and “mystery”.

       

    • #168575
      tbskoglund
      Moderator
      Eventide Staff

      Sorry you are still having issues. I’ll email you directly with some further troubleshooting steps. Thanks for your patience.

    • #168590
      scobot1
      Participant

      Thank you @tbskoglund and Eventide Staff for reaching out via email. As it turns out, everything just “magically” worked today!  Go figure!

      The EDM worked (on the Mac) by seeing both MISHAs – as if there was never any problem and it was the most natural thing in the world. Updated the firmware on MISHA 2 easy-peasy.

      ONE possible thing to try (if anyone comes across this issue in the future) is to test the USB connection (and cable) with another device that has a Mini USB connection.

      I happened to have a ZOOM H1n Digital recorder that had a mini port and connected that to the Mac. Using the Terminal command, I was able to see that the ZOOM device was listed as a connection. I then left everything as is, connected “MISHA 1″(which had the updated firmware), ran the ioreg -p IOUSB -l -w 0 command, and saw “Eventide” device listed as being connected. Then I ran the EDM, it found MISHA 1 connected. I left everything as is, repeated the process with MISHA 2, and YES – the EDM found it too, and I was able to update the firmware.

      Don’t know what all that means. Maybe the USB port on the Mac had to be “woken up” or something.  Who knows?! Computers…gotta love them.

      Thanks again for the help, and willingness to go down the rabbit hole with me. Cheers!

Viewing 8 reply threads
  • You must be logged in to reply to this topic.