Eventide PitchFactor blinking and Eventide Space missing letters on screen

Home Forums Products Stompboxes Eventide PitchFactor blinking and Eventide Space missing letters on screen

  • This topic is empty.
Viewing 1 reply thread
  • Author
    Posts
    • #116251
      Salvatore_Miele
      Participant
      Hello everyone, 

       

      My PitchFactor has started to have problems with the screen, in practice it randomly starts to blink intermittently.

       

      My Eventide Space, on the other hand, sometimes does not display the preset names correctly, sometimes not displaying the vertical or horizontal parts of the letters.

       

      Show More...
      Both pedals are powered by the original power supplies.

       

      What should I do?

      Show Less...
    • #156605
      bohan
      Moderator
      Eventide Staff
      Salvatore_Miele wrote:

      Hello everyone, 

       

      My PitchFactor has started to have problems with the screen, in practice it randomly starts to blink intermittently.

       

      My Eventide Space, on the other hand, sometimes does not display the preset names correctly, sometimes not displaying the vertical or horizontal parts of the letters.

       

      Both pedals are powered by the original power supplies.

       

      What should I do?

      Show More...

      Sounds like loose ribbon cables.

      1st, you should back up your presets in H9 Control, and factory reset your units or reinstall the firmware with the Direct Updater (bundled with H9 Control)

      If #1 didn't help, you may try open your pedal and clean and tightly plug the ribbon cable between 2 boards (UI board with display & mainboard).

      Show Less...
Viewing 1 reply thread
  • You must be logged in to reply to this topic.