H9 Control on Android 13

Home Forums Products Stompboxes H9 Control on Android 13

Viewing 11 reply threads
  • Author
    • #174313

      Hi there,

      I was looking to install h9 control on my pixel 7 running android 13. When i go to the play store is says ‘This app isnt available for your device because it was made for an older version of Android’



      I was wondering if there was a new app to install? or if there was an update coming?

      And apologies if this was address on another post, but i couldnt find an answer



    • #174321
      Eventide Staff


      Sorry for the issues you are having. Can you please use the “H9 Control Android – Direct Download” from the link below and let me know if that works? https://www.eventideaudio.com/downloads/?product=H9+Max

      • #175564

        Glad this forum exists!

        Using the Direct Download, I was able to get H9 Control functional again.  I had to uninstall the existing instance first, resulting in loss of all presets and lists stored on my phone but better than having no control at all.

    • #174457

      awesome! works perfectly. Do you know if there is any plan to add it to the play store? just so it gets automatic updates and things like that?

    • #174571

      I have the same issue but my Galaxy 22 was working fine with the h9 app. Now not. I downloaded the direct app but got a message that I don’t have an app that can open the file?

      • #174580

        I just downloaded the app on my phone, and when i clicked on it in downloads it installed. It did throw up a warning about sideloading apps, but it was ok.

    • #174591

      App was working great until the October surprise update. Now app crashes and cant find my devices. not an issue with my H9’s because I have several. Definitely not my phone it is a Flagship Z-Fold. Definitely an “Eventide app developer issue.” And did I mention I am an engineer by trade so I usually can get things to work without issue.

    • #174612

      I have the same issue. I have a Samsung Galaxy A23 running Android 13. By default H9 control wasn’t discoverable on the Google play store, so i used the direct link to install.

      But, it dosnt work. The H9 will bluetooth pair with the phone. But the app dosnt discover it – I get the message ‘Device not found!’. When i select ‘Search for Bletooth Devices’ the app just crashes. Seems to work in demo mode, but thats it.

    • #174820

      My H9 android app also stopped working aftwr the latest update.  The direct download app won’t even reinstall.

    • #175002

      The direct download worked for me on Pixel 7 when the previous was crashing everytime it tried.to.connect to device. I also deleted all data prior to deleting the previous app in case that helped 🤷

      H9 Control Android – Direct Download

    • #175445

      Yep. Same experience here. Running Galaxy Tab S6 Lite, Android version 13, One UI version 5.1.1. After the most recent update, H9 crashes. Uninstalled, does not appear in Google Play store to install. Found this thread. Installed from the direct download and everything appears to be working. That was scary. When did drag and drop show up on Android??? I just noticed it.

    • #175886

      I know all the stompbox attention right now is on the H90, but is there a committment on the part of Eventide to keep the H9 Control for Android app current with new Android releases? It seems that this thread has gone quiet and I’m wondering about that. I could not do a live show without being able to control my two H9s from my Android tablet. Any input from Eventide is welcome.

    • #175894

      My H9 Max has worked fine for over a year and for some reason the app keeps shutting down whenever I try to connect to the pedal via Bluetooth. It stays open only in demo mode. I restarted my phone and uninstalled/reinstalled the app. Same thing. Any help would be greatly appreciated. Thanks.

    • #177281

      14 Jan 2024 and still doesn’t work the app via Bluetooth, not able to recall preset lists of the bands I play with.

Viewing 11 reply threads
  • You must be logged in to reply to this topic.