H9 looper not working when controlled via MIDI CC

Home Forums Products Stompboxes H9 looper not working when controlled via MIDI CC

  • This topic is empty.
Viewing 2 reply threads
  • Author
    Posts
    • #114111
      Robert Walitsch
      Member

      Hi!

      I’m a happy user of meanwhile 4 H9 devices in various setups I have.  So far no issues, but until yesterday I had never tried the H9 looper.  It seems to work great when used as standalone in stompbox mode, but when hooked up to MIDI devices to make use of the documented advanced features (i.e. sync to external MIDI clock plus control via MIDI CC) it does not work at all.

      I got all sort of problems (similar to the ones decribed here from back in 2015):

      https://www.eventideaudio.com/community/forum/stompboxes/h9-looper-issues-discussion

      https://www.eventideaudio.com/community/forum/stompboxes/h9-looper-0

      https://www.eventideaudio.com/community/forum/stompboxes/h9s-looper-bug

       

      It looks like these issues were never addressed and I just ran into these myself. Basically when enabling sync to the external MIDI clock, the troubles start i.e. the H9 syncs to tempo changes received from the DAW, but pretty much all the time fails to record in looper mode.

      All I really tried was to

      1. load a new patch which contains the looper preset
      2. send a CC to empty it (I later removed that as it starts empty anyway but does not solve the problem)
      3. send a CC to start recording
      4. send a CC 4 bars later to start play back

      … all while being synced to the MIDI clock.

      Most of the time I end up with empty recordings. Sometimes I get a loud high pitched buzz as described in one of the links above.

      After these issues, even starting looper recording manually with the stompbox buttons fails. Reloading the preset sometimes helps to get the stompbox mode looper working again, but there are cases where the H9 needs a power cycle (looks like it fully crashed).

      Your help is much appreciated.

      Rob

       

       

       

       

       

    • #146116
      wedelich
      Moderator
      Eventide Staff

      My first hunch is that your DAW is sending a MIDI START Command when you press play on the transport (see Looper manual in the H9 Control INFO tab for more info on MIDI Start and Stop).  If your MIDI CC to record is also happening close to this at the beginning, it will close the initial loop very quickly and put the looper in dub mode.  A few questions/suggestions: 

      1. Which DAW are you using?  We can try and reproduce it here.  Better yet, let us know the DAW and shoot us over a simple session that demonstrates the problem.

      2. It'd be good to find out if that particular DAW sends a MIDI START command, and if so, is there a way to disable it if you want to use CCs.  

      3. Can you hook up  MIDI monitoring program to see if there is any START command to verify? 

      4. Try removing your initial CC and see what happens, if it goes into record mode then you're probably getting a MIDI START.   

      5. Also DAWs usually have terrible MIDICLK timer resolution.  However, some allow you to set the resolution in an advanced menu.  If your DAW allows this, I'd set it to the smallest possible timer resolution.  

       

      As for those other issues in the links, we tried our darndest to reproduce most of them, and were unable to do so for the issues similar to yours. One of those threads looks like it just went dead after we requested more detailed information to help the user.  So maybe related, maybe not, hard to tell, but happy to pick it back up again for you!  

    • #146127
      Robert Walitsch
      Member

      Thanks a lot for your information. It helped me to make a big step forward.

      The DAW I’m using is Sonar and apparently if I want it to send MIDI clock output it also sends MIDI Start and Stop. I could verify on the H9 that it tries to jump right into overdub mode as you stated and the gets stuck there … unfortunately MIDI clock/start/stop inside Sonar is all enable/disabled with one checkbox, so there is no way to turn MIDI clock on and the start/stop off …

      However, from the information you provided I could derive a workaround: if I tell the DAW upon start of playback to send a MIDI prg chg to first load a non-looper H9 preset and then right afterwards send a MIDI prg chg to change to the H9 looper preset, I do not run into the instant overdub issue. H9 loads an empty looper preset and responds to record, play and stop CCs … as long as I keep the playback in the DAW a one sequence …

      If I enable loop mode in the DAW, apparently some MIDI messages are send when jumping to the start of the DAW loop. This is caused by some controller look back messages which should ensure that MIDI devices at the start of the DAW loop start with identical batches as before … apparently this totally throws the H9 off track (it usually buzzes load and gets stuck) … maybe could have a look at that / filter out some MIDI message internally if already looping ??? This I could disable in Sonar, but it will no longer establish the same patch settings for external synths when starting playback frmo any later point than “1:0:0”.

      MIDI clock lock is OK (mostly) … sometimes the end of the loop is not 100% spot on and the you hear an artefact at the end of the H9 looped section …

      Now I will try to see if I get it work with 2 H9s in series.  Any chance we will see the H9 looper process stereo IN/OUT anytime soon rather than summing to mono?

       

       

       

      Show More...
      Show Less...
      • #146174
        nickrose
        Moderator
        Eventide Staff
        Robert Walitsch wrote:
        Any chance we will see the H9 looper process stereo IN/OUT anytime soon rather than summing to mono?

        Unlikely, I fear. Running in stereo would halve the delay time, which would be a shame.

         

Viewing 2 reply threads
  • You must be logged in to reply to this topic.