H9 Screen Starts to Flicker After a While

Home Forums Products Stompboxes H9 Screen Starts to Flicker After a While

  • This topic is empty.
Viewing 1 reply thread
  • Author
    Posts
    • #116402
      BassPorn
      Member

      Hello, Everyone…

      I tried to search the forum for this topic, but with no luck…

      My eventide H9’s onBoard screen starts to flicker after a while (not long, actually)…

      It does so for a bit, then the letters begin to scroll… then they light one by one… then…

      It is hardly usable in these conditions…

      Any thoughts as to what this could be and how to fix it?!?…

      Grateful to anyone who might land a hand…  Cheers…

      Pier

    • #157445
      bohan
      Moderator
      Eventide Staff
      BassPorn wrote:

      Hello, Everyone…

      I tried to search the forum for this topic, but with no luck…

      My eventide H9's onBoard screen starts to flicker after a while (not long, actually)…

      It does so for a bit, then the letters begin to scroll… then they light one by one… then…

      It is hardly usable in these conditions…

      Any thoughts as to what this could be and how to fix it?!?…

      Grateful to anyone who might land a hand…  Cheers…

      Show More...

      Pier

      Are the effects are good? And does H9 Control work without any issues? If so, it may be a connection issue between the display and the board.

      Show Less...
    • #157446
      BassPorn
      Member
      bohan wrote:

      Are the effects are good? And does H9 Control work without any issues? If so, it may be a connection issue between the display and the board.

      Hello, Bohan…  Thanks for your quick reply…

      No, unfortunately it’s not just the display: as this happens, the sound becomes progressively degraded and disappears in the end…

      Pier

    • #157447
      bohan
      Moderator
      Eventide Staff
      BassPorn wrote:

      Hello, Bohan…  Thanks for your quick reply…

      No, unfortunately it's not just the display: as this happens, the sound becomes progressively degraded and disappears in the end…

      Pier

      OK. You may try

      1. Reinstalling its firmware by using the Direct Updater, which is bundled within H9 Control. It can be found if you click "Window" -> "Open Eventide Direct Updater" in H9 Control's menu bar on Mac, or by searching "Direct Updater" on Windows's start menu. You'll need to boot UPDATE mode by powering up the unit with HOTKNOB button pressed and held to do the update.

      2. After update, try a factory reset by powering up the unit with the right footswitch and the black encoder knob pressed.

      Show More...

      If these don't fix the issue, you should email support@eventide.com and consider to send it in for repair.

      Show Less...
    • #157450
      BassPorn
      Member
      bohan wrote:

      OK. You may try

      1. Reinstalling its firmware by using the Direct Updater, which is bundled within H9 Control. It can be found if you click “Window” -> “Open Eventide Direct Updater” in H9 Control’s menu bar on Mac, or by searching “Direct Updater” on Windows’s start menu. You’ll need to boot UPDATE mode by powering up the unit with HOTKNOB button pressed and held to do the update.

      2. After update, try a factory reset by powering up the unit with the right footswitch and the black encoder knob pressed.

      If these don’t fix the issue, you should email support@eventide.com and consider to send it in for repair.

      Hey, Bohan…  Thanks for your precious suggestion…

      Unfortunately, Direct Updater does not appear to be able to communicate with the H9, even over a direct USB cable…

      Show More...

      Guess I should open a ticket?!?  (do consider I live in Italy)…

      Pier

      Show Less...
    • #157456
      bohan
      Moderator
      Eventide Staff
      BassPorn wrote:

      Hey, Bohan…  Thanks for your precious suggestion…

      Unfortunately, Direct Updater does not appear to be able to communicate with the H9, even over a direct USB cable…

      Guess I should open a ticket?!?  (do consider I live in Italy)…

      Pier

      If and factory reset doesn't work and your PC/Mac cannot recognize your H9 as a USB or MIDI device, you should probably get it repaired. Please contact the seller or email support@eventide.com 

    • #157462
      BassPorn
      Member
      bohan wrote:

      If and factory reset doesn’t work and your PC/Mac cannot recognize your H9 as a USB or MIDI device, you should probably get it repaired. Please contact the seller or email support@eventide.com 

      Thanks, again…  I’m afraid I’m gonna have to do just that…

      All my best…  Cheers…

      Pier

Viewing 1 reply thread
  • You must be logged in to reply to this topic.