H90 Control losing device

Home Forums Products Stompboxes H90 Control losing device

Viewing 3 reply threads
  • Author
    • #171555

      I’ve been having a lot of problems with H90 Control 1.4.1.   I have to constantly re Add it because it whenever I restart everything the app shows the pedal greyed out including the connect button.  My experience has been when this happens the alternative is to delete and re-add the pedal which has shows all my powered up USB devices but not the H90 pedal.  On most occasions I have to put the pedal in recovery mode, quit and restart H90 control to fix the problem.   When I restarted this morning the H90 Control had the same problem and nothing that I have tried is allowing me to add the pedal.    I have an open ticket with Eventide but I was wondering if I’m the only one with this problem.   I’m running an Intel based Mac Mini with OS 12.5.1.

    • #171606

      Same issue here.

    • #171627
      Eventide Staff


      Sorry for the issues you are having. You shouldn’t need to delete/re-add the device or use recovery mode just to connect to H90 Control.

      Have you tried a different USB cable? Are you using a USB hub or adapter?

    • #171630

      Mine started working as if nothing was wrong. I hope this resolves everything for the other user. Thanks for responding.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.