H90 Control not seeing the H90

Home Forums Products Stompboxes H90 Control not seeing the H90

Tagged: 

  • This topic has 3 replies, 2 voices, and was last updated 3 weeks, 1 day ago by tbskoglund
    Eventide Staff
    .
Viewing 3 reply threads
  • Author
    Posts
    • #166635
      Arby82
      Participant

      I’ve got the H90 running and connected to my Windows 10 PC via the included USB cable. When I open control panel, I can see “H90 Pedal” listed in the devices. When I open H90 Control and click ‘Connnect’ it always says, “H90 not responding! Check your H90 USB connection.”

      Any ideas on what I can do to make it connect?

      Thanks!

       

       

    • #166644
      tbskoglund
      Moderator
      Eventide Staff

      Sorry for the issues you are having.

      In H90 Control, open preferences and click Rescan MIDI Ports. The Send and Receive port should both be “H90 Pedal”

      Let me know if that resolves the issue.

    • #166651
      Arby82
      Participant

      Thanks for the quick response. I didn’t really do anything differently today, but now it works. When I started up H90 Control, it said it needed to update the firmware on the pedal, which went off without a hitch, then the pedal rebooted and connected immediately. It seems we’re good to go now.

      Thanks again for your help!

    • #166675
      tbskoglund
      Moderator
      Eventide Staff

      Glad to hear it’s working!

Viewing 3 reply threads
  • You must be logged in to reply to this topic.