HELP! H9 Harpeggiator not working when tempo is engaged

Home Forums Products Stompboxes HELP! H9 Harpeggiator not working when tempo is engaged

  • This topic is empty.
Viewing 1 reply thread
  • Author
    • #112075

      Im wondering if anyone else is experiencing the fact that the harpeggiator doesnt modulate pitch when "tempo" is engaged? It modulates the pitch perfectly when tempo is switched off. Ive tried to update the firmware, but it doesnt fix the problem. There is also a mild scratchyness to the sound of the harpeggiator, im wondering if this algorithm is flawed. All my other algorithms sound perfect. 

    • #126961

      This is your 2nd unanswered thread on this issue, so I'll try to help out.  It's probably a simple routing or setting adjustment.  But you'll need to give a little more detail on how your system is set up.

      Do you have Global Tempo set to On (in the system / General Settings)?


      What are you using as a source of MIDI tempo (5-pin MIDI DIN plug or USB)?


      Is MIDI Clock In set to Yes / On (in the system / MIDI Settings)?


      Are you using the H9 Control app, or the H9 itself, to change Tempo=On?


      When you press the Tap button for more than 2 seconds (with Tempo On), do you see a BPM value?  Can you change that displayed value with the HotKnob?

      There are 2 conditions where I've seen the HarPeggiator "freeze" like that: One was under H9 Control – hooked through a USB cable – at the same time that a MIDI cable was hooked up to MIDI In.  And that was using a PitchFactor (not the H9).  Second, I've seen the PF jump to 500 BPM for no apparent reason.  The rates are so fast that it seems like a tempo freeze (in reality, a tempo blur).

      As for the "mild scratchiness", the HarPeggiator does have some rough edges; especially with multiple input notes & less-than-perfect playing technique.  There's a lot going on in that algorithm.  I try to keep it as simple as possible for the job at hand.  Or embrace it for the quirks and glitchy behavior.

Viewing 1 reply thread
  • You must be logged in to reply to this topic.