Help – Program Transmit not functioning!

Home Forums Products Stompboxes Help – Program Transmit not functioning!

  • This topic is empty.
Viewing 10 reply threads
  • Author
    • #107521

      I'm trying to have my Timefactor change presets on my Modfactor via MIDI.  I followed the video tutorial to set it up (System Mode>MIDI>PGM XMT – ON>Exit) but it doesn't work.  Any advice? Maybe something is turned on (or off) in the MIDI tier & needs to be adjusted?  

    • #121309

      Just a few quick thoughts… I'm going to guess you've ruled out a bad cable or a loose connection…

      Make sure that OUTPUT on the TF is set to XMT.

      Make sure both TF & MF are set to the same MIDI channel (XMT-CH on the TF side; on the MF side… RCV-CH set to OMNI or the same channel as the TF).

      Also, make sure that the RCV-MAP on the MF has a program assigned to the program change message it's receiving. It's unlikely, but possible, that it could be ignoring messages because of the map. You might want to check the XMT-MAP on the TF side, too.

      All this stuff is under the MIDI menus in System Mode, but I'm sure you caught that already. If the above doesn't help, can you give us more detail about the settings under the MIDI menu on both the TF and MF?

    • #121319


      Thanks for the info.  I did everything that you instructed – still does not work.  SO – here is the entire MIDI menu list for both the Time and Mod Factor pedals – hopefully you can tell me what I'm doing wrong (I'm sure I'm at fault here!):

      Timefactor (controller)                                         Modfactor (slave)

      MIDI menu:

      RCV CH – OMNI                                                   RCV CH OMNI

      XMIT CH – 1                                                           XMIT CH – 1

      RCV CTL – BYP <                                                 RCV CTL – BYP<

      XMIT CC – PDL<C15                                            XMIT CC- PDL<C15

      RCV MAP – 0 < 1:1                                                RCV MAP – 1 < 1:1

      XMIT MAP – 1:1 < 1                                               XMIT MAP – 1:1 < 0

      CTL XMT – ON                                                       CTL XMT – OFF

      PGM XMT – ON                                                      PGM XMT – OFF

      SYS ID – ID 1                                                          SYS ID – ID 1

      OUTPUT – XMIT                                                     OUTPUT – THRU

      ALL Clock Functions on both pedals:  OFF

      PLEASE tell me it's something I"M doing wrong!!!  I appreciate all of your advice and input greatly!!


    • #121320

      I tried everything you suggested – still doesn't work!  Here's the entire MIDI section settings for both pedals – Timefactor is the controller – Modfactor is the slave:

                                 TIMEFACTOR               MODFACTOR

      RCV CH                   OMNI                                OMNI

      XMT CH                     1                                         1

      RCV CTL                 BYP<                                 BYP<

      XMT CC                 PDL< C15                         PDL< C15

      RCV MAP                1 < 1:1                                1 < 1:1

      XMT MAP               1 < 1:1                                1 < 1:1

      CTL XMT                   ON                                      OFF

      PGM XMT                  ON                                      OFF

      SYS ID                         1                                           1

      OUTPUT                   XMT                                   THRU

      CLK IN                      OFF                                     OFF

      CLK OUT                  OFF                                     OFF

      CLK FLT                    OFF                                    OFF

      Hopefully it's ME that's doing something wrong!!!! Please let me know – I have a big show upcoming & would LOVE to control the MF with the TF.  I also have the Expression Pedal & 3 Button Aux Ftswch. that I can use to control both ala the Instructional Videos, but I've got to get the 2 pedals synched up first!

    • #132457
      Eventide Staff

      You say it "doesn't work." This can mean almost anything, but I assume that you mean you have no response from the MF.

      What presets are you loading on the TF and what are you trying to load on the MF, and how are your MIDI maps set up? Give an example of the program number on the TF, the corresponding program number on the MF, and the resulting TF XMT MAP and MF MF RCV MAP entry.

      Have you tried different cables ? Presumably they are connected IN to OUT and vice versa.

    • #132460

      I agree with Nick… The examples he's outlined will help us determine what's going on.

      Have you tried different cables? I have one set that won't always work because the plug's too big and doesn't fit securely.

      TF MIDI OUT >> MF MIDI IN – right?

      The TF is in BANK mode, right? (not play mode – this shouldn't matter on the MF, since it's receiving)

      Have you tried re-initializing both pedals? From the manual… "To restore System settings, power up ModFactor while simultaneously pressing the Right Footswitch and the Encoder until [CLEAR SETUP] is displayed."

      Please note, though, that even though the above is supposed to leave your presets in place, please back them up first. There is another procedure that WILL overwrite your presets, almost exactly like the one above, so just to be safe… backups are never a bad idea.

    • #132461

      Thanks Nick!  I get no response from the 'slave' (I want Timefactor to control ModFactor). All I want to do is load presets ala the Instructional Video.  Do I need to go through the entire MIDI mapping process for each patch? I thought it was as simple as your video showed!

      I tried different cables – including a brand new MIDI (Monstercable) – they are connected IN to OUT.

      Did you see the settings that I posted in the post above yours?  It details the MIDI settings – let me know if you need MORE info.  Hopefully this helps!  I'm a MIDI idiot, so any help would be greatly appreciated!

    • #132463
      Eventide Staff

      I think we're getting there … a problem is your MIDI Map settings. Although, this does not explain no activity. Make sure your MAX BANK value is set high enough.

      You DO have to have a MIDI Map setting for each preset at each end, sorry. These determine what MIDI Program Change message is sent  when you load a TF preset, and which MF preset is loaded for a corresponding received MIDI Program Change message. See the UM for more information. The other settings you list look good.

      You can probably make things easier by keeping the default TF TX MAP settings. Then the TF will send Program Change #0 for 1:1, #1 for 1:2, etc. Then setup the MF RX map to load the right presets to correspond.

      If you did not have these maps, you could only load MF 1:1 for TF 1:1, etc.

    • #132493

      Well – I've tried everything you suggested, read the manual thoroughly, and just spent hours getting everything set up correctly – still NO response from the controller to the slave whatsoever!!!  I even bought a new MIDI cable (Monster), but I'm starting to think that it's the MIDI cable connection – it's VERY loose fitting & I have to pretty much tape the cable ends to the chassis to secure them.  My MIDI maps are now correct, but nothing seems to transmit from one pedal to the other, even if I switch pedals & settings (MF controlling TF instead).  Any suggestions?  Can I bring them to NAMM & have you take a stab at it?  I'm at a loss right now – frustrating!  (Don't get me wrong – they are the BEST pedals I've ever owned & are keepers for my rig, I just WISH I could control one (or 2) with another.

    • #132501
      Eventide Staff

      Sadly, I don't get to go to NAMM, I have to stay here in the frozen North-East. But, some of our designers will be there and will be happy to talk to you.

      I would suggest that you do not bring equipment, as there are all sorts of security issues involved.

      It's just possible that we may have a few of our pedals at the booth.

      Back to your original problem – it would be helpful to test the hardware to make sure there is nothing wrong with it. Taking one pedal at a time, connect your MIDI cable from input to output. Then power up the unit with the left switch held down, until you see "TEST 1.x", or similar. Release the switch, and turn the encoder slowly until you see "31 MIDI PORT" scrolling. Press the encoder. You will see "P1E0T0", or similar. The number after P will increase. If the numbers after T or E are other than 0, you have a fault. If you appear to have a fault on both units, it's probably the cable.

      Note – follow these instructions carefully – you can damage the unit if you get experimental.

    • #132584

      OK – figured it out!  I'M AN IDIOT!!!!! The MIDI cables were not plugged all the way in!!!!!!  Now it's working!!!! Truly awesome!!  Thanks for bearing with me.

Viewing 10 reply threads
  • You must be logged in to reply to this topic.