Is My Brand New ModFactor Broken???

Home Forums Products Stompboxes Is My Brand New ModFactor Broken???

  • This topic is empty.
Viewing 4 reply threads
  • Author
    • #107034

      I just bought a brand new ModFactor. It arrived today after I have been waiting over a week to get it. I opened the box, plugged it in, and all I heard was my guitar… effect. I can switch between banks. I can switch between presets. But for some reason it won't actually turn the preset on. The left and right LEDs don't even light up when I'm trying to turn on a preset. Though, it acts like the preset is on. I can hit the slow and fast button (which the LED will engage), I can change tempo, I can change the parameters, but still no effect. I tried restoring the factory settings to see if it would then work….nothing. HELP!!!!!Is there a simple system fix to this? Or is it broken and I need to buy a new one?


       – Jeff

    • #120302

      Hi Jeff,

      Sorry to hear this. Something's not right. Please contact and they'll help you out.

    • #120314

      …or you could try updating it. might fix the problem. i tried updating mine before (not that it was problematic in the first place) but the update didn't go well and left my ModFactor behaving a bit like what yours is doing. The switches' LEDs won't turn on and the display was stuck. I just tried updating it again and it finished updating and the pedal worked fine after that.

      But it might be a good idea to just let Eventide know. At least you're using your warranty. Wink

    • #120315

      Hey thanks for the reply. I'm trying to update it now….but I'm running into some problems. The Update Utility is not listing any available updates. My software version is 2.0.2[3], if that helps at all. I know there is a newer update that is still in Beta mode, but the Utility doesn't have it listed???

      Also, if I try to do a force update with the Modfactor, the Utility originally wasn't recognizing my MF when it was in Update mode. When it finally did recognize it, the Utility said that I was unable to install the most recent update. This was the message I received:

      "The version information for your device cannot be determined, either because the device is in an invalid state or the device firmware is not reporting it correctly.
      To determine the exact firmware version of your device before proceeding, first reboot the device normally and then press 'Refresh Devices' below.
      Alternatively, press 'Cancel' to continue updating your device from the list of available updates."

      So I refresh the devices and restart the MF, but then the Update Utility doesn't have any new updates for me to install. Seems like a never ending cycle. Any suggestions???

       – Jeff

    • #131557
      Eventide Staff

      Hello rknjeff, sorry to hear about your problems.  Please see this thread for update utility issues:  Otherwise please email

Viewing 4 reply threads
  • You must be logged in to reply to this topic.