lot of issues connecting TF to pc/mac: help!

Home Forums Products Stompboxes lot of issues connecting TF to pc/mac: help!

Viewing 3 reply threads
  • Author
    • #169239

      Hi,  First I must say I’ve never used eventide software to edit my TF even if, long time ago, I was able to upgrade the version software (5.2.0 (6))

      Now, I can’t run Factorlib 1.8  on windows 10 Pro and on Macbook, as well. And the H9 sw doesn’t recognize my pedal (no pedal found).

      Windows pc:

      lunching the Sw  it recognize my TF (number: tf 02161) as a “MF” (the window name shows as: “Factor Pedal Librarian (MF)”.  When opening I can see first “TF”  (for  less of a second); then it turns in “MF”

      From the MIDI menu/config it shows correctly  Timefactor in Input and output.

      I can only upload the factory’s preset  from the FactorLib 1.8 folder. Trying to send a preset list to the pedal (or even a single selected preset) by clicking on “save to pedal” from the menu it shows this message:  “cannot send TF preset to MF pedal”. Sometimes happens that it crashes.

      I’ve tried to run Eventide Device Manager but it can only update the TF software. Though it recognize my pedal, no other options are available.

      MACBOOK: after dowloading Factorlib 1.8 (mac version) when trying to lunch the installer it shows this message:

      “impossible opening FactoLib 1.8 osx installer” because  the developer can’t be identified: macOS cant’ verify the app malware free”……

      No way to run the app….. I’ve tried to unlock permissions on FactorLib

      can someone tell me what’s happening????



    • #169289
      Eventide Staff


      The Factorlib software is quite old and I wouldn’t recommend using it at this point. You can use Eventide Device Manager to update the TimeFactor’s firmware, and you can use H9 Control to manage presets and adjust parameters.

      It seems like you are able to use Eventide Device Manager correctly if the device shows up and you are able to update the unit.

      Here are some tips for getting the connection to H9 Control to work:

      • Make sure there are no other USB or MIDI devices attached to your computer.
      • Make sure MIDI cables are not connected when the USB cable is connected.
      • Make sure you are not using a USB hub.
      • If TimeFactor, make sure “Looper” was not the last effect type selected.
      • Make sure MIDI Clock is turned off.
      • Make sure no other programs are running.
      • Make sure antivirus or firewall programs are not interfering with the update.
      • Make sure you are using the Eventide power supply.
      • Try the following factory reset. Be aware that it will erase any user presets and settings that you have created.
        • To restore Factory Presets and all System settings, power up TimeFactor while simultaneously pressing the Middle Footswitch and the Encoder until
          [INITIALIZING] is displayed.
    • #169307

      Thanks for your reply. The H9 control app doesn’t recognize in any way my pedal…..(“no pedals found”).

      TF is nor recognized using a tablet (android). I can’t use the H9 control with my MacBook because the app is not available for Mac nor for windows PC. I tried to download on my iPhone but, still, my pedal is not recognized. In this case a connection problem may exist as I can’t connect directly the usb cable to my iPhone (it has a lightning port) but I need a hub (how can I connect TF with my iPhone without using a hub?)

      In any case my pedals doesn’t need updating nor to reset the factory presets (just done by initializing trough the procedure you recall in the last point).

      Surely I’ m not using the original Eventide power supply as I purchased another one, long time ago, with the same features and power. It never showed any problem while using live in concert or at rehearsal: I can’t imagine how it could give troubles with the connection.

      I checked the other points of your “tips list” and I think it seems everything is ok……

      Thank you again


    • #169394
      Eventide Staff

      Thanks for this information.

      Have you tried a different USB cable that you know works with another device?

      When you connect your TimeFactor to your Mac, please go to Audio MIDI setup and go to Window > Show MIDI Studio. You should see “Eventide TimeFactor” as one of the MIDI devices.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.