macOS 10.15 Catalina Support Info

Home Forums Products Plug-Ins macOS 10.15 Catalina Support Info

  • This topic is empty.
Viewing 20 reply threads
  • Author
    Posts
    • #116174
      tlongabaugh
      Moderator
      Eventide Staff

      Eventide plugins are fully compatible with macOS 10.15 Catalina.

       

      Previous announcement (edited 11/13/19):

      Apple is expected to release macOS 10.15 Catalina sometime in October.

      At the moment, our plugins are not currently supported on macOS 10.15. We have been conducting systematic tests, and there are several known issues that we are working on resolving. We hope to officially support macOS 10.15 soon.

      In the meantime, please do not install macOS 10.15 if you are using Eventide plugins. Please check back here regularly for up-to-date information about compatibility.

    • #152841
      gwahlers
      Member

      will updating effect the H9 software ?

       

    • #152851
      galanter
      Member

      This release is not exactly a big surprise. Developers have had access to betas for months. Why weren’t more human resources put on this?

    • #152853
      galanter
      Member

      Are these problems due to 32-bit support going away? That’s been in the works for *years*.

    • #152860
      Vanuatu
      Participant

      Sorry Eventide, you have had the chance of testing and making the necessary adjustments with the Catalina beta for months. As I just spent quite some money on plugins from you I find this amateur way you are dealing with it pretty upsetting. What is you time frame for a solution now? Some days? Some months?

    • #152864
      nickrose
      Moderator
      Eventide Staff

      Many companies much larger than Eventide do not yet have support for Catalina. For example:

      http://avid.force.com/pkb/articles/en_US/Compatibility/macOS-Catalina-support

      This stuff is not easy.

      Please do not rush to upgrade to the latest shiniest thing unless either you really need it, or are confident that full support is in place.

       

    • #152867
      charlesanderson
      Member

      Hi everyone, I’m  Charles Anderson, I have just joined the site.Nice to meet you all. I just want to explore knowledge and share the valuable information here.

      Thanku

    • #152870
      tlongabaugh
      Moderator
      Eventide Staff

      Hi all-

      It is understandable that the current lack of support on Catalina is frustrating. As nickrose has mentioned, there are quite a number of significant changes in the release of Catalina, and they are not trivial to support.

      We have in fact been testing with the Catalina betas for several months, and making the necessary changes to our plugins and installers to support the release. However, there are still gating items – which we have reported to Apple – that prevent us from yet offerring full support. Additionally, Apple has been a moving target with regard to the changes required by Catalina. This process is further complicated when you are creating software which is run inside of other software (e.g. plug-ins).

      Of course, it is understood that there are a variety of reasons that users would want to update to Catalina. We are working to support it as soon as possible.

      -Tom

    • #152875
      amul
      Participant

      curious, do you guys have any projections or ideas? is it a week? or a month? three months?

    • #152912
      wonbyte
      Participant

      Any updates or ETA on when we might have Catalina support?

    • #153003
      rlehman-borer
      Member

      Some of our upstream software dependencies don't yet fully support Catalina, so we've been working with other vedors to find solutions that will be compatible with the new macOS without breaking existing configurations. I think we're getting very close, but I want to make sure to allocate sufficient time for testing before we support Catalina.

    • #153050
      wilkinsi
      Participant

      I’m curious to see how this “Side Car” feature works. In theory, users could have an Eventide plugin displayed on their iPad whilst their DAW is on the main`display, for example. Eventide are not the only developer with Catalina woes. Empirical Labs is another I use, so I understand the frustration in having to wait.

    • #153055
      Vanuatu
      Participant

      Sorry I don’t get it. Do all Eventide plugins not work at all with Catalina? Or only some plugins? Or only certain features of some plugins? Please, could you clarify this? Information here has been pretty vague.

    • #153060
      Vanuatu
      Participant

      Thank you!

    • #153080
      wichita2006
      Participant

      Any news about the issue you are having with Catalina?

    • #153102
      dcarmich
      Participant

      Just as a data point: I was able to install Anthology XI successfully on macOS 10.15.1 (along with the latest iLok) without any issues.

       

    • #153107
      derelict78
      Member

      just bought mangleverb and it is not working. 

      Error running chown -R ‘admin’ ‘/Users/admin/Documents/Eventide’: chown: /Users/admin/Documents/Eventide: Operation not permitted

      chown: /Users/admin/Documents/Eventide: Operation not permitted

      any idea when this will be resolved?

    • #153206
      rlehman-borer
      Member

      We've just released Catalina-compatible versions of all our plugins (and their installers)!

      Note: Plugin presets and documentation have been moved from the user Documents directory to Music, and the new installers will move any custom presets you have saved in the old location. This is true for all versions of macOS, but Catalina users will be prompted to grant the installer permission to modify the ~/Documents directory.

      Enjoy, and of course let us know if you encounter any problems.

    • #153254
      dangayle
      Participant

      Why didn’t you take the opportunity to move the presets to the standard macOS location ~/Library/Audio/Presets instead of this non-standard location?

       

    • #153626
      npinero1
      Participant

      I am getting a lot of issues. Starting with a 040755 error. the folder structure is not avaiable on my iMac Pro. What can I do?

    • #153722
      wilkinsi
      Participant

      Blackhole and Ultratap working fine on 10.15.2. I wasn’t taking any risks with the earlier versions of Catalina.

    • #152852
      nickrose
      Moderator
      Eventide Staff
      galanter wrote:

      This release is not exactly a big surprise. Developers have had access to betas for months. Why weren't more human resources put on this?

      Companies much larger than ours are having problems with Catalina.

      Unless your really really need it, I would suggest that you wait a while.

       

    • #152866
      galanter
      Member
      nickrose wrote:

      Many companies much larger than Eventide do not yet have support for Catalina. For example:

      http://avid.force.com/pkb/articles/en_US/Compatibility/macOS-Catalina-support

      This stuff is not easy.

      Please do not rush to upgrade to the latest shiniest thing unless either you really need it, or are confident that full support is in place.

      Please do not assume people are anxious to install Catalina merely because they like shiny things.  For example, Apple will be releasing security updates, and perhaps they will only install under Catalina. Other application vendors will be making highly desireable new releases, and perhaps they will only install under Catalina. Some use systems that are administered by IT staff, and they may have policies such that they only support the latest OS release.

      etc.

    • #153059
      rlehman-borer
      Member
      Vanuatu wrote:

      Sorry I don't get it. Do all Eventide plugins not work at all with Catalina? Or only some plugins? Or only certain features of some plugins? Please, could you clarify this? Information here has been pretty vague.

      At this time we're not aware of any problems with the plugins themselves, but we've found some issues when running our installers on Catalina. In particular, access to the Documents directory has been restricted, and that's where we've historically kept presets and documentation. If you've upgraded to Catalina and already have Eventide plugins installed, they likely still work. Running a fresh installation on Catalina may or may not work for you with the current installer versions, and we won't be able to provide support to Catalina users until we've officially released Catalina-compatible installers.

      In short, if you're not on Catalina yet, we advise sticking with your current OS for a bit longer. If you're already on Catalina and want to give it a shot, it's quite possible that you'll be able to get it working, but you do so at your own risk. I hope that helps!

    • #153259
      rlehman-borer
      Member
      dangayle wrote:

      Why didn't you take the opportunity to move the presets to the standard macOS location ~/Library/Audio/Presets instead of this non-standard location?

       

      My understanding is that the ~/Library/Audio/Presets directory is created and used by Logic and GarageBand for storing Audio Units presets (.aupreset). Eventide presets are stored in a custom format (.tide) that can be used by all the plugin formats we support, so we made the decision to use a different location.

    • #153601
      sop99
      Member
      dangayle wrote:

      Why didn’t you take the opportunity to move the presets to the standard macOS location ~/Library/Audio/Presets instead of this non-standard location?

       

      location really matters?

    • #153279
      dangayle
      Participant
      rlehman-borer wrote:

      My understanding is that the ~/Library/Audio/Presets directory is created and used by Logic and GarageBand for storing Audio Units presets (.aupreset). Eventide presets are stored in a custom format (.tide) that can be used by all the plugin formats we support, so we made the decision to use a different location.

      That is where almost all other developers put their user presets, .aupreset or not. U-he, Valhalla, Softube. It’s mostly only Native Instruments, iZotope and Eventide who do not.

      Default presets usually go in /Library/Audio/Presets:

       

      Show More...
      Show Less...
    • #153629
      DGillespie
      Moderator
      Eventide Staff
      npinero1 wrote:

      I am getting a lot of issues. Starting with a 040755 error. the folder structure is not avaiable on my iMac Pro. What can I do?

      Hey, sorry, the Eventide plug-ins do have Catalina installers, but I haven’t released them for Newfangled Audio yet. I do have them, though, so email support at newfangledaudio dot com and I’ll send them to you.
      I’m hoping to get them out next week.

    • #154057
      s.codec
      Member

      Hello,

      Where is the catalina version for Newflanged Elevate bundle? It’s not working on Catalina. It’s giving errors! It won’t install!

       

      DGillespie wrote:
      npinero1 wrote:

      I am getting a lot of issues. Starting with a 040755 error. the folder structure is not avaiable on my iMac Pro. What can I do?

      Show More...

      Hey, sorry, the Eventide plug-ins do have Catalina installers, but I haven’t released them for Newfangled Audio yet. I do have them, though, so email support at newfangledaudio dot com and I’ll send them to you. I’m hoping to get them out next week.

      Show Less...
    • #154072
      DGillespie
      Moderator
      Eventide Staff
      s.codec wrote:

      Hello,

      Where is the catalina version for Newflanged Elevate bundle? It's not working on Catalina. It's giving errors! It won't install!

       

      DGillespie wrote:
      npinero1 wrote:

      Show More...

      I am getting a lot of issues. Starting with a 040755 error. the folder structure is not avaiable on my iMac Pro. What can I do?

      Hey, sorry, the Eventide plug-ins do have Catalina installers, but I haven’t released them for Newfangled Audio yet. I do have them, though, so email support at newfangledaudio dot com and I’ll send them to you. I’m hoping to get them out next week.

      Hi s.codec.  I emailed them to you.  If you don't get them please email support at newfangledaudio dot com and I'll send them again.

       

      Thanks,

      Dan

      Show Less...
Viewing 20 reply threads
  • You must be logged in to reply to this topic.