Micro Pitch Device Mgr. Issue

Home Forums Products Stompboxes Micro Pitch Device Mgr. Issue

  • This topic is empty.
Viewing 38 reply threads
  • Author
    Posts
    • #116526
      dirtybuck
      Participant

      Not sure what’s going on here.

      I’ve had the Micro Pitch plugged in to my computer previously and everything worked fine.

      I was able to check out all the presets etc.

      Now when I’m connected I can’t get out of the 1st 5 presets. I’ve done the recent updates.

      Am I forgetting something that I need to do on the actual pedal?

      I know the bottom 2 lights should be lit in preset mode when going past the top 5 but for the life of me

      I cannot get them to come on.

      Newbie here, so thanks for any basic help in advance.

    • #157978
      joecozzi
      Moderator
      Eventide Staff

      If you have EDM open, check to make sure it’s not waiting for you to SAVE or CANCEL before you try to do anything else. You’ll see the prompt up top in yellow. If you try to change presets without first answering that query, you won’t get a response from the pedal. Just hit CANCEL and everything will function normally again. Let me know if that helps.

    • #157980
      dirtybuck
      Participant

      Thanks for the reply. No I don’t see that happening. When I open up the DM it does show the pop up of usb mode.

    • #157981
      joecozzi
      Moderator
      Eventide Staff

      Not sure I understand what you mean when you say pop up of USB mode. I’m not talking about when you first open up EDM a and it detects the pedal.

      I was referring to the normal screen where you can see the knobs in the middle and the presets on the right. Sometimes if EDM detects a change has been made on the pedal it will give you a prompt up top in yellow asking to SAVE or CANCEL. Because it is in this mode, it won’t allow you to do anything, like change presets, until you press either SAVE or CANCEL.

    • #157982
      dirtybuck
      Participant

      Hmm, not seeing a save or cancel prompt. I’m just not getting a preset to load when I click on any preset on the dm.

    • #157983
      joecozzi
      Moderator
      Eventide Staff

      What version of EDM are you running?

      and

      The pedal functions normally when not connected, correct?

    • #157984
      dirtybuck
      Participant

      Version 1.7.0. And yes, the pedal seems to work fine when unplugged. I did have the DM working previously and was able to check out the presets etc.

       

    • #157985
      joecozzi
      Moderator
      Eventide Staff

      To have a clearer understanding of what I’m talking about, please take a look at this picture. If you do not see the prompt on the top right or the word “modified” on the top left of the knobs pane, then I know the problem is something else.

    • #157986
      dirtybuck
      Participant

      Alright, when I move a knob on the DM those prompts appear. Then I just hit cancel to move on. I still cant seem to select a preset from the right side list.

      I can only scroll through the 5 on the pedal using the tap and active knob on the pedal. I must be overlooking something simple, so my apologies. Getting to where the lower 2 lights blink on the pedal and I can click any of preset is where I need to be.

    • #157987
      dirtybuck
      Participant

      When I move a knob on the dm then those prompts come up. I hit cancel to get out. What’s happening is I’m not able to select a preset and have it load. I can only manually change 1 thru 5 on the pedal. I must be missing something simple.

    • #157988
      joecozzi
      Moderator
      Eventide Staff

      Let’s try this:

      1-Turn the pedal off by disconnecting the power supply.

      2-Press the TAP footswitch and LED button above it simultaneously, while turning the pedal on. The LEDs should flash indicating you are in System Mode

      3-Open up EDM and go to the left where it says “Check For Updates”. Choose the first one, and reinstall it. The pedal should boot up like normal.

      See if you can use EDM like you’re wanting to. Let me know if the problem is fixed.

    • #157990
      dirtybuck
      Participant

      Alright, I did that and It still wasn’t responsive. Then out of frustration I did a factory reset. I only had one custom preset so far so I really didn’t care. The good news is everything worked as it should. The active/tap/primary lights stayed lit and I used the DM to load my favorites into the top 5. I unplugged and checked it all and the new top 5 saved properly. So just to check the software again I plugged it back into my PC and opened up the DM. When doing that I’m right where I started, unable to select presets. Obviously I’m going to do a factory reset every time. What could be the issue. I have a TRS to midi in the exp jack and the in and out used as it’s in the middle of my board. Also, in global settings what is ttl and opto midi setting? I have it on opto now. Thanks!

    • #157991
      joecozzi
      Moderator
      Eventide Staff

      Are you trying to access more than the five onboard presets without EDM?

      …because that is not possible unless you select them from within the software’s preset list or you send program changes via MIDI. If so, I apologize for misunderstanding this whole time. But, it’s NOT possible to search through more than the five onboard presets from the front panel.

      Use MIDI TTL when you’re using a 5-pin DIN to TRS converter box.

      Use MIDI OPTO when you’re using a MIDI controller that has TRS MIDI capabilities directly from a TRS output.

    • #157992
      dirtybuck
      Participant

      No, when I have the DM connected I can’t select a preset. The only time it worked was after I did the factory reset. I understand the pedal only allows the top 5 unless I select through midi. 

    • #157993
      joecozzi
      Moderator
      Eventide Staff

      You can’t select a preset from within EDM or from the front panel of the pedal?

      Out of curiosity, if you disconnect the TRS from the EXP input, do you have the same problem?

    • #157994
      dirtybuck
      Participant

      Selecting from the front panel is fine. I’ll see what It does after unplugging the midi trs. Thanks for the help on a holiday btw

    • #157995
      dirtybuck
      Participant

      Unplugged the midi trs and still cant load presets on the DM

    • #157996
      dirtybuck
      Participant

      I can make changes to a preset in the DM, but still only access a preset from the pedal, which of course is only 1-5. Selecting any preset in the DM does nothing.

    • #158006
      joecozzi
      Moderator
      Eventide Staff

      What OS are you using? MacOS or Windows? Which version? Is it possible to upload a short video of what you’re experiencing?

      I cannot replicate the issue you’re having.

    • #158011
      dirtybuck
      Participant

      Windows. V 1.7.0. Perhaps I should uninstall then reinstall the DM? 

    • #158012
      joecozzi
      Moderator
      Eventide Staff

      Wouldn’t hurt. All I know is, the when you have the pedal hooked up via USB and you click on presets in the list, they’re supposed to change immediately. If you’re not running into the CANCEL/SAVE prompt at any time and it’s still not working, there’s another issue. Let me know if reinstalling works for you.

    • #158055
      dnostrand
      Member

      Hi – wondering if this has been resolved. I am having the same issue. Updated both firmware and DM version. Cannot select a preset in DM and have it affect the MicroPitch at all…

       

       

    • #158057
      dnostrand
      Member

      Is that done through EDM in the “Check for Updates” section? Or do I have to manually put the pedal in update mode and then execute through EDM?

    • #158058
      dnostrand
      Member

      OK, I performed the update by putting the pedal into Update mode and then ran the update through EDM……so I should be up to date on both EDM and the pedal. Still can’t change presets on the pedal via EDM…..the preset changes on EDM, but does not change on the pedal. I am connected via USB to a MacOS Catalina 10.15.7 

    • #158059
      joecozzi
      Moderator
      Eventide Staff

      As stated earlier on this thread, do you see a Cancel / Save prompt up top and the preset highlighted in yellow? Until you press Cancel or Save, preset changes from the list in EDM won’t take effect on the pedal. Please see the attached image for guidance.

    • #158060
      dnostrand
      Member

      Right, I see those, perform the Cancel action, and still can’t change the presets on the pedal through DM…..not sure what else to try

    • #158061
      joecozzi
      Moderator
      Eventide Staff

      I cannot get the problem to manifest on my end. Please email support@eventide.com and explain the problem you are having. Please link to this forum thread, so they can see what we've covered. Include your operating system, EDM version, and any videos of the problem, if you have them. Hopefully, we can resolve this another way.

    • #158062
      joecozzi
      Moderator
      Eventide Staff

      By the way, there is a new version of EDM released on June 4th. Try downloading it and see if it resolves the issue: https://www.eventideaudio.com/support/product/13388/installers

    • #158063
      joecozzi
      Moderator
      Eventide Staff

      Additionally, you can try a Factory Reset. Be aware this completely erases all System Settings and User presets, so you may back those up on EDM before you restore factory settings.

       

      Backing up your pedal:

      Connect the pedal via USB to a computer

      Open up EDM and click OK when your pedal is detected.

      Navigate to the left side of the screen and click “Backup To File.” You have the option to name it and save the preset list to the location of your choice. This generates a .bak file that stores all presets in memory as well as System Settings.

      Factory Reset

      To conduct a factory reset on the Eventide Device Manager, navigate to the top left side, and click on “Factory Reset” under “Manage Device.” A pop-up will warn us this process cannot be undone, so this is our last chance to save our presets and settings. If we click OK, the reset takes about 8 seconds to complete at which point the pedal will return to normal functionality.

       

      Show More...

      Let us know if this solves the issue.

      Show Less...
    • #158064
      joecozzi
      Moderator
      Eventide Staff

      We may have found the problem. As a temporary solution, change your MIDI channel to "Omni" or '1" and EDM should changes presets for you.

    • #158065
      dnostrand
      Member

      Bingo!

      That worked for me – I had the midi channel set to 5 as I am using a Morningstar MC6 to call up presets.

       

      Thank you!

    • #158066
      joecozzi
      Moderator
      Eventide Staff

      Excellent. We're working on a new version of EDM where you don't have to worry about changing your custom MIDI channel. Until then, now you know what the workaround is. Thanks for working with us to track this down.

    • #158068
      dirtybuck
      Participant

      This is great news! I’ll try the workaround when my rack comes back from the shop. Thanks to everyone for figuring this out. Felt all alone for a minute there, and was not looking forward to another factory reset.

    • #158152
      CLUBTURBO
      Member

      Yeah, I had all these things fail as a solution with EMD.

      This is a Memory Issue in EDM.

      Software sometimes dose not know we have

      made changes, and the software falls behind

      the hardware settings.

      I Had To Remove EDM And Reinstall To Fix Everything

       

    • #158354
      dirtybuck
      Participant

      Gotta be honest, this is becoming a headache. After the work around going to omni. I tweaked my top 5 presets a bit and then just wanted to go back to everything in my midi/Airstep footswitch working like before. The micro pitch in my set-up is on midi channel 3. I can’t get my switch to command the pedal anymore and everything was fine before the workaround. I went into the pedal system set-up and tried to set it there and still nothing. then made sure it was midi trs on the exp jack etc. I appriciate your help. This really shouldn’t be this difficult. Please tell me what I need to do and all the details  on both device mgr and on the pedal itself to get this working again on midi channel 3. Thanks.

    • #158355
      joecozzi
      Moderator
      Eventide Staff

      Did you also set the MicroPitch Delay pedal back to MIDI channel 3 in the system settings? You didn’t mention it in your comment.

    • #158357
      dirtybuck
      Participant

      Yes, I did set it back to 3. it’s also strange that when I would hit the midi footswitch, although the pedal won’t activate, the 5 ladder lights do go on. Weird.

    • #158363
      dirtybuck
      Participant

      The Midi signal I send is a simple on and off for preset 1 thru 5. This all got mixed up after having to do the work around of setting the midi to 1 or omni.

      Really don’t want to do another factory reset. 2 questions, I see how to back up but how do I put the info back in the pedal / DM after a reset (which I hope not to have to do).

      2nd, are they working on an update to resolve these issues? Thanks….

    • #158365
      dirtybuck
      Participant

      Thanks for the reply and  for the help. I got the midi channel sorted out (somehow). 

      I had updated the device mgr. before all this but I see now it updated to 1.7. Very nice to hear it’s resolved in the new version.

      Thanks again!

    • #158056
      joecozzi
      Moderator
      Eventide Staff
      dnostrand wrote:
      I am having the same issue. Updated both firmware and DM version. Cannot select a preset in DM and have it affect the MicroPitch at all…

      Did you conduct the firmware update on EDM while the pedal was in Update Mode?

    • #158155
      joecozzi
      Moderator
      Eventide Staff
      CLUBTURBO wrote:
      Software sometimes does not know we have made changes, and the software falls behind the hardware settings.

      EDM is only one-way communication. We either turns the knobs on the pedal or we work with EDM’s knobs to control the pedal, but not both. Unlike H9 Control, which does use bi-directional communication, EDM will not sense changes we make on the pedal via the front panel knobs. It’s meant to be use as a preset management tool.

    • #158188
      CLUBTURBO
      Member
      joecozzi wrote:
      CLUBTURBO wrote:
      Software sometimes does not know we have made changes, and the software falls behind the hardware settings.

      EDM is only one-way communication. We either turns the knobs on the pedal or we work with EDM’s knobs to control the pedal, but not both. Unlike H9 Control, which does use bi-directional communication, EDM will not sense changes we make on the pedal via the front panel knobs. It’s meant to be use as a preset management tool.

       

      Thank You, I got that Part of the EDM preset Management Design?

      But Unix and Windows Both have the same memory issues

      as the memory slots in the memory chips get confused sometimes

      and try to assign and or look for newer information of which is not there.

      Its a caching issue I am almost 100% sure.

      I tried the same presets with no changes

      Show More...

      in EDM and on the Pitch Micro, same issue.

      I changed nothing, and had to reinstall to get it working.

      Never the less, I am still having an issue of EDM not liking

      what I am doing after I save a preset on pitch micro.

      Its no biggie to me? 

      I know how to work around it 100%?

      But still the issue of EDM not liking

      my saved setting on Pitch Micro.

      I can’t use EDM on anything but factory presets

      on EDM or Pitch Micro. Nothing I saved On Pitch Micro shows

      Up In EDM? I will work around it again some how.

      Or just ditch EDM I need way, more then 5 presets

      and this is a huge design issue from the start. 

      I can’t use EDM to make my presets, just wont work.

      If I can’t get EDM to see my saved settings?

      How Do I use EDM to change settings?

      I can maybe make up some software for a nicer way?

      But still left with the same issue on EDM. 

      Show Less...
    • #158189
      joecozzi
      Moderator
      Eventide Staff
      CLUBTURBO wrote:
      I am still having an issue of EDM not liking what I am doing after I save a preset on pitch micro.

      Are you trying to save a preset from the front panel of the pedal while you’re connected to EDM? If so, EDM won’t register the changes until you close the application and open it up again. This is why if we decide to use EDM, we must work from within EDM only and not touch the pedal in the process.

      CLUBTURBO wrote:
      I can’t use EDM on anything but factory presets on EDM or Pitch Micro. Nothing I saved On Pitch Micro shows

      Make sure the pedal’s MIDI channel is set to OMNI or 1 to make sure EDM is communicating with the pedal. This may be part of the original issue in this post.

      As soon as you choose a preset on EDM that is outside of the top 5, the last two LEDs on the pedal’s preset ladder light up. Does this happen for you? If you then proceed to edit a preset on EDM, the app should prompt you to save your changes in yellow at the top. Does this not happen for you?

    • #158358
      joecozzi
      Moderator
      Eventide Staff
      dirtybuck wrote:
      Yes, I did set it back to 3. it’s also strange that when I would hit the midi footswitch, although the pedal won’t activate, the 5 ladder lights do go on. Weird.

      Is it possible you have saved your presets in a bypassed state? Try re-saving one of them making sure it’s activated when you save it. Recall it. If it continues to not work properly, I would take a look at what kind of messages your controller is sending to the MicroPitch Delay. Sounds like it may be more than just a simple program change.

    • #158364
      joecozzi
      Moderator
      Eventide Staff
      dirtybuck wrote:
      how do I put the info back in the pedal / DM after a reset

      To put the info back in the pedal, click “Restore from File” in EDM and select the .bak file you created when you made your backup. If all you changed before was the MIDI channel, there’s no reason why it would mess with any other settings or commands you’re sending from the MIDI controller.

      dirtybuck wrote:
      2nd, are they working on an update to resolve these issues?

      The issue with the MIDI channel and EDM was fixed more than a week ago. Make sure you’re running EDM version 1.9, the latest one on the website.

Viewing 38 reply threads
  • You must be logged in to reply to this topic.