MicroPitch pedal question

Home Forums Products Stompboxes MicroPitch pedal question

Viewing 6 reply threads
  • Author
    Posts
    • #163806
      udi9
      Participant

      From time to time, when using my MicroPitch pedal, I see the LED of preset 5 flashing.

      Can someone please explain why is it happening?

      I think I read somewhere that it flashes when you change something in the preset, but here it happens even if I’m just using the preset and not touching any knobs.

       

      Thanks!

    • #163807
      joecozzi
      Moderator
      Eventide Staff

      Hmmm, that’s peculiar. Are you using a an expression pedal with your unit?

    • #163808
      udi9
      Participant

      Hi Joe,

      No, not using an expression pedal, but I do have catch-up mode enabled.

      BTW, it happens regardless of the preset I’m using. I can be on preset 1 and still see preset 5’s LED flashing….(it flashes only for a second or two).

    • #163809
      joecozzi
      Moderator
      Eventide Staff

      Aside from blinking when editing a preset, I’m not aware of any reason the LED would behave like this. I recommend contacting support@eventide.com to document the behavior. Perhaps they can troubleshoot what is going on. In the event it’s a faulty LED, the pedal is under warranty.

    • #163810
      udi9
      Participant

      Thank you, Joe.

      I’ve tried recreating the LED’s behavior for 45 minutes, but couldn’t. It seems that it’s just random.

      I’ll try to pay closer attention to every action I do on the pedal, maybe I’ll understand when it’s happening.

      Do you think that maybe I should try a factory reset?

      Other than that the pedal works flawlessly and sounds incredible. One of the best purchases I’ve made in years.

      I’ll also contact support, as you suggested.

      Thanks again!

    • #163811
      joecozzi
      Moderator
      Eventide Staff

      It definitely couldn’t hurt to try both a fresh install of the firmware and a factory reset. Support may even ask you to do that first. Basically, following instructions beginning at 22:51 of this video.

      I’m happy to hear you’re enjoying your MicroPitch Delay!

    • #163813
      udi9
      Participant

      Those videos are fantastic – That’s what made me pull the trigger on this pedal 🙂

      I reinstalled the firmware and did a factory reset. I’ll give it a couple of days and see if the flashing LED is coming back.

      Thanks for your help, Joe!

Viewing 6 reply threads
  • You must be logged in to reply to this topic.