My H9 does not receive midi program change from my AX8 or my ES5

Home Forums Products Stompboxes My H9 does not receive midi program change from my AX8 or my ES5

  • This topic has 8 replies, 3 voices, and was last updated 4 weeks ago by joecozzi
    Eventide Staff
    .
Viewing 8 reply threads
  • Author
    Posts
    • #164723
      56Tone
      Participant

      My H9 does not receive any midi input from either my AX8 or my ES5. I can get my other devices to connect with no problems but my H9 just will not co-operate. I have the midi channels set to ch1 on both units yet no program changes are happening on my other unit it is dead simple they work. H9 not so much. Is there a specific set up I may be missing?

    • #164725
      brock
      Participant

      One common item missed is setting the OUTPUT to THRU.  XMT blocks incoming PC messages.  If I’m not mistaken, there’s also a System setting to RCV program changes.

    • #164726
      joecozzi
      Moderator
      Eventide Staff

      Hello 56Tone,

      As long as the H9 is set to the proper MIDI channel and you’re transmitting on the same MIDI channel from your controller, there should be open communication between the devices. To start troubleshooting, let’s get some obvious questions out of the way:

      Have you tried isolating the H9 with your MIDI controller or AX8 so that it’s the only thing in the chain?

      Are you sure you’re connecting MIDI Out from your controller to MIDI In on the H9?

      Have you tried another MIDI cable?

      Do you have a USB cable hooked up to the H9 by any chance?

       

       

       

    • #164727
      joecozzi
      Moderator
      Eventide Staff

      One common item missed is setting the OUTPUT to THRU. XMT blocks incoming PC messages. If I’m not mistaken, there’s also a System setting to RCV program changes.

      The MIDI output setting doesn’t play a role in interpreting the information the H9 is receiving. XMT does not block incoming messages. It only determines how the H9 will react when it does receive a message – will it retransmit or not.

      RCV.MAP could be a source of confusion if somehow all program changes are set the same for some reason. Might be worth checking out.

    • #164729
      brock
      Participant
      The MIDI output setting doesn’t play a role in interpreting the information the H9 is receiving. XMT does not block incoming messages. It only determines how the H9 will react when it does receive a message – will it retransmit or not. RCV.MAP could be a source of confusion if somehow all program changes are set the same for some reason. Might be worth checking out.
      Joe, you are absolutely correct.  For whatever reason, I have had that assumption locked in my head, ever since my 1st PitchFactor pedal.  Probably because I’ve never used the pedal(s) to XMT any messages.  I stand corrected.
    • #164730
      56Tone
      Participant

      Hi guys thanks for your responses.

      I have tried more than one midi cable, they both work with other units.
      the midi output is set to through.
      I am only wanting to use the H9 in the chain, I tried my old Roland synth to see if my AX8 was sending midi messages correctly which it does. I have sent some screenshots of the H9 settings

      D05FAA74-85F6-4405-AAAA-A2F583D8FA84E7E9DB35-D1A7-455D-9557-2B40012ACE78

      Thanks again 🍻🍻

    • #164731
      joecozzi
      Moderator
      Eventide Staff

      I am only wanting to use the H9 in the chain.

      I understand you want to use the H9 in the chain, but by testing the MIDI controller directly with the H9 we can see if the problem persists. If it does not, then it could be another pedal before the H9 that is the problem.

    • #164732
      56Tone
      Participant

      Hi Again Joe, thanks for your response, I have figured out the problem. The idiot who was setting up the AX8 midi program changes forgot to press save. 🥸🤦‍♂️🤐

      Thanks again mate I will be having words with the idiot🍻🍻🍻

    • #164733
      joecozzi
      Moderator
      Eventide Staff

      I’m happy you solved the problem. Have fun with your rig!

Viewing 8 reply threads
  • You must be logged in to reply to this topic.