OSX Mojave and H9000 – USB Audio not appearing back on computer

Home Forums Products Rackmount OSX Mojave and H9000 – USB Audio not appearing back on computer

  • This topic is empty.
Viewing 4 reply threads
  • Author
    Posts
    • #115157
      Edgar9001
      Participant

      Hi,

      …brought my H9K home to work there and funnily the USB capabilities are not working properly.

      Studio environnment: All USB in and outs behave as they should with a Mac Pro 5.1, Ableton 10, Mac OS X High Sierra, aggretated device there with Motu 24 i/O…

      At home: latest iMac from 2017, OX X Mojave, Ableton 10, aggregated device with NI Audio Kontrol 2, USB IN works but USB Out none are working, despite the meters in the H9K displaying USB Output signal(s).

      I can route into the H9K via USB but have to connect then to Analog Out to hear the effect…

      H9000 software updatet to latest version today via the internet.

      kinda puzzled,

      Edgar.

    • #151020
      jbamberg
      Moderator
      Eventide Staff
      Edgar9001 wrote:
      Hi, …brought my H9K home to work there and funnily the USB capabilities are not working properly. Studio environnment: All USB in and outs behave as they should with a Mac Pro 5.1, Ableton 10, Mac OS X High Sierra, aggretated device there with Motu 24 i/O… At home: latest iMac from 2017, OX X Mojave, Ableton 10, aggregated device with NI Audio Kontrol 2, USB IN works but USB Out none are working, despite the meters in the H9K displaying USB Output signal(s). I can route into the H9K via USB but have to connect then to Analog Out to hear the effect… H9000 software updatet to latest version today via the internet. kinda puzzled, Edgar.

       

      Mojave has been working fine for me (apart from Dante) but admittedly I have a much simpler setup.  We will see if we can replicate this problem tomorrow.  Perhaps it's related to the aggregate device.

       

    • #151021
      Edgar9001
      Participant

      HI,

      the problem persists even if I make the H9000 the only audio interface in my Mac. All USB Out meters in the H9000 display signal going out to all 16 USB – but none are arriving in Ableton on my Mac. Ableton 10 or 8, no difference here.

      Kind regards, Edgar.

    • #151025
      jfirlik
      Moderator
      Eventide Staff

      There is a trick to getting the USB audio to work, I'm not sure if this is the problem that you're experiencing but it's worth a shot.

      From the H9000 FAQ:

      When switching to a new sample rate, you should first change the H9000’s sample rate, then change the computer’s sample rate. The audio will be muted if the sample rates don’t match. If you switch the computer’s sample rate first (e.g. by loading a session with a different sample rate), you will have to change the H9000’s sample rate, then change the computer’s sample rate again once the H9000’s clock is locked to the new rate.

      • #151029
        Edgar9001
        Participant
        jfirlik wrote:

        There is a trick to getting the USB audio to work, I’m not sure if this is the problem that you’re experiencing but it’s worth a shot.

        From the H9000 FAQ:

        When switching to a new sample rate, you should first change the H9000’s sample rate, then change the computer’s sample rate. The audio will be muted if the sample rates don’t match. If you switch the computer’s sample rate first (e.g. by loading a session with a different sample rate), you will have to change the H9000’s sample rate, then change the computer’s sample rate again once the H9000’s clock is locked to the new rate.

         

        …this is not the issue here… audio is received by the H9000 and going out to USB as per its meters… but not arriving in Ableton

      • #151031
        jbamberg
        Moderator
        Eventide Staff
        Edgar9001 wrote:

        …this is not the issue here… audio is received by the H9000 and going out to USB as per its meters… but not arriving in Ableton

        Granting Ableton the permission to access the microphone fixed this for me.  See:

        https://discussions.apple.com/thread/8562503?answerId=34114960022#34114960022

        It seems that Mojave treats all audio inputs as "Microphone" for the purposes of access control.

        Please let us know if this fixed it for you.

         

        Show More...
        Show Less...
      • #151033
        Edgar9001
        Participant
        jbamberg wrote:

        Edgar9001 wrote:

        …this is not the issue here… audio is received by the H9000 and going out to USB as per its meters… but not arriving in Ableton

        Granting Ableton the permission to access the microphone fixed this for me.  See:

        https://discussions.apple.com/thread/8562503?answerId=34114960022#34114960022

        It seems that Mojave treats all audio inputs as “Microphone” for the purposes of access control.

        Show More...

        Please let us know if this fixed it for you.

         

        Hi, yes, this was the problem- now the H9000 works as it should and I can concentrate again on exploring this fantastic machine. Thanx for quick help, Kind regards, Edgar

        Show Less...
    • #151028
      Edgar9001
      Participant

      Hi,

       

      it is not the issue with muted audio due to mismatch in sample rate – in this case no signal would go into the H9000 via USB

      See screenshot plus two photos from the H9000 Input/Output Meters …

       

Viewing 4 reply threads
  • You must be logged in to reply to this topic.