Pedal Ultratap stuck after updating

Home Forums Products Stompboxes Pedal Ultratap stuck after updating

  • This topic is empty.
Viewing 1 reply thread
  • Author
    • #157890
      Eventide Staff

      Let’s try manually putting the pedal in update mode.

      Disconnect the power supply from the pedal. Make sure you’re connected to your computer via USB. Don’t open up EDM just yet.

      Simultaneously press the TAP footswitch and LED button above it while reconnecting the power supply. The LEDS should blink on the pedal indicating you are in update mode.

      Open up EDM, and try reinstalling the latest firmware.

      Let me know if the pedal works.

    • #116506


      I just tried to update my Ultratap pedal with the Eventide Device Manager on a mac. I selected the latest firmware (1.0.3 I think) and press Update. Then the pedal disappeared from the Device Manager and the pedal is stuck with the Top / Right Led blinking continuously.

      Since the pedal does not respond and is not detected by the Device Manager anymore. If I disconnect, switch off and on the pedal, it does not change a think. The Led carries on blinking. I tried a factory reset but no luck.

      Any help ?


Viewing 1 reply thread
  • You must be logged in to reply to this topic.