Pitchfactor update utility fails while “writing” on three difficult computers, unit doesn’t work now

Home Forums Products Stompboxes Pitchfactor update utility fails while “writing” on three difficult computers, unit doesn’t work now

  • This topic is empty.
Viewing 2 reply threads
  • Author
    • #108123

      I just brought home my new Pitchfactor today and eagerly hooked up the USB port to update the software on the unit. Everything seems fine, it goes to Erase, done, goes to Write then I get "Failed updating device PF-02375. Error updating device. Please reboot your device and try updating again. I reboot, it crashes instantly. I reboot holding the middle button putting it into update mode, try again, same problem. I have ran the update utility on my  pc's desktop, pc laptop and on my macbook pro. I get the same error with all of them. I tried another usb cable, same error. 

      Unfortunately my pedal no longer functions. Rebooting the pedal with the middle footswitch and encoder pressed in yields no results either. Sad

    • #122699


      If you have followed the troubleshooting tips on the top of the forum and the unit is brand new…and has not been previously registered I would contact support ….. support@eventide.com

      you could try an initialize, hold down the middle switch and encoder whilst powering on.


      then try another flash.



    • #122700

      Thanks for the tips but I did try both suggestions. Holding down the encoder and the middle footswitch is not working. The only thing that does work is pressing down the middle footswitch alone while powering off/on the unit. It then goes into update mode. However many times I try to update, however, it gets to the writing phase and randomly goes anywhere from 1-9% complete and then fails… also, on the pedal it flashes "BAD !!!" right when the updater fails. I've tried it on multiple computers on multiple platforms with multiple USB cables, read the forums, have thoroughly gone through the trouble shooting steps posted, double checked MIDI CLK OUT is off.

      Perhaps a bad sector in the flash memory that's preventing it from completing the "write" mode. At any rate, I've rebooted and re-initialized the installation at least 40 times now without it getting any further than 9%. I'm thinking I may have bricked the unit. I'll see if guitar center will exchange it tomorrow (though they'd probably freak out if I mentioned anything about updating firmware). 

Viewing 2 reply threads
  • You must be logged in to reply to this topic.