PitchFactor user has some issues..!

Home Forums Products Stompboxes PitchFactor user has some issues..!

  • This topic is empty.
Viewing 1 reply thread
  • Author
    • #110878

      Hello everybody,

      I got the PitchFactor 4 months ago and I've been very pleased with it. Being said that, I've been having certain issues that need to be fixed and I haven't been able to find a way to do it. These issues if not fixed can be a deal breaker for me.

      I'd appreciate it if any of you could help me sort these problems out.

      1) When I first got the pedal, after turning it on, it would automatically be on the last preset and mode used.

      For some reason, a few weeks ago it started loading in the same preset and mode every time (Preset 46:1 on PLAY mode). It doesn't matter which preset I'm using or if I'm running it on BANK mode, it always starts on preset 46:1 and PLAY mode.

      That wouldn't be very important if it wasn't for the fact that last night I noticed that it's not saving the changes I'm doing to the system. Last night during soundcheck I got another AUX SW so I was assigning the AUX SW functions. It worked fine. After soundchek I turned the pedalboard off. When I turned it back on the AUX SW wasn't working as needed. After doing several tests I finally realized that whenever I turn the unit off all the changes made in SYSTEM MODE are lost and it goes back to the previous settings. Note: These are not even default settings. These are some settings I saved some time ago.  

      Out of curiosity I tried to modify a preset and then save it. When I'm about to press the Save button for the second time the screen shows a weird pattern and the pedal freezes. So, basically I cannot change or save any new presets!!!

      Do you know what is going on with that?

      2) I downloaded the 'Eventide Update Utility' thinking that the problem may be fixed by updating the software. Well, the software doesn't recognize the pedal ("No Eventide MIDI devices could be located, etc, etc"). I'm using the same USB cable that I use with my Lexicon audio interface on a Lenovo laptop running Windows 7 64 bit.

      3) After that I downloaded the 'Factor Lib'. The idea was to save my presets and then reset the pedal and upload my presets back on it. Well, the software doesn't recognize the pedal as an audio device or anything.

      Is there any way to fix these issues? Is there another way  to backup my presets or update the software? What's going on?

      I've used a bunch of different products (amps, pedals,etc) with my laptop through USB connections and this is the first time I've encountered issues like these. I extensively use this pedal in my shows (14 to 16 per month)  so I'm in desperate need of fixing this out. 

      Your help and input will be truly appreciated.

      Thank you,


    • #124411
      Eventide Staff

      Make sure you are using the Eventide power supply.

      If you are using the supplied unit it could be faulty – contact support@eventide.com with your full information.

Viewing 1 reply thread
  • You must be logged in to reply to this topic.